LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 04-27-2008, 08:26 PM   #1
BigRedBall
LQ Newbie
 
Registered: Feb 2008
Posts: 7

Rep: Reputation: 0
X.org problems: black screen on 8.04 after Ubuntu boot process


Hi all,
Just upgraded from Ubuntu 7.10 to 8.04 desktop using the GUI package updater.

Getting a black screen just after the normal Linux boot process when using the normal kernel (so it goes black right where X should load and I should get the autologin sequence).

In this black screen, I'm not able to ctrl-f1 to a shell - it's completely dark, and unresponsive.

I've tried booting into the recovery mode kernel, and running 'xfix', which certainly writes a new /etc/X11/xorg.conf and allows me to boot - but it's only a fix good until a reboot. The default set-up still doesn't work.

I'm using an Asus P5KPL-VM with the built-in Intel GMA 3100 graphics and a Dell 15" monitor.

Any ideas?

Thanks in advance.
 
Old 04-28-2008, 01:42 AM   #2
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
My Dell Inspiron 1420n has Intel X3100 video. I've had no problems with 7.04 or 7.10 with Ubuntu built by Dell. Perhaps http://linux.dell.com/wiki/index.php/Ubuntu_7.10 or http://linux.dell.com/wiki/index.php/Ubuntu_8.04 can be of help.
 
Old 04-28-2008, 07:46 AM   #3
el amigo*
Member
 
Registered: Dec 2006
Location: República Dominicana
Distribution: CentOS, Scientific Linux
Posts: 122

Rep: Reputation: 15
I had that funny issue as well, due to the proprietary Nvidia drivers... What I did was booting Hardy and selecting "recovery mode" in the Grub menu. Then choose the "fixX" options, and it just worked for me... I actually zapped the closed source drives and gave me back the Free one... I am sticking to it, as long as I don't hear from a fix...
 
Old 04-28-2008, 10:41 AM   #4
BigRedBall
LQ Newbie
 
Registered: Feb 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by el amigo* View Post
I had that funny issue as well, due to the proprietary Nvidia drivers... What I did was booting Hardy and selecting "recovery mode" in the Grub menu. Then choose the "fixX" options, and it just worked for me... I actually zapped the closed source drives and gave me back the Free one... I am sticking to it, as long as I don't hear from a fix...
Thanks, El Amigo.

I actually ran fixX through the recovery mode, and while it did generate a new xorg.conf and allowed me to continue booting, after a restart into normal mode, I get the black screen again.

Hmm.

 
Old 05-13-2008, 05:17 PM   #5
Killerchief
LQ Newbie
 
Registered: May 2008
Distribution: Ubuntu
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by BigRedBall View Post

I actually ran fixX through the recovery mode, and while it did generate a new xorg.conf and allowed me to continue booting, after a restart into normal mode, I get the black screen again.

I had the same problem. Solved by a workaround: simply I changed ubuntu studio bootsplash with the classic ubuntu splash screen.
I don't know why but for me it worked.
Hope to be helpful.
 
Old 06-26-2009, 05:43 AM   #6
dipinkrishna
LQ Newbie
 
Registered: Oct 2008
Posts: 3

Rep: Reputation: 0
Blank screen after boot process in Ubuntu

You may encounter a blank screen after boot in ubuntu. This will be due to some update of certain packages.
Follow the steps at blog.dipinkrishna.info/2009/06/blank-screen-after-boot-process-in.html to correct the problem...
 
Old 06-26-2009, 05:44 AM   #7
dipinkrishna
LQ Newbie
 
Registered: Oct 2008
Posts: 3

Rep: Reputation: 0
blank screen after boot in ubuntu

You may encounter a blank screen after boot in ubuntu. This will be due to some update of certain packages.
Follow the steps at blog.dipinkrishna.info/2009/06/blank-screen-after-boot-process-in.html to correct the problem...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 11:52 AM
screen goes black when trying to run ubuntu live cd BehindUsDidnt Linux - Newbie 2 09-03-2008 02:56 AM
Installing Ubuntu (black screen) Starius Linux - Newbie 4 01-17-2008 12:46 PM
Ubuntu 7.04 won't start - black screen... jamiepane Ubuntu 2 09-08-2007 01:41 AM
Ubuntu Edgy - black screen on reboot tiger.woods Ubuntu 4 01-25-2007 05:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 07:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration