Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 10-08-2013, 04:03 PM   #1
Registered: Nov 2010
Posts: 114

Rep: Reputation: 6
Wifi in windows 8 not working after disabling wireless in ubuntu 12.04

I have a dual boot system with Ubuntu 12.04 installed within windows 8 (C drive).

Wifi was working fine, both in ubuntu and windows until yesterday, when I disabled wireless in ubuntu by unchecking the "Enable Wireless" button from the top panel. I wasn't aware that this option was bugged. It went grey after unchecking it, so I couldn't click on it to re-enable it. I looked up for solution to turn the wireless back on and I found a solution.

I followed the steps below:
Use the command "rfkill unblock all".
Uncheck "Enable Networking" from the top panel.
Check "Enable Networking" from the top panel.
Check "Enable Wireless" from the top panel.

The wifi is working in ubuntu after that. However, I cannot enable wifi in windows.

The following image shows that the Wifi is off.

The following image shows that Wifi adapter is enabled and the diver is working fine.

So I guess I need the "rfkill unblock all" equivalent command in windows to fix this. Any other solution which you think can fix this will be also be appreciated.
Old 10-08-2013, 04:07 PM   #2
Registered: Aug 2012
Distribution: Ubuntu 10.04, CentOS 6.3, Windows 7
Posts: 262

Rep: Reputation: 55
Just to be 100% sure, you don't have any physical switch turned off for wireless right?
Old 10-08-2013, 05:43 PM   #3
Registered: Nov 2010
Posts: 114

Original Poster
Rep: Reputation: 6
Originally Posted by YankeePride13 View Post
Just to be 100% sure, you don't have any physical switch turned off for wireless right?
Its on. The light is on and if it was a hardware issue I wouldnt have wifi connections in Ubuntu.
Old 10-12-2013, 09:53 AM   #4
Mr. Bill
Registered: Mar 2011
Location: Maryland, USA
Distribution: Xubuntu 14.04 - 64
Posts: 185

Rep: Reputation: 14
Your problem may or may not be related to your activity on Ubuntu; quite frankly, I don't see how that would even work. My son-in-law has W8 on his laptop, and he had the same issue repeatedly until he found this:

In the first image, you should be able to right-click the wifi icon, or in the window in the second, select it to turn it on. Once on and connection is re-established, be sure to find and check the box for "Connect on Start-Up" or something similar. For some strange reason, it is unchecked by default.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless isn't working on Ubuntu, It does it at Windows 20deoctubre Linux - Networking 1 10-14-2012 03:11 PM
why is my wireless working slower on ubuntu than when i use windows? simonsur Linux - Wireless Networking 3 01-26-2012 06:18 PM
[SOLVED] wireless not working after disabling from networkmanager applet in fedora 15 and b43 bluesatbridge Linux - Wireless Networking 4 11-02-2011 11:28 AM
[SOLVED] Wireless Internet fine on Windows, not working with neither Fedora nor Ubuntu!!! Help mprogrammer Linux - Newbie 8 05-24-2011 08:47 AM
Ubuntu 9.04 can't connect to wifi with Intel Wireless WiFi Link 5100 Shinbatsu Linux - Networking 3 08-30-2009 01:55 AM > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 05:31 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration