LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-14-2010, 10:26 AM   #1
basheer
Member
 
Registered: Mar 2009
Location: Bangalore, India
Distribution: slackware 13.1, Centos 5.5, Ubuntu 10.10
Posts: 173

Rep: Reputation: 29
ubuntu10.10 there is no volume in tvtime


Hi I was using ubuntu 10.04 and tvtime was working perfectly. But after I upgared it to 10.10, I cannot adjust the volume. The Volume shows zero. There is no sound at all. The right arrow key is not increasing the volume. I tried many ways but to no avail. Does anyone have a solution for this. Thanx in advance.
 
Old 10-14-2010, 04:58 PM   #2
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Depending on your TV card, volume may have a different hardware control. Mine uses line in. Sound Preferences, Hardware tab may show two devices, make sure the TV isn't off. This may not be your problem but worth mentioning here. Comcast upgraded basic TV service and an adapter box is required. With that box, TV volume is controlled by the box and the remote that came with it. Changing volume on the computer has no effect on volume with this Comcast service.
 
Old 10-14-2010, 11:08 PM   #3
Kenarkies
Member
 
Registered: Nov 2007
Location: South Australia
Distribution: Ubuntu 11.10
Posts: 77

Rep: Reputation: 23
Quote:
Originally Posted by basheer View Post
Hi I was using ubuntu 10.04 and tvtime was working perfectly. But after I upgared it to 10.10, I cannot adjust the volume. The Volume shows zero. There is no sound at all. The right arrow key is not increasing the volume. I tried many ways but to no avail. Does anyone have a solution for this. Thanx in advance.
Welcome, new recruit to Linux sound wars, which don't seem to ever end. What TV card do you have? Do you have a mixer app and does it show any inputs muted? Mixer apps seem to have gone away in stock Ubuntu distributions so you may need to install one. Otherwise the command line "alsamixer --view all" may help.

Ken
 
Old 10-16-2010, 09:34 AM   #4
basheer
Member
 
Registered: Mar 2009
Location: Bangalore, India
Distribution: slackware 13.1, Centos 5.5, Ubuntu 10.10
Posts: 173

Original Poster
Rep: Reputation: 29
Unhappy

Hi Kenarkies, I installed all the alsa packages using synaptic but to no avail. I have the Phillips saa7134 card. It was working fine in ubuntu 10.04 though I had to modprobe the card as "modprobe saa7134 card=81 tuner=51 alsa=1". I don't know how to get the sound.
 
Old 10-18-2010, 02:50 AM   #5
Kenarkies
Member
 
Registered: Nov 2007
Location: South Australia
Distribution: Ubuntu 11.10
Posts: 77

Rep: Reputation: 23
Quote:
Originally Posted by basheer View Post
Hi Kenarkies, I installed all the alsa packages using synaptic but to no avail. I have the Phillips saa7134 card. It was working fine in ubuntu 10.04 though I had to modprobe the card as "modprobe saa7134 card=81 tuner=51 alsa=1". I don't know how to get the sound.
The saa7134 is the chip rather than the card name. According to http://linuxtv.org/wiki/index.php/Saa7134-alsa you shouldn't need to use alsa=1, but apparently it is optional. Try something like:

Code:
 dmesg|grep -i saa713|grep -i alsa
and make sure alsa is being loaded. You should see something like

Code:
[   25.101854] saa7134 ALSA driver for DMA sound loaded
[   25.101891] saa7133[0]/alsa: saa7133[0] at 0xddeff800 irq 19 registered as card -2
I assume you have TV showing correctly, just no sound. I also assume you have the normal Ubuntu sound working.

Ken
 
Old 11-10-2010, 03:11 PM   #6
Rodemire
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Rep: Reputation: 0
Good day everyone,

I have the same problem. I've used tvtime since 9.10 perfectly, when I used it with Maverick the volume just won't move from 0 no matter what I do.

The DMA drivers are loaded, my Ubuntu sound is working for everything else. And on 'Sound preferences' the input meter detects sound from the tv card (I use Line in from the tv card to the main soundcard). So the problem is that tvtime just doesn't want to have its volume increased hence I can't listen to tv programs.

Any help anyone?

Regards,

Rodemire.
 
Old 11-10-2010, 03:12 PM   #7
Rodemire
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Rep: Reputation: 0
Good day everyone,

I have the same problem. I've used tvtime since 9.10 perfectly, when I used it with Maverick the volume just won't move from 0 no matter what I do.

The DMA drivers are loaded, my Ubuntu sound is working for everything else. And on 'Sound preferences' the input meter detects sound from the tv card (I use Line in from the tv card to the main soundcard).

I can watch tv fine. So the problem is that tvtime just doesn't want to have its volume increased hence I can't listen to tv programs.

Any help anyone?

Regards,

Rodemire.
 
Old 11-11-2010, 04:53 PM   #8
Kenarkies
Member
 
Registered: Nov 2007
Location: South Australia
Distribution: Ubuntu 11.10
Posts: 77

Rep: Reputation: 23
Check this bug report to see if it applies to your situation. It may already provide a solution.

https://bugs.launchpad.net/ubuntu/+s...me/+bug/650693

Ken
 
Old 11-14-2010, 02:34 PM   #9
midhat
Member
 
Registered: Aug 2009
Location: bosna
Distribution: ubuntu
Posts: 42

Rep: Reputation: 15
i have that problem on pclinuxos .
try to change in
/etc/tvtime/tvtime.xml
this value="/dev/mixer:line"/> to line1


<!--
This sets the mixer device and channel to use. The format is device
name:channel name. Valid channels are:
vol, bass, treble, synth, pcm, speaker, line, mic, cd, mix, pcm2,
rec, igain, ogain, line1, line2, line3, dig1, dig2, dig3, phin,
phout, video, radio, monitor
-->
<option name="MixerDevice" value="/dev/mixer:line"/>
 
Old 11-14-2010, 03:16 PM   #10
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Ubuntu has that file but I believe it's use is only for running tvtime the first time. It's comments are of great value but I believe the file you wish to change is ~/.tvtime/tvtime.xml in your home folder.
 
Old 11-15-2010, 02:37 AM   #11
midhat
Member
 
Registered: Aug 2009
Location: bosna
Distribution: ubuntu
Posts: 42

Rep: Reputation: 15
if you open ~/.tvtime/tvtime.xml you will see that there is no mixer device setings .
here is my
<tvtime>
<option name="DefaultBrightness" value="-1"/>
<option name="DefaultContrast" value="-1"/>
<option name="DefaultSaturation" value="-1"/>
<option name="DefaultHue" value="-1"/>
<option name="PrevChannel" value="9"/>
<option name="Channel" value="8"/>
<option name="FramerateMode" value="0"/>
<option name="OverScan" value="3.5"/>
<option name="CheckForSignal" value="1"/>
<option name="AudioBoost" value="90"/>
<option name="AlwaysOnTop" value="0"/>
<option name="QuietScreenshots" value="0"/>
<option name="UnmuteVolume" value="15677"/>
<option name="Muted" value="0"/>
<option name="V4LInput" value="1"/>
<option name="AudioMode" value="mono"/>
<option name="PalDKMode" value="0"/>
<option name="Norm" value="PAL"/>
<option name="Frequencies" value="europe"/>
<option name="Matte" value="4:3"/>
</tvtime>

so you must edit /etc/tvtime/tvtime.xml
 
Old 06-20-2011, 03:51 AM   #12
RifRaf1961
LQ Newbie
 
Registered: Oct 2009
Distribution: Ubuntu 10.04.2 LTS
Posts: 4

Rep: Reputation: 0
TVTime sound fix

Hi fellow Ubuntu users,
The answer to the problem isn't hard as you're making it. I spent a few hours fiddling with the different setup files without success. TVTime worked fine for me in 8.04 LTS, but when I installed 10.04.2 LTS the new version of TVTime had video and no sound (like everyone else here). First open TVTime (make sure the volume is up enough), then open your sound mixer. If you are like me, you'll have to install one. I chose "Gnome ALSA Mixer". You may get errors when you run it, but you can ignore them (it still works fine). Simply push the sliders up one at a time until you hear the sound from the TV. Obviously make sure nothing has mute selected (except PC speaker).

I actually fixed mine from the command line with the bogus ALSA mixers Lucid installed, but I went back and did it as described above to make it easier to explain and for you to do. My speakers have a strange plug setup. It turned out I needed to turn up the mic to hear it. Go figure...
 
Old 11-15-2012, 12:13 AM   #13
jmlm-1970
LQ Newbie
 
Registered: Nov 2012
Posts: 1

Rep: Reputation: Disabled
TVtime volume slide starts working.

This makes the volume slide goes up and down, but sound can still be missing.

Try:

cat /proc/asound/cards

Then the result will be something like:

0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at xxxxxxxxxxxx
1 [EasyALSA1 ]: easycapdc60 - easycap_alsa
easycap_alsa

Then just type (if your video is the 0 change video1 to video0):

tvtime-configure --device=/dev/video1 --mixer=/proc/asound/EasyALSA1:monitor

Then type:

tvtime -v

and when the key + and - is pressed the slide will go up and down, if still no sound is because the mixer=device:channel is for OSS, the ALSA way is device/channel but I do not know yet what is the equivalent, because the path needs / and also the separator between device and channel.
 
Old 02-05-2013, 04:24 PM   #14
davis68nf
LQ Newbie
 
Registered: Feb 2013
Posts: 1

Rep: Reputation: Disabled
SOLVED!

I had trouble with my tvtime too. HVR-850 sent a video, but there was no audio. The volume was set at 0 and would not move.

---------------------------------------

In a nutshell, type:
sudo gedit /etc/tvtime/tvtime.xml
and change the line:
<option name="MixerDevice" value="/dev/mixer:vol"/>

So, my tvtime.xml now reads:
<option name="MixerDevice" value="HVR850:vol"/>

The OLD code used to read:
<option name="MixerDevice" value="default/Line"/>
 
Old 02-15-2013, 06:13 PM   #15
lshantz
LQ Newbie
 
Registered: Oct 2011
Location: Phoenix, AZ
Distribution: Opensuse
Posts: 19

Rep: Reputation: Disabled
Guys, for some of us, there is more to it. If you do a search for sox tvtime, it will show up. I just posted results there.
http://www.linuxquestions.org/questi...0/#post4892621 and scroll up.


I did some experimenting around and came up with:

sox -S -t alsa hw:0,0 -d -G

This allows for sound for, but still no volume control.

later: I found that xfce4-mixer allowed me to turn on sound, making the above obsolete. But now I can't get it to load. I am getting:

xfce4-mixer: Failed to initialize xfconf: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I have screwed up my kmixer volume control and need to tweak it. Anybody know how to fix this?

Last edited by lshantz; 02-16-2013 at 09:54 AM. Reason: additional info
 
  


Reply

Tags
tvtime


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu10.04: cd-rom not mounting Sjonnie48 Ubuntu 14 09-16-2010 04:13 AM
Vmware 7.0.1 in Ubuntu10.04 - issues with 3D noneofthecharacters Linux - Virtualization and Cloud 2 09-11-2010 01:49 AM
how to configure oracle10g in ubuntu10.04 starbala2008 Linux - Software 2 07-09-2010 02:16 PM
[SOLVED] laptop cant find web with ubuntu10. dean adams Linux - Newbie 2 05-24-2010 07:27 PM
TVTIME default volume Warlon Linux - Software 1 03-08-2006 06:59 PM


All times are GMT -5. The time now is 02:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration