LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 01-10-2019, 07:36 AM   #1
Sarcutus
LQ Newbie
 
Registered: Jan 2019
Posts: 12

Rep: Reputation: Disabled
Trying to boot Ubuntu in UEFI mode, UEFI doesn't recognize boot devices


I have tried several times to boot Ubuntu 18.10 Cosmic Cuttlefish in UEFI mode. My trouble started with installing Ubuntu -- I had to switch to Legacy mode to get my computer to recognize the LiveUSB with Ubuntu on it. When I tried booting from a DVD or LiveUSB of Ubuntu in UEFI mode, I got the message that booting from those devices wasn't supported. I had Windows 10 installed at the time.

So I installed Ubuntu in Legacy mode, wiping Windows.

Now when I switch to UEFI, my machine won't recognize ANY bootable devices -- not either SSD, not the LiveUSB, nothing. I can't seem to get UEFI to work, and I can't switch Ubuntu from Legacy to UEFI mode. Is there something I'm missing? Should I even keep trying? Is UEFI really that much better than Legacy?

I've also tried using a boot-repair LiveUSB to separate the EFI partition, but boot-repair wants me to start it in UEFI mode, and when I hit F12 to choose which device to boot from, I get NO OPTIONS. The UEFI firmware doesn't recognize ANYTHING. I can only reach devices in Legacy mode.
 
Old 01-10-2019, 01:23 PM   #2
dna9
Member
 
Registered: Nov 2004
Location: Colorado
Distribution: Ubuntu mostly...
Posts: 78

Rep: Reputation: 28
what BIOS do you have - AMI, Phoenix, etc.? also what brand of computer - Dell, HP, etc.? let's start there.
 
Old 01-10-2019, 02:33 PM   #3
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 4,466
Blog Entries: 11

Rep: Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544
It's also worth examining your EFI system partition to see if you actually have GRUB there, because a UEFI chip in its native mode doesn't look at the mbr. Boot in legacy mode, mount the ESP on /boot/efi and check its contents. There should be a grub directory containing a file with a name like grub64.efi or boot64.efi. If these aren't present, you need to install them.
Code:
sudo grub-install /dev/sda --target=x86_64-efi
 
Old 01-10-2019, 04:24 PM   #4
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 989

Rep: Reputation: 261Reputation: 261Reputation: 261
Quote:
Originally Posted by hazel View Post
It's also worth examining your EFI system partition to see if you actually have GRUB there, because a UEFI chip in its native mode doesn't look at the mbr. Boot in legacy mode, mount the ESP on /boot/efi and check its contents. There should be a grub directory containing a file with a name like grub64.efi or boot64.efi. If these aren't present, you need to install them.
Code:
sudo grub-install /dev/sda --target=x86_64-efi
If Ubuntu was installed in legacy mode and Windows was wiped out, there is no EFI partition and thus Ubuntu cannot be booted in UEFI mode.
 
Old 01-10-2019, 04:28 PM   #5
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 989

Rep: Reputation: 261Reputation: 261Reputation: 261
Quote:
Originally Posted by hazel View Post
It's also worth examining your EFI system partition to see if you actually have GRUB there, because a UEFI chip in its native mode doesn't look at the mbr. Boot in legacy mode, mount the ESP on /boot/efi and check its contents. There should be a grub directory containing a file with a name like grub64.efi or boot64.efi. If these aren't present, you need to install them.
Code:
sudo grub-install /dev/sda --target=x86_64-efi
If Ubuntu was installed in legacy mode and Windows was wiped out, there is no EFI partition and thus Ubuntu cannot be booted in UEFI mode unless the installer was specifically directed to install in the Windows partition and leaving the EFI partition.
 
Old 01-10-2019, 05:37 PM   #6
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 9,061

Rep: Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938
If you have boot repair, run it with the Create BootInfo Summary option and post a link to the output here so we have something to work with. Did you read the Ubuntu documentation on the subject at the link below?

https://help.ubuntu.com/community/UEFI
 
Old 01-10-2019, 11:03 PM   #7
Sarcutus
LQ Newbie
 
Registered: Jan 2019
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by dna9 View Post
what BIOS do you have - AMI, Phoenix, etc.? also what brand of computer - Dell, HP, etc.? let's start there.
BIOS is InsydeH20 (I'm assuming from the BIOS menu header). Computer is Acer E5-575-33BM.

I have the drive partitioned as Master Boot Record right now. I tried repartitioning the drive to GPT, and I managed to get Ubuntu installed in UEFI mode, but then when I tried starting up -- no bootable device. Once again, UEFI refused to recognize any boot devices, including LiveUSB drives. And then when I tried to boot up in Legacy, I got the same message. I can't use boot-repair because it nags me to run it in UEFI mode to repair the boot, and when I switch to UEFI mode, UEFI refuses to recognize the USB drive I have boot-repair on. So I can't get GRUB installed.

It's of note that the InsydeH20 BIOS menu recognizes all my devices. UEFI is what stubbornly refuses to recognize ANY media I could boot from. It ran fine with Windows, but doesn't want to play nice with Linux.

Thank you all for bothering to address my struggles with this machine. I appreciate the advice.
 
Old 01-11-2019, 06:49 AM   #8
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 9,061

Rep: Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938
Was your windows 10 UEFI or do you know? If it was installed when purchased, it was almost certainly UEFI.

How old is your Acer? Newer Acer computers require you to set Trust in the BIOS before you can install other than the pre-installed windows. I believe the first step is to set a Supervisor password in the BIOS. You might check your Acer user manual.

Did you read the link below which has the official documentation on dual booting with windows 10 UEFI. Would have been a better choice to start with if you wanted to keep windows.

https://help.ubuntu.com/community/UEFI

If you cannot boot your boot repair iso, can you boot the Ubuntu DVD/USB you used to install Ubuntu? If you can do that, you can run some commands to get info to post here such as: sudo parted -l OR sudo fdisk -l

Again, if you can boot the Ubuntu install media, I would suggest you go to the boot repair site while booted into Ubuntu and use the 2nd option to get boot repair using the ppa since, according to Ubuntu it is more up to date than the iso version. If you can do this, do NOT try to make any repairs but select the option to Create BootInfo Summary and post a link to the output here.
 
1 members found this post helpful.
Old 01-11-2019, 08:33 AM   #9
Sarcutus
LQ Newbie
 
Registered: Jan 2019
Posts: 12

Original Poster
Rep: Reputation: Disabled
My Windows 10 was UEFI.

I'm not sure how old my Acer is. I got a certified refurbished Acer. I don't have a user manual. It has a core i3 7100 processor in it. So it's not an up-to-date rig, exactly.


I was able to install Ubuntu on the hard drive in Legacy mode with a Master Boot Record partition (confusing -- I'd think newer operating systems would work better with GPT). That's what I'm operating now. How do I set Trust in the BIOS? I have set a Supervisor password. Every time I try to access the BIOS, it prompts me for the pass and I enter it.


I can't boot ANYTHING in UEFI mode. It refuses to see any boot devices. So I can't boot from a USB, I can't boot from a hard drive, I can't boot from anything.

I'm considering leaving UEFI mode alone and just continuing to run in Legacy mode. I was thinking of putting Windows 10 on the other hard drive and running it on occasion, but I like Ubuntu so much I'm wondering if there's a point. Are there advantages to UEFI that I don't know about?

The only problem is that occasionally my computer gets stuck when trying to power down, and I have to power it down manually. Would booting in UEFI mode fix this?
 
Old 01-11-2019, 01:01 PM   #10
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 9,061

Rep: Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938
If you have Ubuntu installed in Legacy mode, are you using msdos partitioning or GPT? If you have GPT, you need an unformatted bios-grub partition of 1MB or more near the beginning of the drive. More info at the link in my last post.

I don't know how you would set trust in the BIOS with your Acer. Generally, if you know the model of the computer you should be able to find an online manual for it.

When you access the BIOS, do you see any references to UEFI/EFI? If not the machine may be old enough that it is not EFI capable.

I doubt using UEFI if possible would resolve your issue of failing to power down.
 
1 members found this post helpful.
Old 01-11-2019, 05:00 PM   #11
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 989

Rep: Reputation: 261Reputation: 261Reputation: 261
Quote:
Originally Posted by Sarcutus View Post
My Windows 10 was UEFI. Are there advantages to UEFI that I don't know about?
UEFI was designed to address BIOS limitations, the only advantage in your case would be if you want to run your Windows 10 which likely has pre-installed Acer bloatware software. Most of the Acer software can be downloaded and installed from their website.

You can download for free from Microsoft a current version 1809 Windows 10 ISO and install it in Legacy mode, your product key which is embedded in the UEFI firmware will activate it as long as you install same version you had before. Then you can install whatever Acer apps you want or need to have same functionality as the previous installation. If I remember correctly, in Legacy mode, Windows typically needs to be in the first partition.

In your case, there is no advantage having GPT over Dos partitioning, a partition is a partition no matter what scheme you choose.
 
1 members found this post helpful.
Old 01-11-2019, 07:14 PM   #12
Sarcutus
LQ Newbie
 
Registered: Jan 2019
Posts: 12

Original Poster
Rep: Reputation: Disabled
I don't have to worry about partitions. I have two SSD drives now, and I can give Windows its very own drive to live in. But at this point, I probably won't. I REALLY like Linux. There's nothing I can do with Windows that I can't do with Linux. Thanks for all the advice.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mobo only supports uefi boot - how do I boot off a non-uefi cd? Ulysses_ Linux - Hardware 3 02-25-2016 08:06 PM
Xandros 3.x doesn't recognize USB2 wireless devices rusty2 Linux - Wireless Networking 6 02-25-2006 11:43 AM
Dell BIOS often doesn't recognize devices any more! blue penguin General 3 11-13-2005 06:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 06:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration