LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 10-23-2019, 04:34 AM   #1
phyotay3
LQ Newbie
 
Registered: Oct 2019
Posts: 8

Rep: Reputation: Disabled
SPAN and PSM in MANETs


Which Ubuntu version is suitable for ns-2.28?
I have patches that only runs on ns-2.28.

These are patches
1. ns2.28-span-gcc4.patch
2. ns2.28-gcc4-configure-scripts.patch
for SPAN and PSM for energy efficency in mobile ad hoc network.

I need to run these protocols for my thesis.
I tried with Ubuntu 18.04 and Ubuntu 9.10.
But i got too many errors in installation of ns-2.28 in Ubuntu after patching.



Please help me.

Last edited by phyotay3; 10-23-2019 at 04:38 AM.
 
Old 10-23-2019, 09:13 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 22,079

Rep: Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889
Quote:
Originally Posted by phyotay3 View Post
Which Ubuntu version is suitable for ns-2.28?
I have patches that only runs on ns-2.28.

These are patches
1. ns2.28-span-gcc4.patch
2. ns2.28-gcc4-configure-scripts.patch
for SPAN and PSM for energy efficency in mobile ad hoc network.

I need to run these protocols for my thesis.
I tried with Ubuntu 18.04 and Ubuntu 9.10.
But i got too many errors in installation of ns-2.28 in Ubuntu after patching.

Please help me.
Since you don't tell us what the errors are, there's not a lot we can suggest. You started off saying you were using Windows 10 and cygwin (which isn't something Linux related), and now you're asking about Ubuntu? Did you INSTALL Ubuntu? Because 9.10 is ancient, and you mention 18.04....which is it?

And you need to read the LQ Rules about posting duplicate threads, and the "Question Guidelines". Do basic research first, such as performing a search, as this question has been asked and answered MANY times on this site:
https://www.linuxquestions.org/quest...0-04-a-842773/
 
1 members found this post helpful.
Old 10-23-2019, 09:28 AM   #3
phyotay3
LQ Newbie
 
Registered: Oct 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
Sorry for my mistakes and thanks u for guiding me sir.
 
Old 10-23-2019, 09:34 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 22,079

Rep: Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889Reputation: 5889
Quote:
Originally Posted by phyotay3 View Post
Sorry for my mistakes and thanks u for guiding me sir.
Again, read the LQ Rules, and pay attention to the part about not using text-speak. If you are working on your thesis, you should know how to spell "please" and "you".

You still haven't told us what errors you were getting or what version of Ubuntu you installed (or even if you DID install it). We cannot help if you don't post details and ask a clear question. It is very possible that your 18.04 Ubuntu errors can be fixed, but we don't know that unless you give us details.

Last edited by TB0ne; 10-23-2019 at 09:35 AM.
 
1 members found this post helpful.
Old 10-23-2019, 11:48 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2019 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,297

Rep: Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573
@phyotay3

According to these posts, #5, #8 of 02-22-13, span may be OK with Ubuntu 8.04 - i386 (32bit)
https://www.linuxquestions.org/quest...-4175434724/#5

Besides that, SPAN was run with CentOS 5 - i386 : 02-22-13.
Result : span-ns-2.28-1.el5_i386.deb (3.8MB)
https://drive.google.com/file/d/0B7S...ew?usp=sharing
... Which can be installed to Ubuntu 18.04 :
Code:
sudo gdebi Downloads/span-ns-2.28-1.el5_i386.deb
         ## Some 32bits packages will be installed too
Provides /usr/local/bin/ns-span
and /usr/local/lib/libpcap.so.0.9.4
Note : You may have to copy `libpcap.so.0.9.4´ to /usr/lib/.
-----
span-2.28-patch.tar.gz
https://drive.google.com/file/d/11r9...ew?usp=sharing
Ref. https://knowledgehurts.wordpress.com...2-and-gcc-4-3/
. https://pdos.csail.mit.edu/~benjie/span/span_ns.html

-

Last edited by knudfl; 10-23-2019 at 12:08 PM.
 
1 members found this post helpful.
Old 10-23-2019, 03:25 PM   #6
phyotay3
LQ Newbie
 
Registered: Oct 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
How can i sovle this?
Attached Thumbnails
Click image for larger version

Name:	Screenshot (22).png
Views:	6
Size:	148.5 KB
ID:	31613  
 
Old 10-23-2019, 03:37 PM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2019 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,297

Rep: Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573
I made a test with Ubuntu 16.04 - amd64 → → ns-2.28 + SPAN :
ns-allinone-2.28 + ns228-gcc41-64_2016-1.patch + span-2.28-patch.tar.gz.
OK with $ export CC=gcc34 CXX=g++34 && ./install : No errors.
ns2 patches https://drive.google.com/drive/folde...00?usp=sharing


Ref. https://www.linuxquestions.org/quest...-a-4175662982/
Quote:
couldn't read file "tcl/lib/ns-mobilenode.tcl": no such file or directory
I did
Code:
cd /home/knudfl/
ln -s ns2/SPAN/ns-allinone-2.28/

Last edited by knudfl; 10-23-2019 at 09:33 PM.
 
Old 10-23-2019, 06:59 PM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2019 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,297

Rep: Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573
Re #6.

»»You should avoid posting pictures of text. Pictures can be hard to read. Text is easier to read in different screen formats, can be copied and pasted, as well as is search engine addressable, making it easier for people to reach this post who may have a similar issue.««
... My comment: I guess you know how to copy-paste a text.


Code:
$ perl run-span.pl tcl/mobility/scene/600-600-n120-0-t600-m1-p60-e0-r10.scen -stop 120
No errors here. Please install `tcsh´: sudo apt-get install tcsh

-

Last edited by knudfl; 10-23-2019 at 10:11 PM.
 
1 members found this post helpful.
Old 10-23-2019, 09:42 PM   #9
phyotay3
LQ Newbie
 
Registered: Oct 2019
Posts: 8

Original Poster
Rep: Reputation: Disabled
I have done it in Ubuntu 9.10.
Thank u very much sir.
 
Old 10-24-2019, 06:08 AM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2019 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,297

Rep: Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573Reputation: 3573
An updated ns-allinone-2.28.2.tar.xz for a contemporary OS
https://drive.google.com/file/d/1fHT...ew?usp=sharing

Example, Ubuntu 18.04 - amd64 → → gcc-3.4.6 compilers required :
compat-gcc34-3.4.6-ubuntu1204-1_amd64.deb ( Ubuntu 12* .. 19.04 - 64 )
https://drive.google.com/file/d/0B7S...ew?usp=sharing
compat-gcc-34-c++_3.4.6-20_amd64.deb
https://drive.google.com/file/d/0B7S...ew?usp=sharing

Testing with Ubuntu 18.04 - amd64 :
perl run-span.pl tcl/mobility/scene/600-600-n120-0-t600-m1-p60-e0-r10.scen -stop 120
* The files /tmp/{span.out, span.stdout, span.tr} are created :
* span.out 1.7MB, span.stdout 4.8kB, span.tr 24.6MB .

* Same result with the ns2 reference OS = PCLinuxOS 2019.

-

Last edited by knudfl; 10-24-2019 at 06:30 AM.
 
1 members found this post helpful.
  


Reply

Tags
ns2, span, span-psm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running SPAN protocol on ns2 !! errors !! Hi, I am trying to SPAN protocol on ns2.28 using cygwin on windows 10 phyotay3 Linux - Wireless Networking 2 10-23-2019 09:11 AM
how to install span and psm in ns2 2.34 popoaung Linux - Software 8 04-08-2013 01:17 PM
code for wormhole attack in MANETs maria_seb Linux - Software 3 10-26-2012 03:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 04:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration