LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 09-09-2007, 11:09 AM   #1
rrrssssss
Member
 
Registered: Mar 2005
Posts: 287

Rep: Reputation: 33
USB Devices Fail To Mount - They Worked Fine Yesterday


Hello forum,

All of my USB devices have suddenly failed to mount (two USB hard drives and a card reader). I am running openSUSE 10.2

When I try to mount any of them, I get the message "Cannot lookup privilege from PolicyKit".

They seem to have stopped working when I installed a few programs yesterday, the Hewlett Packard Office jet HPOJ driver, xine gui media player, and the Main Actor video editor.

So I uninstalled all three of those programs but the problem still persists.

When I stop and restart the policykitd service (/etc/init.d/policykitd stop/start), the error message changes to "hal-storage-removable-mount refused uid 1000" but when I reboot the computer, I get the original error message all over again.

When I run "resmgr dump" in a root terminal window, this is the results:

Code:
linux-6cp2:/home/roy # resmgr dump
### begin dump
class desktop-console
class audioplayer
class pda
class scanner
class modem
class camera
class usb
class floppy
class cdrom
class input
class video
class sound
class v4l
class dvb
class remote-x-desktop
class desktop
class desktop includes dvb
class desktop includes v4l
class desktop includes sound
class desktop includes video
class desktop includes input
class desktop includes cdrom
class desktop includes floppy
class desktop includes usb
class desktop includes camera
class desktop includes scanner
class desktop includes pda
class desktop includes audioplayer
class desktop includes desktop-console
login "roy" :0
grant "roy" desktop
grant "roy" dvb
grant "roy" v4l
grant "roy" sound
grant "roy" video
grant "roy" input
grant "roy" cdrom
grant "roy" floppy
grant "roy" usb
grant "roy" camera
grant "roy" scanner
grant "roy" pda
grant "roy" audioplayer
grant "roy" desktop-console
### end dump
linux-6cp2:/home/roy #
If I run resmgr in a root terminal window, nothing happens after waiting a few minutes. I just get a non blinking cursor.

All of this is unfamiliar territory for me so I am asking if somebody would be kind enough to try to help me get my USB devices (hard drives) to working again.

Thanks in advance,
Roy

Last edited by rrrssssss; 09-09-2007 at 11:19 AM.
 
Old 09-09-2007, 02:01 PM   #2
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
Try "rcpolicykitd start" in a root shell.
 
Old 09-09-2007, 02:27 PM   #3
rrrssssss
Member
 
Registered: Mar 2005
Posts: 287

Original Poster
Rep: Reputation: 33
That Didn't Work Either

Thanks for the reply but I tried "rcpolicykitd stop/start" in a root shell and the end results were the same, meaning I got the second error message. And when I rebooted the computer, I got the first error message.

I have noticed that when I run either "policykitd stop/start" or "rcpolicykitd stop/start, the USB drives will mount ONLY if I log out of X and log back in X as a root user. But when I log out of root X and log back into X as a regular user, I get the same error message all over again.

I've also noticed that I have lost write access to the NTFS partitions I have mounted from the internal hard drives. OpenSUSE enabled write privledges by default on NTFS partitions when everything was working alright.

I have broken something somewhere and don't know what.

Please don't give up on this thread. I'm willing to go through great lengths to get this fixed.

Thanks,
Roy

Last edited by rrrssssss; 09-09-2007 at 03:46 PM.
 
Old 09-10-2007, 08:08 AM   #4
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
Do an "rpm -V PolicyKit", "rpm -V resmgr", "rpm -V pam-config" and "rpm -V xorg-x11" as root. In my system they return nothing and everything works. Also, what is the version of Xorg you have (rpm -q xorg-x11)?

Last edited by auxsvr; 09-10-2007 at 08:09 AM.
 
Old 09-10-2007, 12:48 PM   #5
rrrssssss
Member
 
Registered: Mar 2005
Posts: 287

Original Poster
Rep: Reputation: 33
Still Trying

Thank you for the response and expertise.

I ran those commands in the root terminal and the results are below:

roy@linux-6cp2:~> su
Password:
linux-6cp2:/home/roy # rpm -V PolicyKit
linux-6cp2:/home/roy # rpm -V pam-config
linux-6cp2:/home/roy # rpm -V resmgr
linux-6cp2:/home/roy # rpm -V xorg-x11
linux-6cp2:/home/roy # rpm -q xorg-x11
xorg-x11-7.2-26
linux-6cp2:/home/roy #

Appariently nothing is missing from those four packages and my version of xorg is 7.2-26

Typing dmesg in a terminal window said two of my ntfs partitions were dirty from my internal hard drives (not the USB hard drives). I have a multiboot configuration. So I booted into WindowsXP and Windows automatically did a chkdsk on those same two partitions without any user intervention from me so they must have really been in bad shape for some reason. After booting back into openSUSE, the dmesg warning went away and I re-gained write access to one of those ntfs partitions where it was lost before. I did not gain write access to the other ntfs partition due to improper flag settings according to dmesg. I don't know this has anything to do with me not being to mount my USB devices but I thought I would mention it anyway.

Any more suggestions would be greatly appreciated,
Roy

Last edited by rrrssssss; 09-10-2007 at 12:55 PM.
 
Old 09-10-2007, 01:55 PM   #6
ngjunkie0011
Member
 
Registered: Jun 2005
Location: New York
Distribution: Ubuntu Studio
Posts: 105

Rep: Reputation: 15
I have seen the same error before but I forgot how I fixed it.

These are the things that I tried but I don't know which one did it.

1. Disconnect all USB devices from my pc.

2 Shut down machine. I made sure my USB IDE card was properly seated in the motherboard.

3. Turn machine on.

4. Log in, then connected my USB drive. Powered it on.


I --create a new user.
II --log out then login as the new user

After I did that I was able to see USB devices, which one fixed it? Your guess is as good as mines.
 
Old 09-10-2007, 03:11 PM   #7
rrrssssss
Member
 
Registered: Mar 2005
Posts: 287

Original Poster
Rep: Reputation: 33
Didn't Work

Hello ngjunkee0011,

Regretfully, after trying both possibilities, neither of them fixed my problem. I did not unplug my USB mouse, however. Would that have to be unplugged also?

My USB card is most probably seated correctly since everything works fine in the other Linux distributions (multi-boot) so I didn't check that.

I'm open to any ideas,
Roy

Last edited by rrrssssss; 09-10-2007 at 03:17 PM.
 
Old 09-10-2007, 03:28 PM   #8
RHAPOLLO
LQ Newbie
 
Registered: Oct 2006
Location: TX, US
Distribution: Fedora12
Posts: 13

Rep: Reputation: 0
Hi,

I am not a SUSE user .. however, conceptually speaking, this problem happened after you installed those 3 rpms .. Sounds to me that they overwrote or changed some modules related to the loadable usb modules. I cannot claim that this may be the problem, but I would try to unload and reload the usb-storage and the uhci_hcd modules (or whatever equivalent for SUSE). Try a command to list the currently loaded modules e.g. /sbin/lsmod also try to see exactly the contents of those rpms using something like e.g. rpm -ql <rpm-name> | grep "lib" | less

I hope this may help a little bit .. Please let me know ..
 
Old 09-10-2007, 07:51 PM   #9
ngjunkie0011
Member
 
Registered: Jun 2005
Location: New York
Distribution: Ubuntu Studio
Posts: 105

Rep: Reputation: 15
Quote:
Originally Posted by rrrssssss View Post
Hello ngjunkee0011,

Regretfully, after trying both possibilities, neither of them fixed my problem. I did not unplug my USB mouse, however. Would that have to be unplugged also?

My USB card is most probably seated correctly since everything works fine in the other Linux distributions (multi-boot) so I didn't check that.

I'm open to any ideas,
Roy

OK, read this:


http://www.suseforums.net/index.php?showtopic=29302
 
Old 09-11-2007, 07:15 AM   #10
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
Also do a "rpm -V hal" and type "groups" in a console as roy, not as root.
 
Old 09-11-2007, 10:26 AM   #11
rrrssssss
Member
 
Registered: Mar 2005
Posts: 287

Original Poster
Rep: Reputation: 33
Terminal Readout

Here is my non root terminal readout with those two commands:

roy@linux-6cp2:~> rpm -V hal
S.5....T /etc/PolicyKit/privilege.d/hal-storage-removable-mount-all-options.privilege
S.5....T c /etc/dbus-1/system.d/hal.conf
.......T /etc/udev/rules.d/90-hal.rules
roy@linux-6cp2:~> groups
users root dialout video
roy@linux-6cp2:~>

Thanks for your continued help,
Roy
 
Old 09-12-2007, 05:01 AM   #12
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
The quick way is to reinstall the hal package from the opensuse distribution media or server, provided that you didn't intentionally make these changes to these files. If you made them intentionally, then you need to show us the content of these files. Most likely the HP program you installed made these changes, what is the filename of the package and where did you get it from? I have installed the other programs and they cause no problem to my system.
 
Old 09-12-2007, 06:40 AM   #13
rrrssssss
Member
 
Registered: Mar 2005
Posts: 287

Original Poster
Rep: Reputation: 33
Printer Driver

All I know about the printer driver is that the tarball version is called hpoj-0.91.tgz but I actually installed the rpm version from the graphical package manager.

I also know this driver creates an entry in the services manager (a running process) called ptal, which might interact with HAL, I'm not sure right now.

I plan to uninstall and reinstall HAL soon if all else fails.

Thanks,
Roy
 
Old 09-12-2007, 07:40 AM   #14
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
Unless I missed something, the hpoj project is dead since 2005 and the last suse version it supported is 8.2, so installing the hpoj package was a bad idea. It has been replaced with the hplip project, so you need to check whether your printer is supported there, assuming it isn't supported by opensuse 10.2, and install the relevant package. Opensuse 10.2 includes hplip-1.6.10.

Last edited by auxsvr; 09-12-2007 at 10:08 AM.
 
Old 09-12-2007, 11:44 AM   #15
ngjunkie0011
Member
 
Registered: Jun 2005
Location: New York
Distribution: Ubuntu Studio
Posts: 105

Rep: Reputation: 15
Quote:
Originally Posted by auxsvr View Post
The quick way is to reinstall the hal package from the opensuse distribution media or server, provided that you didn't intentionally make these changes to these files. If you made them intentionally, then you need to show us the content of these files. Most likely the HP program you installed made these changes, what is the filename of the package and where did you get it from? I have installed the other programs and they cause no problem to my system.
There's your quick fix. You can do that using YaST or with whatever packager you're using, I'm using smart nowadays, I finally got rid of zen!!!

You could also try adding the following lines to this file: /etc/dbus-1/system.d/hal.conf

Quote:
<policy user="root">
<allow own="org.freedesktop.Hal"/>
</policy>

<!-- Allow anyone to invoke methods on the Manager and Device interfaces -->
<policy context="default">
<allow send_interface="org.freedesktop.Hal.Manager"/>
<allow send_interface="org.freedesktop.Hal.Device"/>
<allow receive_interface="org.freedesktop.Hal.Manager"
receive_sender="org.freedesktop.Hal"/>
<allow receive_interface="org.freedesktop.Hal.Device"
receive_sender="org.freedesktop.Hal"/>

<allow send_interface="org.freedesktop.Hal.Device.SystemPowerManagement"/>
<allow send_interface="org.freedesktop.Hal.Device.LaptopPanel"/>
<allow send_interface="org.freedesktop.Hal.Device.Volume"/>
<allow send_interface="org.freedesktop.Hal.Device.Volume.Crypto"/>
<allow receive_interface="org.freedesktop.Hal.Device.SystemPowerManagement"
receive_sender="org.freedesktop.Hal"/>
<allow receive_interface="org.freedesktop.Hal.Device.LaptopPanel"
receive_sender="org.freedesktop.Hal"/>
<allow receive_interface="org.freedesktop.Hal.Device.Volume"
receive_sender="org.freedesktop.Hal"/>
<allow receive_interface="org.freedesktop.Hal.Device.Volume.Crypto"
receive_sender="org.freedesktop.Hal"/>
</policy>
Check your conf file first to see if you have "root" and "default user" in your policy. This info is on the link I gave you and I believe it should work. I would rather reinstall the hal package as auxsvr suggested, it sounds much safer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installed puppy on usb flash drive, worked fine glorsplitz Puppy 8 09-30-2008 10:19 AM
ipodder worked yesterday not today pennyg Linux - Desktop 1 11-07-2006 01:31 PM
DOOM3 worked yesterday, doesn't today NetRAVEN5000 Linux - Games 9 10-22-2005 06:25 PM
startx -- :1.0 worked yesterday but today.. slackist Linux - General 3 05-12-2005 10:35 AM
lost my audio, worked good yesterday. mimsmall Fedora 4 05-06-2004 10:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration