LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 10-09-2006, 02:11 AM   #1
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Rep: Reputation: 31
Question Permission denied when I try to see the files on my CD ROM


Hi,

I am trying to resolve the problem I have encountered recently. I insert CD ROM into drive and it is correctly recognised when I open My Computer. But when I try to see files on the CD I get the "Permission denied" message. How can I repair this??
 
Old 10-09-2006, 02:29 AM   #2
Samotnik
Member
 
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
RTFM!
man mount
(put umask=0444 in /etc/fstab)
 
Old 10-09-2006, 02:59 AM   #3
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Hi samotnik,

I put that into my fstab but it is not working. The same message appears when I try to see files on my CD.
 
Old 10-09-2006, 06:26 AM   #4
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,286

Rep: Reputation: 62
Can you post the contents of your /etc/fstab file
 
Old 10-09-2006, 06:40 AM   #5
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Here it is:

/dev/hda3 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdb1 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/hda2 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
/dev/hdc /media/dvdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
 
Old 10-09-2006, 07:52 AM   #6
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,286

Rep: Reputation: 62
Quote:
Originally Posted by riba43
/dev/hdc /media/dvdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
I had the same problem with slackware 10.0 all I did was to add user to the fstab file and it allowed the current user to have permission to mount and read from the cd. You can add this to all the cd/dvd drive in the fstab file, place it before the noauto setting:

Code:
/dev/hdc             /media/dvdrecorder   subfs      user,noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdd             /media/dvd           subfs      user,noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
 
Old 10-09-2006, 08:08 AM   #7
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Hi fotoguy,

Thanks, I tried that but now I am getting the following error msg:

mntent]: warning: no final newline at the end of /etc/fstab
mount: unknown filesystem type 'subfs'
 
Old 10-09-2006, 06:24 PM   #8
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,286

Rep: Reputation: 62
Quote:
Originally Posted by riba43
Hi fotoguy,

Thanks, I tried that but now I am getting the following error msg:

mntent]: warning: no final newline at the end of /etc/fstab
mount: unknown filesystem type 'subfs'

OK you need to have a blank line at the end of the file

Code:
/dev/hda3 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdb1 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/hda2 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
/dev/hdc /media/dvdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
    <-- blank line here
Without the blank line it cannot read the last line properly
 
Old 10-10-2006, 12:56 AM   #9
Samotnik
Member
 
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
mntent]: warning: no final newline at the end of /etc/fstab
mount: unknown filesystem type 'subfs'

The blank line at the end, and change subfs to auto
 
Old 10-10-2006, 01:11 AM   #10
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
Hi guys,

Thanks a lot for your help. I tried what you proposed. But I always get error messages. So I search a bit in LQ an found the following:

Its the last lines you want to remove, specifcally /media/cdrom or whatever is the equivalent on your system.

At this point the auto mounter takes charge of the devices and mounts them when you put a disk in.
,

and it works. I do not need even to reboot.
 
Old 10-10-2006, 02:08 AM   #11
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,286

Rep: Reputation: 62
OK glad to hear it all sorted out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Permission Denied while coping files busaussie Linux - General 5 01-05-2006 11:26 AM
permission denied on .htaccess files in Apache scott.anderson Linux - Software 3 12-16-2005 12:19 PM
permission denied for root in FC4: why can't I modify own files? ixis Linux - General 4 12-10-2005 06:05 PM
Python CGI script can't write files, permission denied The_Nerd Programming 4 03-17-2005 12:19 PM
permission denied! floppy cd-rom dvd-rom HELP! OMEGA-DOOM Linux - Software 17 10-15-2004 05:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 04:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration