LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 10-31-2007, 10:30 AM   #1
DeekBeek
Member
 
Registered: Mar 2005
Distribution: Ubuntu 14.04 LTS 64-bit
Posts: 127

Rep: Reputation: 15
openSUSE 10.3 not presenting a user login screen..


Have I found a bug? I have my main non-root user set up to have to log in with a password (I re-checked it in YaST). Linux is starting without presenting a login prompt, and booting straight to my main non-root user desktop; anyone experiencing this?
 
Old 10-31-2007, 10:53 AM   #2
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
Make sure you don't have some sort of auto-login feature enabled.
 
Old 10-31-2007, 11:33 AM   #3
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
As suggested by win32sux, it looks like you have auto-login enabled and maybe you enabled it at installation time. To check open Yast --> Security and Users --> User Management. Look for Expert Options near the bottom and select Login Settings. Uncheck Auto Login (if enabled) and the trick is done!
 
Old 10-31-2007, 12:10 PM   #4
DeekBeek
Member
 
Registered: Mar 2005
Distribution: Ubuntu 14.04 LTS 64-bit
Posts: 127

Original Poster
Rep: Reputation: 15
Thanks for the more specific answer, colucix. Problem solved (for some reason, auto-login was checked under expert options, as if that were the default). I still think it's bizarre, though, because I didn't specify it during install, yesterday. I'm still thinking bug(s).
Now. I'll just go tinker with kdm, which is what I "fixed" the problem with before I read what colucix posted. kdm has a tab that will stop/enable auto-login, also; but using it results in an extra splash screen, which I might just want to punt out.
 
Old 10-31-2007, 01:48 PM   #5
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
Moved to Suse/Novell, as this discussion is pretty distro-specific.

Last edited by win32sux; 10-31-2007 at 01:49 PM.
 
Old 10-31-2007, 07:33 PM   #6
gabebster
Member
 
Registered: Jun 2003
Location: Oklahoma
Distribution: Gentoo
Posts: 117

Rep: Reputation: 15
It is an option during the installation, and it is selected by default. I think it defeats the security of your user account if it is enabled.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot Login as User OpenSuSE 10.2 Jakman85 Linux - Software 9 05-08-2008 01:28 PM
Login screen user colors jeucken SUSE / openSUSE 4 01-23-2006 10:36 AM
Hiding user names on the login screen windoze killa Mandriva 2 10-16-2003 06:27 AM
User pics on login screen Ju Deddo Koinu Linux - General 2 07-10-2003 06:19 PM
changing user login screen in rh 7.3 abhicool Linux - Newbie 1 09-18-2002 04:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration