Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 10-12-2007, 09:54 PM   #1
Senior Member
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
NFS server won't mount during boot up - OpenSuSE 10.3

This is really annoying, but I placed an NFS mount in my /etc/fstab and it won't recognize it. But if I do mount -a, then it mounts fine. Never had this problem with Ubuntu or CentOS. Anyone know what's going on?
Old 10-17-2007, 11:02 PM   #2
Registered: Oct 2007
Posts: 75

Rep: Reputation: 15
Can you please post the errors from syslog or dmeg? We'll start there.

Old 10-18-2007, 12:10 AM   #3
LQ Guru
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
You might want to post your /etc/fstab entries as well as the corresponding /etc/exports entries on the target computer. Also look at the _netdev option which will defer mounting networked filesystems until the network is working.

Scanning the logs for messages from kernel:NFSD as suggested above is a good idea. Look in /var/log/messages as well.
Old 10-19-2007, 06:08 AM   #4
LQ Newbie
Registered: Oct 2007
Posts: 6

Rep: Reputation: 0
I had the same problem after an update from 10.2 to 10.3.

Command line solution: chkconfig --add nfs

GUI: YaST2, Network Services, NFS Client (you might have to install the respective yast package first), click Finish.
Old 10-19-2007, 03:51 PM   #5
Registered: Oct 2007
Posts: 53

Rep: Reputation: 15
Having the same problem here. It used to work, but now it stopped working. I reboot so rarely that who knows what change may have caused this :P

jowagner, your solution didn't help. As I said, it used to work, so obviously I have nfs stuff installed.

Here is my fstab:
/dev/sda2 / ext3 acl,user_xattr 1 1
/dev/sda3 /home ext3 acl,user_xattr 1 2
/dev/sda1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0 /mnt/nb cifs user,credentials=/etc/samba/.smbpasswd 0 0
jade:/vol/users /mnt/users nfs defaults 0 0

It used to be that the cifs and the nfs shares were mounted on boot, but now they're not.

When I look in dmesg, here's the relevant section
Adding 586332k swap on /dev/sda1. Priority:-1 extents:1 across:586332k
device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised:
loop: module loaded
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda3, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
AppArmor: AppArmor initialized
audit(1192811455.860:2): type=1505 info="AppArmor initialized" pid=1661
IA-32 Microcode Update Driver: v1.14a <>
powernow: This module only works with AMD K7 CPUs
mtrr: your processor doesn't support write-combining
eth0: link up
NET: Registered protocol family 17
CIFS VFS: Error connecting to IPv4 socket. Aborting operation
CIFS VFS: cifs_mount failed w/return code = -101
audit(1192825924.832:3): audit_pid=3036 old=0 by auid=4294967295
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
Mobile IPv6
ip6_tables: (C) 2000-2006 Netfilter Core Team
ip_tables: (C) 2000-2006 Netfilter Core Team
bootsplash: status on console 0 changed to on
eth0: no IPv6 routers present

It ends there.

Any help appreciated!
Old 10-20-2007, 03:03 AM   #6
LQ Newbie
Registered: Oct 2007
Posts: 6

Rep: Reputation: 0
Hi TiredOfThis,

Do you have a file (symlink) S[0-9][0-9]nfs in /etc/init.d/rc5.d/ (or rc3.d if you are using text mode only)? This is where OpenSuSE would normally mount the NFS volumes. After installing the NFS tools, this entry is still missing. Chkconfig should add it (and renumber the entries to satisfy dependencies).

Regarding dmesg, it wouldn't pop up there. On my 10.3 system "grep nfs" shows a line in /var/log/boot.msg that says "Starting NFS client services: sm-notifyBackgrounding to notify hosts..." and two entries in /var/log/messages saying that sm-notify and statd are running as root. Do you have these lines? You could also try to add some debugging output to /etc/init.d/nfs - something like

LOGGER="/bin/logger -t NFS"
test for x || $LOGGER -p user.alert "could not find x"

for example
[ -x $IDMAPD_BIN] || $LOGGER -p user.alert "could not find idmapd"



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to mount a nfs mount from linux client to AIX nfs server dennyqian AIX 13 04-11-2016 11:30 PM
nfs client does not mount server-shares automatically on boot rsp Debian 2 07-29-2007 07:26 AM
NFS Error during PXE Boot from NFS server JatMan Linux - Enterprise 0 10-16-2006 05:48 PM
mount to NFS server '' failed: server is down. hemant kumar tiwari General 1 06-07-2006 09:09 AM
mount to NFS server '' failed: server is down rblampain Linux - Networking 2 01-14-2005 01:19 AM > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 03:17 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration