LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 02-07-2012, 05:03 AM   #1
devUnix
Member
 
Registered: Oct 2010
Posts: 606

Rep: Reputation: 59
Setting "ulimit" is Not Working and Throwing Errors


Hi,


In order to increase "ulimit" I followed this article as it explains the same error that I receive while doing that on OpenSolaris (my local test box) as well as on Solaris 10 (production box):

http://blogs.oracle.com/hasham/entry...sing_number_of

Here is what I am running:

Code:
bash-3.2# ulimit -u
8021
Code:
bash-3.2# ulimit -u 25000
bash: ulimit: max user processes: cannot modify limit: Invalid argument
Code:
bash-3.2# ulimit -a
core file size          (blocks, -c) unlimited
data seg size           (kbytes, -d) unlimited
file size               (blocks, -f) unlimited
open files                      (-n) 256
pipe size            (512 bytes, -p) 10
stack size              (kbytes, -s) 8480
cpu time               (seconds, -t) unlimited
max user processes              (-u) 8021
virtual memory          (kbytes, -v) unlimited
bash-3.2#
Now setting "pidmax" as suggested in the article:

Code:
bash-3.2# set pidmax=60000
bash-3.2# echo pidmax/D | mdb -k
pidmax:
pidmax:         30000
bash-3.2#
It's not working.


Now setting "maxuprc" as stated in the article:

Code:
bash-3.2# set maxuprc=50000
bash-3.2# echo maxuprc/D | mdb -k
maxuprc:
maxuprc:        8021
It is also not working.

Some guesses:


Code:
bash-3.2# mdb
> maxuprc
mdb: failed to dereference symbol: unknown symbol name
> pidmax
mdb: failed to dereference symbol: unknown symbol name
>

Code:
bash-3.2# ulimit -u
8021
bash-3.2# ulimit -u 30000
bash: ulimit: max user processes: cannot modify limit: Invalid argument
bash-3.2#
Any help?


Side Note: At this point I am not concerned about the ulimit's ideal size or any philosophy behind it. I just need to do that on a production box per the instruction / requirement we have received. But as stated above, it is not working.
 
Old 02-07-2012, 10:37 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Ubuntu/WSL
Posts: 9,781

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Quote:
Originally Posted by devUnix View Post
Now setting "pidmax" as suggested in the article:

Code:
bash-3.2# set pidmax=60000
bash-3.2# echo pidmax/D | mdb -k
pidmax:
pidmax:         30000
bash-3.2#
It's not working.
That is because you are missing to set pidmax (and other tunables) properly. The article you cite tells to set them in the /etc/system file and then reboot for the kernel to get them, not to use the unrelated shell set command.
 
Old 02-07-2012, 11:21 AM   #3
devUnix
Member
 
Registered: Oct 2010
Posts: 606

Original Poster
Rep: Reputation: 59
Quote:
The article you cite tells to set them in the /etc/system file and then reboot for the kernel to get them, not to use the unrelated shell set command.

Not sure, then, why the "set" commands are shown in the article. However, changing "/etc/system" will make system wide changes- for all users. We want to do it for specific users. Besides, a reboot would be required. It's a production box which is not supposed to be rebooted without a change request/control.
 
Old 02-07-2012, 12:48 PM   #4
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Ubuntu/WSL
Posts: 9,781

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Quote:
Originally Posted by devUnix View Post
Not sure, then, why the "set" commands are shown in the article.
Because that's the correct syntax. Why do you think there is a problem with these "set" commands ?
Quote:
However, changing "/etc/system" will make system wide changes- for all users.
Indeed and the article is quite clear these settings are system wide. Three of them do not make sense "per user" anyway.
Quote:
We want to do it for specific users.
Then you might want to investigate resource controls, especially max-lwps.
Quote:
Besides, a reboot would be required. It's a production box which is not supposed to be rebooted without a change request/control.
If you need to raise tunable values than cannot be set dynamically, there is no other way outside rebooting. However, some of these variables looks like to be changeable online using kmdb, although it is always risky doing it on a production system.

By the the way, you missed to pass the correct option to mdb (mdb -k), that's the reason why your mdb commands failed.

Last edited by jlliagre; 02-07-2012 at 02:22 PM.
 
Old 02-08-2012, 12:59 AM   #5
devUnix
Member
 
Registered: Oct 2010
Posts: 606

Original Poster
Rep: Reputation: 59
Quote:
Originally Posted by jlliagre View Post
By the the way, you missed to pass the correct option to mdb (mdb -k), that's the reason why your mdb commands failed.

Could you please point out those incorrect commands the correct them as well?
 
Old 02-08-2012, 08:18 AM   #6
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Ubuntu/WSL
Posts: 9,781

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
You are missing to pass -k to mdb here:
Code:
bash-3.2# mdb
> maxuprc
mdb: failed to dereference symbol: unknown symbol name
> pidmax
mdb: failed to dereference symbol: unknown symbol name
>
 
Old 02-13-2012, 12:26 PM   #7
devUnix
Member
 
Registered: Oct 2010
Posts: 606

Original Poster
Rep: Reputation: 59
Quote:
Originally Posted by jlliagre View Post
By the the way, you missed to pass the correct option to mdb (mdb -k), that's the reason why your mdb commands failed.
Nope. It is there in my OP:

"Now setting "pidmax" as suggested in the article: ..."
 
Old 02-13-2012, 12:27 PM   #8
devUnix
Member
 
Registered: Oct 2010
Posts: 606

Original Poster
Rep: Reputation: 59
Quote:
Originally Posted by jlliagre View Post
You are missing to pass -k to mdb here:
Code:
bash-3.2# mdb
> maxuprc
mdb: failed to dereference symbol: unknown symbol name
> pidmax
mdb: failed to dereference symbol: unknown symbol name
>
I had tried with the "-k" option as well.
 
Old 02-13-2012, 01:04 PM   #9
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Ubuntu/WSL
Posts: 9,781

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
I do not question that but these error messages were caused by the missing "-k" option.

You need to tell at least once how you want the variables to be presented by appending a /D to the variable name, otherwise, nothing is displayed, eg:

Code:
# mdb -k
...
> maxuprc
> maxuprc/D
maxuprc:
maxuprc:      16165
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need another pair of eyes (BASH script throwing a "s-e-n-u-t" error) SilversleevesX Linux - Newbie 6 11-17-2011 09:52 AM
Sendmail unable to start "throwing Error Messeges" sachin_shetty Linux - Server 9 04-08-2011 01:45 PM
LXer: Sheep-Throwing Marsupial in the "Yo Frankie" Game LXer Syndicated Linux News 0 11-20-2008 10:20 PM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 07:11 PM
kernel compilation:throwing error related with sound during "make bzImage" b0nd Linux - Newbie 1 08-19-2005 09:16 AM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 04:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration