LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 08-14-2007, 12:31 PM   #1
Ryzol
Member
 
Registered: Jun 2007
Distribution: Ubuntu, Slackware
Posts: 50

Rep: Reputation: 15
slackware boots into a black screen


Was already multibooting with grub so I didn't install lilo. Other than that, emacs and the kdei I did a full cd1-2 install. This is /boot/grub/menu.lst:
Code:
title		Slackware 12.0, vmlinuz-huge-smp-2.6.21.5-smp	
root		(hd0,6) 
kernel		/boot/vmlinuz-huge-smp-2.6.21.5-smp root=/dev/sda7 ro vga=ask
Slackware appears to boot fine through grub as it is displaying the boot process but after a certain point the screen goes black and stays that way. I don't know if this helps, but this black isn't the black background of a tty, it is the black of powered tv not receiving input.
 
Old 08-14-2007, 01:24 PM   #2
carkju
LQ Newbie
 
Registered: Aug 2007
Posts: 1

Rep: Reputation: 0
slackware boots into a black screen

Quote:
Originally Posted by Ryzol View Post
Was already multibooting with grub so I didn't install lilo. Other than that, emacs and the kdei I did a full cd1-2 install. This is /boot/grub/menu.lst:
Code:
title		Slackware 12.0, vmlinuz-huge-smp-2.6.21.5-smp	
root		(hd0,6) 
kernel		/boot/vmlinuz-huge-smp-2.6.21.5-smp root=/dev/sda7 ro vga=ask
Slackware appears to boot fine through grub as it is displaying the boot process but after a certain point the screen goes black and stays that way. I don't know if this helps, but this black isn't the black background of a tty, it is the black of powered tv not receiving input.
What runlevel your system? You can runleve 3 or 1. Probably your video card not configured.
 
Old 08-14-2007, 03:37 PM   #3
Ryzol
Member
 
Registered: Jun 2007
Distribution: Ubuntu, Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
Okay so how do I tell what my runlevel is and what do I need to do to configure my video card? It is an nvidia go 7600.
 
Old 08-14-2007, 04:45 PM   #4
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,443

Rep: Reputation: 73
You can tell your default run level by looking in /etc/inittab (should be easy to spot using the comments in the file)

By default Slackware goes into run level 3 (multi-user console). However, seeing as how your screen doesn't blank until after the boot process it would seem that it blanks when X starts which would suggest that you are starting in run level 4.

You can setup your video driver using xorgconfig or xorgsetup. They are explained pretty well in the Slackbook.

http://www.slackbook.org/html/x-window-system.html

Edit:
I forgot to mention earlier that if you are in run level 4 and X is not displaying you can switch over to a console on tty6 by pressing ctrl+alt+F6 and login to do your work from there. Run level three should have consoles by default on tty1-6 (F1 thru F6).

Hope that helps.

Last edited by shadowsnipes; 08-14-2007 at 04:49 PM.
 
Old 08-15-2007, 09:44 AM   #5
geek745
Member
 
Registered: Jul 2004
Location: Alton, IL
Distribution: Linux Mint; Slackware; Ubuntu; Slax
Posts: 172
Blog Entries: 2

Rep: Reputation: 34
I had this problem too, and for the life of me, I could not find out what to do. Since you put vga=ask in the parameters, can't you specify which vga setting you want to use? try either 773 (goes to 1024x768@256 colors) or "normal" which usually works. If that is not a problem or doesn't help at all, go in and configure your x server again. use the documentation for your monitor - you'll need the horizontal and vertical refresh rates, and your desired resolution. Run the xorgconfig utility and answer all the questions carefully. look at the card database when it asks you to. install the file to /etc/X11/xorg.conf as it says, then go edit that file. Make copy first.

Go through the whole file but there are only a few things to look for to change. Whatever the monitor's documentation says, enter the horizontal and vertical refresh rates, in the same format as you see in the file. this will prevent your video adapter from putting out the wrong format signal.

Then you will be looking for a section containing the property "Depth" and the block with Depth 24. uncomment the Modes line if it's not already active, and add to the beginning of the modes list, your desired resolution "1280x1024" for example, with the quotes.

The only other option you might want to check is that your scroll wheel on your mouse will work. In the "Core Pointer " section, you'll want to set the mouse protocol to "ImPS/2" and AxisMapping "4 5 6 7" just like that. you should see those options already listed but they may not be correct.

If none of that works, you might need a custom kernel. Welcome to Linux.

a note about virtual terminals... as mentioned before, you should be able to control your computer after it boots by switching to a console on a different virtual terminal. the last line you should see before the screen blacks out is "Starting X11..." or something similar. that indicates that you're going to runlevel 4 (graphical) which by default has only one text console enabled, 6 (Ctrl+Alt+F6). You can change this in the /etc/inittab configuration file. To default to runlevel 3 (6 text consoles and no graphical) change the id:4:default or something like that, just replace the number with whichever number you want (really 3 or 4 because 1 will be a single console, 0 will shutdown immediately and 6 will reboot) If you comment that line it will ask you for it. To enable more consoles in graphical mode, go down where there is a block with something like id:12356: followed by the path to getty or agetty. This creates the login shells on different virtual terminals. just add the number 4 to that string of numbers and you will have all 6 virtual terminals in addition to your graphical console when you get there.
 
Old 08-21-2007, 08:26 PM   #6
Ryzol
Member
 
Registered: Jun 2007
Distribution: Ubuntu, Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
Thanks for the help so far I really appreciate it.

Shadowsnipes:
Default runlevel is 3
I can't switch to a tty, alt+F# doesn't work and neither does alt+ctrl+F# work. Well, okay it could be switching me to a tty but if so the display isn't changing and I don't see any sort of commandline prompt so I don't think I can use xorgconf or xorgsetup. Thankfully I can mount my slack partition in Ubuntu and modify/view system files but I would really like to at least get it booting to a terminal so I don't have to keep restarting it all the time to see if I've gotten it working.
===
geek745:

Setting vga to 773 gives the same result =/

Where would I find the documentation for my laptop's monitor? Also since I already have Ubuntu working on the same laptop can I replace slackware's xorg.conf with ubuntu's as a kludge? What would I need to change?

With adding the virtual terminals, there is only one line that begins with id: and that is id:3:initdefault:, anyways I don't see what you describe so I'm attaching my innittab. Also adding my Ubuntu xorg.conf so you can hopefully tell me how compatible it is.
 
Old 08-21-2007, 08:29 PM   #7
Ryzol
Member
 
Registered: Jun 2007
Distribution: Ubuntu, Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
inittab:
Code:
#
# inittab	This file describes how the INIT process should set up
#		the system in a certain run-level.
#
# Version:	@(#)inittab		2.04	17/05/93	MvS
#                                       2.10    02/10/95        PV
#                                       3.00    02/06/1999      PV
#                                       4.00    04/10/2002      PV
#
# Author:	Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified by:	Patrick J. Volkerding, <volkerdi@slackware.com>
#

# These are the default runlevels in Slackware:
#   0 = halt
#   1 = single user mode
#   2 = unused (but configured the same as runlevel 3)
#   3 = multiuser mode (default Slackware runlevel)
#   4 = X11 with KDM/GDM/XDM (session managers)
#   5 = unused (but configured the same as runlevel 3)
#   6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

# System initialization (runs when system boots).
si:S:sysinit:/etc/rc.d/rc.S

# Script to run when going single user (runlevel 1).
su:1S:wait:/etc/rc.d/rc.K

# Script to run when going multi user.
rc:2345:wait:/etc/rc.d/rc.M

# What to do at the "Three Finger Salute".
ca::ctrlaltdel:/sbin/shutdown -t5 -r now

# Runlevel 0 halts the system.
l0:0:wait:/etc/rc.d/rc.0

# Runlevel 6 reboots the system.
l6:6:wait:/etc/rc.d/rc.6

# What to do when power fails.
pf::powerfail:/sbin/genpowerfail start

# If power is back, cancel the running shutdown.
pg::powerokwait:/sbin/genpowerfail stop

# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

# Local serial lines:
#s1:12345:respawn:/sbin/agetty -L ttyS0 9600 vt100
#s2:12345:respawn:/sbin/agetty -L ttyS1 9600 vt100

# Dialup lines:
#d1:12345:respawn:/sbin/agetty -mt60 38400,19200,9600,2400,1200 ttyS0 vt100
#d2:12345:respawn:/sbin/agetty -mt60 38400,19200,9600,2400,1200 ttyS1 vt100

# Runlevel 4 used to be for an X window only system, until we discovered
# that it throws init into a loop that keeps your load avg at least 1 all 
# the time. Thus, there is now one getty opened on tty6. Hopefully no one
# will notice. ;^)
# It might not be bad to have one text console anyway, in case something 
# happens to X.
x1:4:respawn:/etc/rc.d/rc.4

# End of /etc/inittab
 
Old 08-21-2007, 08:32 PM   #8
Ryzol
Member
 
Registered: Jun 2007
Distribution: Ubuntu, Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
Ubuntu /etc/X11/xorg.conf for the same laptop that I am trying to get slack running on:
Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	Fontpath	"/usr/share/fonts/X11/misc"
	Fontpath	"/usr/share/fonts/X11/cyrillic"
	Fontpath	"/usr/share/fonts/X11/100dpi/:unscaled"
	Fontpath	"/usr/share/fonts/X11/75dpi/:unscaled"
	Fontpath	"/usr/share/fonts/X11/Type1"
	Fontpath	"/usr/share/fonts/X11/100dpi"
	Fontpath	"/usr/share/fonts/X11/75dpi"
	# path to defoma fonts
	Fontpath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load		"i2c"
	Load		"bitmap"
	Load		"ddc"
	Load		"extmod"
	Load		"freetype"
	Load		"glx"
	Load		"int10"
	Load		"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"	"/dev/input/mice"
	Option		"Protocol"	"ImPS/2"
	Option		"ZAxisMapping"	"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"	"/dev/psaux"
	Option		"Protocol"	"auto-dev"
	Option		"HorizScrollDelta"	"0"
	Option 		"SHMConfig"		"true"
	Option 		"MinSpeed"		"1.0"
	Option		"MaxSeed"		"9999999.0"
	Option		"AccelFactor"		"999.0"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"stylus"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"eraser"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"cursor"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"nVidia Corporation G70 [GeForce Go 7600]"
	Driver		"nvidia"
	Busid		"PCI:1:0:0"
	Option		"AddARGBVisuals"	"True"
	Option		"AddARGBGLXVisuals"	"True"
	Option		"NoLogo"	"True"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	Horizsync	28-64
	Vertrefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation G70 [GeForce Go 7600]"
	Monitor		"Generic Monitor"
	Defaultdepth	24
	SubSection "Display"
		Depth	1
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth	4
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth	8
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth	15
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth	16
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth	24
		Modes		"1280x800"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
  screen "Default Screen"
	Inputdevice	"Generic Keyboard"
	Inputdevice	"Configured Mouse"
	Inputdevice	"stylus"	"SendCoreEvents"
	Inputdevice	"cursor"	"SendCoreEvents"
	Inputdevice	"eraser"	"SendCoreEvents"
	Inputdevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection
 
Old 08-22-2007, 11:46 AM   #9
geek745
Member
 
Registered: Jul 2004
Location: Alton, IL
Distribution: Linux Mint; Slackware; Ubuntu; Slax
Posts: 172
Blog Entries: 2

Rep: Reputation: 34
sorry about the inittab - it is the block with lines beginning c1..c6 that I was referring to - you see 1235 for c1..c5 and c6 has 12345 - this means that for console 6, it will get a "getty" terminal for login in runlevels 1-5; you probably want at least a couple more on other virtual consoles. I leave c1 as 1235 so that I can look at the tail end of the init messages quickly, and have c2..c6:12345.

As for the ubuntu xorg.conf file - it should work fine with slackware. it's all the same software, really. Instead of the "Modes" line in the "Display" subsection of the "Screen" section - maybe try "Virtual 1280 800"
maybe also specify "Viewport 0 0" to indicate that the upper left of the screen should be painted beginning at the upper left of your display.

Laptop monitors are usually very standard - you can choose any of the 1024x768 settings in the xorgconfig wizard and it will get you what you need, even if your actual res is bigger - you fix that with Modes or Virtual as I showed you above.

Also, if networking is ok, or you think it is, and you have another machine, you might try logging in via ssh. there are clients for all platforms (putty is best on windows: http://www.chiark.greenend.org.uk/~sgtatham/putty/). telnet might be open too... not as likely though. that would allow you to administer the system directly, while it's running. You might need to use your router's admin utility to determine what the IP address of that computer is so that you can "ssh root@192.168.xxx.xxx" and do what you need to do.
 
Old 08-22-2007, 11:51 AM   #10
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,443

Rep: Reputation: 73
Well you are definitely booting to the console (run level 3), so your xorg.conf file has nothing to do with any of this. Have you tried

vga=normal

By the way you don't need to edit your grub file to do this. At boot time just add the option
Code:
append="vga=normal"
that should do the trick.

So far I think you have been trying to use the framebuffer console and that does not seem to work for you.

If using the plain console does not work it may be that the appropriate modules are not loaded for your monitor. In that case you may have to build a custom kernel (as mentioned previously). You may want to check if there is a wiki or other site devoted towards using linux on your laptop.

I would be surprised if the normal console does not work. Thus far I have never seen that happen.

Here's an exert from my lilo.conf file that shows the various vga settings
Code:
# Normal VGA console
#vga = normal works
# VESA framebuffer console @ 1024x768x64k
# vga=791 does not work
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
In my particular case VGA normal worked and the framebuffers with resolution 800X600 and down worked. This might be the case for you as well. In X, however, my monitor has up to 1024X768 resolution.
 
Old 08-23-2007, 12:42 PM   #11
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 -current
Posts: 2,300

Rep: Reputation: 90
vga=normal should do the trick. Just out of curiosity, what do the last several lines of the dmesg log look like?
 
Old 08-24-2007, 04:54 AM   #12
sleepswim
LQ Newbie
 
Registered: Aug 2005
Location: Oslo, Norway
Distribution: Fedora Core 4
Posts: 1

Rep: Reputation: 0
I have the exact same problem as mentioned here, does anyone know what's wrong ?
I've tried both runlevel 1 and 3. The screen blanks at the end of the boot process, just as if I tried to start X with some wacky config file.
 
Old 08-26-2007, 02:22 PM   #13
Tomás Girardi
LQ Newbie
 
Registered: Aug 2007
Location: Viña del Mar, Chile
Posts: 2

Rep: Reputation: 0
This worked for me

I had the same problem and I solved it this way (the description will be a little long, but that way someone can help us to find where the core of the problem is):

My computer is:
AMD AthlonXP64 +3200
ATI Radeon X800 GTO
Kubuntu 7.04 Feisty

The first strange thing happened when I tried to install Kubuntu 7.04 Feisty; the first menu screen (the one where you can choose to load kubuntu from live cd or boot form the hard disk) appeared, but after pressing the option to run kubuntu from live cd, the screen turned blank and the computer stopped responding to any stimulation.

To solve this, I pressed F4 (vga) the next time the screen appeared (after rebooting) and chose 1024*780 32 bits. The live cd booted just fine, so this was the first sign that something strange was happening related with the video card or some screen resolution configuration.

After installing Kubuntu, I tried to boot in normal mode and exactly the same thing happened. So I thought: "OK... I really have to do something about my video card". After using linux for a few years it is not a mystery for me that ATI video cards tend to be a pain in the ass for this OS.

I booted in recovery mode and everything was working perfectly fine. Evenmore, I was able to start xserver and switch between graphic
interface and ttys consoles (CTRL+ALT+Fx) without problem.

While in recovery mode, I installed my video card driver: fglrx. Rebooted and once again the blank screen in normal boot mode appeared.

I tried the solution involving the vga option in the kernel line of grub's menu.lst:

kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=925045a9-aee8-4850-924b-040d6e2163a3 ro quiet splash vga=773

And it worked! At least that is what I thought. The splash screen appeared, then KDM's login screen appeared and then KDE was working fine. But everytime I switched to a tty console (CTRL+ALT+Fx) the damn blank screen appeared and I was able to do nothing more than rebooting my PC.

I tried various vga options = normal, 771, 790, ask, etc. None of them solved the problem.

So I asked to myself: "What is making the difference between recovery boot mode and normal boot mode? Why does recovery mode works just fine and not normal mode?...Aha!...KDM".

So I remove every reference to KDM in the /etc/init.d/rc file:
update-rc.d kdm remove
(if you want to recover these references use:
update-rc.d kdm defaults 99 01
)

I also changed the kernel line in menu.lst to:
kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=925045a9-aee8-4850-924b-040d6e2163a3 ro
to make it similar to the recovery mode.

And Voilà , normal mode booted, i was able to start xserver with startx command and I could switch to ttys consoles without problem (CTR+ALT+Fx).

The counterpart of this solution is that it is not a very "pretty" one. At startup you will have to login in the tty console prompt and not in the kdm graphic interface login screen. Also, you will have to start the graphic interface with the startx command (however note that you are in multisessions mode and not in single mode).

I am not sure which is the reason for this problem, but could be due to a bug in vmlinuz-2.6.20-15-generic, because a few days later an unexpected solution to this problem came to me. I updated to vmlinuz-2.6.20-16-generic and, at the moment of the update, my menu.lst file was changed to something similar to what came with the installation. When I tried to boot in normal mode the same blank screen appeared once more. I went to recovery mode and changed the kernel line in menu.lst:
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=925045a9-aee8-4850-924b-040d6e2163a3 ro
But this time I didn't remove references to kdm in rc file.

When I booted in normal mode again not only everything worked fine, but also I started the session with the kdm login screen and not the tty prompt.

Last edited by Tomás Girardi; 08-26-2007 at 02:29 PM.
 
Old 08-29-2007, 05:42 AM   #14
Ryzol
Member
 
Registered: Jun 2007
Distribution: Ubuntu, Slackware
Posts: 50

Original Poster
Rep: Reputation: 15
masonm:
vga=normal does not fix it.
Do you mean the dmesg for ubuntu, as I can't get a CLI in slackware. If so the last couple of lines are:
Code:
[   56.096000] NET: Registered protocol family 10
[   56.096000] lo: Disabled Privacy Extensions
[   56.096000] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   56.096000] ADDRCONF(NETDEV_UP): eth1: link is not ready
[   77.636000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[   77.668000] ieee80211_crypt: registered algorithm 'CCMP'
[   77.712000] ieee80211_crypt: registered algorithm 'TKIP'
[   92.616000] eth1: no IPv6 routers present
[ 2393.628000] kjournald starting.  Commit interval 5 seconds
[ 2393.628000] EXT3 FS on sda7, internal journal
[ 2393.628000] EXT3-fs: mounted filesystem with ordered data mode.
Tomas:
Wrong forum? This is slackware not kubuntu, regardless I still appreciate it. Anyways I made new boot entries in grub for each kernel in /boot and none of them worked. All except the 'huge' ones result in a kernel panic and the huge ones create the blank screen problem. /etc/init.d/rc is a symbolic link which to a text file telling me that slackware uses /etc/rc.d/

shadowsnipes:
Set vga=769 and same problem. My laptop is a system76 so I hope I wouldn't have to use a custom kernel as it's supposed to be linux friendly and to their credit all the hardware works out of the box in the included OS (ubuntu). Well their isn't support for the camera or the fingerprint reader but everything else is golden. Here's their wiki. How would I go about making a custom kernel? How difficult is making a custom kernel? As a kludge could I use my ubuntu kernel and if so would that make my slackware distro binary compatible with ubuntu?

geek745:
SSHing in isn't going to help me as I don't know what it is I need to do. Not planning to use my laptop as a server so I need a working screen . Also thanks for the info on inittab it'll be good to have ttys working after fixing this problem.

Last edited by Ryzol; 08-29-2007 at 06:49 AM.
 
Old 08-29-2007, 11:52 AM   #15
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,443

Rep: Reputation: 73
Quote:
Originally Posted by Ryzol View Post
shadowsnipes:
Set vga=769 and same problem. My laptop is a system76 so I hope I wouldn't have to use a custom kernel as it's supposed to be linux friendly and to their credit all the hardware works out of the box in the included OS (ubuntu). Well their isn't support for the camera or the fingerprint reader but everything else is golden. Here's their wiki. How would I go about making a custom kernel? How difficult is making a custom kernel? As a kludge could I use my ubuntu kernel and if so would that make my slackware distro binary compatible with ubuntu?
The Knowledge wiki for the system76 machines is really incomplete!

Making a custom kernel is not hard at all, but it is very time consuming. You first need to know what hardware you have. The wiki isn't much help here, but hopefully you got some documentation from the company. You could email the company to get this information if needed or even use your working OS to discover what all the hardware is. From there you basically untar a kernel source, 'make menuconfig', and select tons of options to create your custom configuration. After that you can 'make bzImage', copy the image to your /boot area and add it to your bootloader. Usually, when creating the config, I look at the help descriptions because there is ALWAYS at least some new thing in the kernel that I don't know what it is. Again, this is very time consuming, but I highly recommend you do it someday if you have never tried it before. The directions I explained above are a brief overview, but there are plenty of online resources that are easy to find.

I don't know if you can use the kernel from Ubuntu for slackware as I am not familiar with the Ubuntu way of doing kernels. You could, however, probably use the same kernel config file to build a kernel. If you don't have a copy of it on your OS you could probably get one from System76. If it is on your machine it will most likely be in /boot. It might be useful to compare the Slackware config from the unbuntu one to see if they have any differences in the hardware configuration. I would be more inclined to simply modify the slackware config to make specific hardware support changes than to simply use the ubuntu config. Otherwise, you still might not know the reason your screen is blanking.

Even if you used the exact same kernel for Ubuntu and Slackware I DO NOT think that the two distros would be binary compatible. The software environment is just too different. Ubuntu software looks for links and stuff in certain places and expects certain libraries to be available. Slackware does the same thing but those places and libraries may be different. You might be able to make your software binary compatible by symlinking and making sure the environment appears the same, but I would be cautious against this. More useful would be to simply share a /home partition so that you can use the same users in both OSs. That might have some problems as well with settings and such if software versions, etc are different.

Try X in runlevel 4
If I were in your position the first thing I would try, based on all of this, is to see if I can even see X on slackware. We already know the console blanks, but if you can at least use X you can manage your system easier using virtual consoles, etc. I think it would be worth it to try setting your runlevel in /etc/inittab to 4 so it would try booting into X.

If you do this you may want to modify /etc/rc.d/rc.4 by commenting out the graphical logins you do not want to use. Slackware doesn't even come with GDM installed, so you definitely can comment that one out. I'd recommend KDM. You can easily pick your window manager from it.

If you can login as root and see the desktop then great, you have something you can finally work with. Then you can create your user, and login X with that to begin your work (just make sure the user is a part of the wheel group so you can su to root). You may not even need the console since you can use the virtual consoles, and if you still want them your system will at least be easier to manage now.

Again, if you still want to look into the custom kernel I would highly recommend taking a long look at the kernel config that works in Ubuntu. I wonder if system76 customized it in any way...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
boots to black screen thing DiabloDan Linux - Newbie 8 12-18-2012 01:12 PM
changed video driver and now boots to a black screen ossnap Linux - Hardware 2 11-30-2006 04:05 PM
Mandriva boots up, but loads to a black screen smurcoch Mandriva 6 05-31-2006 02:04 PM
installation problems, boots to black screen thing DiabloDan Mandriva 2 05-30-2006 04:38 AM
Help! Knoppix almost boots then I get a black screen. Royle Linux - General 1 07-23-2004 08:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 04:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration