LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-13-2021, 01:09 AM   #1
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,790

Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
xscreensaver keeps turning off monitor -current.


This has been happening for a few weeks now and I have ignored it, but it's starting to drive me nuts. about 75% of the time when xscreensaver starts it just powers off my monitor instead of launching screensavers. I am trying to figure out what the culpit could be, X, my monitor, xscreensaver, etc. If anyone has any ideas please let me know.

Thanks.

Last edited by Daedra; 05-13-2021 at 01:17 AM.
 
Old 05-13-2021, 01:27 AM   #2
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,790

Original Poster
Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
Well for whatever reason disabling "fade to black when blanking" has so far made xscreensaver start successfully 15 times in a row. I am not going to mark this as solved yet, but so far that is working. I'll keep an eye on it to see if it starts happening again.
 
2 members found this post helpful.
Old 05-13-2021, 09:30 AM   #3
cwizardone
LQ Veteran
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 6,597
Blog Entries: 1

Rep: Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991
What desktop are you using?
 
Old 05-13-2021, 02:29 PM   #4
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,790

Original Poster
Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
Quote:
Originally Posted by cwizardone View Post
What desktop are you using?
Mate, I have disabled mate-screensaver. But so far that simple fix above is working. IDK why or how that would do anything, but so far so good.
 
Old 05-13-2021, 08:45 PM   #5
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 2,247
Blog Entries: 1

Rep: Reputation: Disabled
Power management causes screen goes black even if there is working scrensaver.
 
Old 05-13-2021, 08:50 PM   #6
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,790

Original Poster
Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
Quote:
Originally Posted by igadoter View Post
Power management causes screen goes black even if there is working scrensaver.
Yeah I have everything set to never, never sleep, never suspend, and never turn off display. It happened again today, I just removed the mate-screensaver package. If that doesn't do it then I will just give up and stop using XscreenSaver. I don't even need a screensaver anyway, I'm just old school that way.
 
Old 05-13-2021, 09:07 PM   #7
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 2,247
Blog Entries: 1

Rep: Reputation: Disabled
I think power-off screen is not only desktop feature. I suspect acpi management - something below desktop. Switch to runlevel 3 - no desktop - and notice does your screen blanks off.
 
Old 05-13-2021, 09:15 PM   #8
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,790

Original Poster
Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
No go, I boot to runlevel 3, always have. The monitor never shuts off in runlevel 3. At least I can't remember a time when it did. I logout of X and leave my home computer in runlevel 3 during the day so I can SSH into from my laptop if I need to. However I usually turn my monitor off. Tonight I will drop it down to runlevel 3 when I go to bed and see if powers off and report back. But like I said this is not that huge of a deal, it could be something simple I am over looking. I am not deep diving into this.
 
Old 05-13-2021, 09:17 PM   #9
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,790

Original Poster
Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
It's also worth mentioning that this is a brand new monitor that is only 3 weeks old. I can't remember if my old monitor did this. I can't rule out that my monitor is causing this, but I don't see any power related settings in the OSD menu.

However the reason I removed mate-screensaver is because it was clobbering xscreensaver and keeping it from starting if mate-screensaver was running. I set a startup command to kill mate-screensaver on X launch but mate-screensaver would eventually relaunch over time. I was going to setup a cron job to periodically kill it, but for not I am just removing it to see if that makes any difference.

Last edited by Daedra; 05-13-2021 at 09:20 PM.
 
Old 05-13-2021, 09:18 PM   #10
cwizardone
LQ Veteran
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 6,597
Blog Entries: 1

Rep: Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991Reputation: 3991
Have you looked at /etc/rc.d/rc.setterm or /etc/rc.d/rc.M
 
1 members found this post helpful.
Old 05-13-2021, 09:28 PM   #11
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,790

Original Poster
Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
Quote:
Originally Posted by cwizardone View Post
Have you looked at /etc/rc.d/rc.setterm or /etc/rc.d/rc.M
No I haven't. but that is a good place to look.

Thanks
 
Old 05-14-2021, 02:04 AM   #12
elcore
Member
 
Registered: Sep 2014
Distribution: Slackware
Posts: 863

Rep: Reputation: Disabled
Quote:
Originally Posted by Daedra View Post
If anyone has any ideas please let me know.
Probably Xorg, see also this thread where dpms and X shutdown timer was discussed.
 
1 members found this post helpful.
Old 05-14-2021, 07:45 AM   #13
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware64 -current (started with 13.37(32))
Posts: 696

Rep: Reputation: 315Reputation: 315Reputation: 315Reputation: 315
Could this be due to XScreenSaver itself?

I run Xfce with Xfce own screensaver blacklisted, and XScreenSaver loaded in the autostart list.

IIRC I noticed the same issue OP reported after the last XScreenSaver update.

The bigger login text is nice (hour and date could be bigger)
but I think XScreenSaver is blanking the screen whatever configuration is set.


Workaround was disabling XScreenSaver from autostart,
now if I want lock the screen I have to start the deamon (XScreenSaver asks for it).

Last edited by Paulo2; 05-14-2021 at 07:49 AM.
 
Old 05-14-2021, 08:45 AM   #14
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 2,247
Blog Entries: 1

Rep: Reputation: Disabled
There should xlock or something - I mean X native solution to lock X session.
 
Old 05-16-2021, 07:14 PM   #15
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,790

Original Poster
Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
Quote:
Originally Posted by elcore View Post
Probably Xorg, see also this thread where dpms and X shutdown timer was discussed.
Thanks everyone, it was a lower level power saving issue. Elcores thread link lead me to the fix. Adding these to autostart fixed it

Code:
xset -dpms
xset s off
xset s noblank
 
3 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen keeps turning off after 10 minutes Josh000 Slackware 12 05-02-2010 02:38 PM
Keyboard autorepeat keeps turning off Cride5 Linux - Desktop 3 02-14-2009 06:20 PM
My computer screen keeps freezing and I have to keep turning the computer on and off breddyy Linux - Hardware 3 01-23-2008 12:43 AM
suse 10.1 keeps turning DMA off to new Plextor 760 Ide DVD recorder sparkbot Linux - Hardware 2 11-17-2006 11:44 AM
mozilla keeps turning off jogurt666 Linux - Software 3 05-20-2004 06:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration