LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-21-2009, 03:06 PM   #1
br00tal
Member
 
Registered: Apr 2005
Distribution: Slackware 11.0-12.1
Posts: 56

Rep: Reputation: 15
Sound from console, but not in X (NIS)


At work I have a small NIS domain, and everything works great, except I don't have any sound while in an X session. I fixed it so I have sound from the console (I can adjust settings with alsamixer and such), but when I log into any desktop environment, alsamixer gives me the "alsamixer: function snd_ctl_open failed for default: No such file or directory" error like there's no sound card installed.

Does anyone know how I can make this work?
 
Old 07-21-2009, 03:11 PM   #2
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,142

Rep: Reputation: 159Reputation: 159
Quote:
Originally Posted by br00tal View Post
At work I have a small NIS domain, and everything works great, except I don't have any sound while in an X session. I fixed it so I have sound from the console (I can adjust settings with alsamixer and such), but when I log into any desktop environment, alsamixer gives me the "alsamixer: function snd_ctl_open failed for default: No such file or directory" error like there's no sound card installed.

Does anyone know how I can make this work?
Are you sure that you are getting sound in the console? Even when using NIS, you still have to configure the soundcard on every box. So, make sure to run alsaconf as root on all your workstations. Also, make sure the accounts is included in the audio group just in case.
 
Old 07-21-2009, 03:39 PM   #3
br00tal
Member
 
Registered: Apr 2005
Distribution: Slackware 11.0-12.1
Posts: 56

Original Poster
Rep: Reputation: 15
Yep. I know it works, because I have a local user that can access the sound card just fine. It's just the NIS user(s) that can't. And as far as I know, you can't simply add an NIS user to a group, since they're not technically a user on the local machine. usermod -G whatever_group username will complain about the user not existing.
 
Old 07-21-2009, 03:56 PM   #4
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,142

Rep: Reputation: 159Reputation: 159
Gotcha! Ok, so next question, are all these workstations Slackware, or are they a combination of different Operating Systems? If they are all Slackware, are they the same version? Also, did you make sure that you added your NIS users to the audio group on the NIS server? I'm quite familiar with NIS, so hopefully, I can get you on the right track.
 
Old 07-21-2009, 04:26 PM   #5
br00tal
Member
 
Registered: Apr 2005
Distribution: Slackware 11.0-12.1
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by stormtracknole View Post
Gotcha! Ok, so next question, are all these workstations Slackware, or are they a combination of different Operating Systems? If they are all Slackware, are they the same version? Also, did you make sure that you added your NIS users to the audio group on the NIS server? I'm quite familiar with NIS, so hopefully, I can get you on the right track.
The NIS server is a Slackware 11.0 server. The client(s) are a mixture of Fedora and Slackware-current machines. The Fedora machines are fine, since I think they do some PAM tricks to allow NIS users to access local devices, but since Slackware doesn't ship with PAM, there are device issues across NIS. Also, since the NIS server is an 11.0 machine running a 2,4 kernel (therefore, no power group, udev, etc.), there are obvious group issues. I did, however, add these groups (with the same GID even) to the NIS server, but it made no difference.
 
Old 07-21-2009, 04:35 PM   #6
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,142

Rep: Reputation: 159Reputation: 159
Quote:
Originally Posted by br00tal View Post
The NIS server is a Slackware 11.0 server. The client(s) are a mixture of Fedora and Slackware-current machines. The Fedora machines are fine, since I think they do some PAM tricks to allow NIS users to access local devices, but since Slackware doesn't ship with PAM, there are device issues across NIS. Also, since the NIS server is an 11.0 machine running a 2,4 kernel (therefore, no power group, udev, etc.), there are obvious group issues. I did, however, add these groups (with the same GID even) to the NIS server, but it made no difference.
I think using Slackware 11 as your NIS is the problem. The Slackware clients don't are probably getting confused on the group id (just a guess). In your Slackware-current box, look at the /etc/nsswitch.conf file and post what shows up after group:. It should be something like "files nis". I'm almost certain that Slackware 11 is causing the problems.
 
Old 07-21-2009, 05:28 PM   #7
br00tal
Member
 
Registered: Apr 2005
Distribution: Slackware 11.0-12.1
Posts: 56

Original Poster
Rep: Reputation: 15
I changed nsswitch.conf to use "files nis" on passwd, shadow, and group. Also, I've made sure the GIDs are the same with the NIS server and it's clients.

Also, like I said, the NIS users can access local devices (sound card, CD-ROM, etc.) on the client machines when they're NOT in X, this only happens when I start an X session.

Last edited by br00tal; 07-21-2009 at 05:31 PM.
 
Old 07-21-2009, 05:36 PM   #8
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,142

Rep: Reputation: 159Reputation: 159
Quote:
Originally Posted by br00tal View Post
I changed nsswitch.conf to use "files nis" on passwd, shadow, and group. Also, I've made sure the GIDs are the same with the NIS server and it's clients.

Also, like I said, the NIS users can access local devices (sound card, CD-ROM, etc.) on the client machines when they're NOT in X, this only happens when I start an X session.
Ah, understand. I still stand on slackware 11 being the problem. In my experience, when deploying an NIS network, it is best practice to keep all servers and client with the same OS just to avoid those kinds of issues. Is the only having problems playing sound in X are your slackware-current box?
 
Old 07-22-2009, 09:28 AM   #9
br00tal
Member
 
Registered: Apr 2005
Distribution: Slackware 11.0-12.1
Posts: 56

Original Poster
Rep: Reputation: 15
Yes. Like I said, the Fedora boxes use PAM I believe to set privileges for all users, so the NIS users have the same rights as the locals. It's just the Slackware boxes that have the permission issues.
 
Old 07-23-2009, 01:10 PM   #10
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,142

Rep: Reputation: 159Reputation: 159
I'm not really sure what the issue is. You can try and remove the nis option from the group section in the nsswitch.conf file. This should force Slackware current to use the local groups. Not sure if that would work though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
solaris nis server and linux nis client configuration soumalya Solaris / OpenSolaris 1 04-09-2008 12:25 AM
NIS: NIS running but users not able to log in with NIS credentials outerspace Linux - Server 3 10-17-2007 09:51 AM
SUSE 9 and 10 NIS clients with RedHat 8.0 NIS server not working fishsponge Linux - Networking 0 11-29-2005 08:43 AM
Gentoo 64-bit on AMD. Console sound with ALSA OK, but no sound in KDE. damien Linux - Software 7 02-02-2005 02:05 AM
How to setup a Solaris NIS client while with a Linux NIS server? ntcm Solaris / OpenSolaris 1 03-31-2004 07:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration