LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-04-2018, 10:41 AM   #1
agricola7
LQ Newbie
 
Registered: Jan 2008
Posts: 20

Rep: Reputation: 0
slackware64 on virt-manager won't connect to internet


I have Slackware64 in a virt-manager vm with a singular internet connection problem. This arrangement wil run Fedora, OpenSUSE, Alpine linux, for example, perfectly well, with full internet connection on boot, but while Slackware boots well in all other respects seemingly, it makes no internet connection either via cable or wireless.

Logically it must be a problem closely related to the Slackware, but I don't seem able to find any help, certainly at my level of understanding.

How to get ifconfig to show something more than lo?
 
Old 07-04-2018, 11:12 AM   #2
allend
LQ Guru
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,007

Rep: Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754Reputation: 1754
Does 'ifconfig -a' show additional interfaces?
If so, you probably need to configure networking correctly. http://docs.slackware.com/slackware:...e_your_network

PS - This post would be better placed in the Slackware forum.
 
Old 07-04-2018, 11:55 AM   #3
agricola7
LQ Newbie
 
Registered: Jan 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Reply to ifconfig question

No. ifconfig shows only lo.

How should I change the thread?
 
Old 07-05-2018, 07:36 AM   #4
rtmistler
Moderator
 
Registered: Mar 2011
Location: MA, USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 7,155
Blog Entries: 12

Rep: Reputation: 2634Reputation: 2634Reputation: 2634Reputation: 2634Reputation: 2634Reputation: 2634Reputation: 2634Reputation: 2634Reputation: 2634Reputation: 2634Reputation: 2634
Moved: This thread is more suitable in Slackware and has been moved accordingly to help your thread/question get the exposure it deserves.

Hit the Report button and write that you'd like the thread moved.
 
Old 07-05-2018, 07:42 AM   #5
Melke
Member
 
Registered: Sep 2009
Location: Graz, Austria
Distribution: Slackware Current
Posts: 104

Rep: Reputation: 37
you can change the network card to e1000. Then it will work

For some reason Slackware doesnt recognoze the RTL driver.

KR
Mel
 
Old 07-05-2018, 08:12 AM   #6
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,423

Rep: Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349
Quote:
Originally Posted by mmawhin View Post
you can change the network card to e1000. Then it will work

For some reason Slackware doesnt recognoze the RTL driver.
if I remember correctly, regarding realtek 8139x cards, it tries to load the 8139too kernel module, while most of the hardware I encountered (physical or emulated) works with the 8139cp module (in some cases is the vice-versa).
another solution, in these cases, is to blacklist the former
Code:
echo "blacklist 8139too" > /etc/modprobe.d/rtl8139.conf
or, in alternative, the latter
Code:
echo "blacklist 8139cp" > /etc/modprobe.d/rtl8139.conf
and reboot.

Last edited by ponce; 07-05-2018 at 08:22 AM.
 
Old 07-05-2018, 01:08 PM   #7
Melke
Member
 
Registered: Sep 2009
Location: Graz, Austria
Distribution: Slackware Current
Posts: 104

Rep: Reputation: 37
Quote:
Originally Posted by ponce View Post
if I remember correctly, regarding realtek 8139x cards, it tries to load the 8139too kernel module, while most of the hardware I encountered (physical or emulated) works with the 8139cp module (in some cases is the vice-versa).
another solution, in these cases, is to blacklist the former
Code:
echo "blacklist 8139too" > /etc/modprobe.d/rtl8139.conf
or, in alternative, the latter
Code:
echo "blacklist 8139cp" > /etc/modprobe.d/rtl8139.conf
and reboot.
I fought a little with virt-manager and slackware trying it with these modules. But if the OP is running virt-manager the easiest is probably to choose the e1000.

But you are completely right Ponce it should work
 
Old 07-05-2018, 03:59 PM   #8
agricola7
LQ Newbie
 
Registered: Jan 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Blacklisting realtek drivers, as suggested

Thank you for your replies. I have tried each of the the two blacklistings, but with no success.
 
Old 07-06-2018, 06:50 AM   #9
agricola7
LQ Newbie
 
Registered: Jan 2008
Posts: 20

Original Poster
Rep: Reputation: 0
How does one obtain and install e1000? My Slackware64 is running (without internet) in a virt-manager vm which cannot make contact with the outside world.
 
Old 07-06-2018, 07:00 AM   #10
Melke
Member
 
Registered: Sep 2009
Location: Graz, Austria
Distribution: Slackware Current
Posts: 104

Rep: Reputation: 37
you can go into the settings of the virtual machine and change the network card to E1000. I made a screenshot:

https://imgur.com/a/rSUBfQ4
 
Old 07-07-2018, 03:00 PM   #11
PhilipH
LQ Newbie
 
Registered: Jul 2016
Distribution: Slackware, FreeBSD
Posts: 12

Rep: Reputation: Disabled
virtio should also work. Slackware 14.2 has the driver already installed. It should be somewhat faster as e1000.
 
Old 07-08-2018, 09:17 AM   #12
agricola7
LQ Newbie
 
Registered: Jan 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Success

Many thanks for the e1000 suggestion. It worked at once, and this comes by virtue of it.
Again, my thanks!
 
Old 07-08-2018, 09:36 AM   #13
Melke
Member
 
Registered: Sep 2009
Location: Graz, Austria
Distribution: Slackware Current
Posts: 104

Rep: Reputation: 37
You're welcome
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] slackware64-current libvirt 2.2.0 - virsh / virt-manager hangs. af7567 Slackware 5 10-25-2016 04:07 PM
[SOLVED] Troubleshooting Qemu/KVM/Virt-Manager on Slackware64 14.2 kikinovak Slackware 1 07-23-2016 11:31 AM
[SOLVED] virt-manager graphical console issues with Slackware64 14.1 Richard Cranium Slackware 7 01-03-2014 12:29 PM
Virt manager won't start my VMs kkroopani Linux - Virtualization and Cloud 1 10-21-2012 12:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration