LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-06-2016, 07:20 AM   #1
Bob Barry
LQ Newbie
 
Registered: Sep 2016
Posts: 4

Rep: Reputation: Disabled
slackware cli entry numbers


Every line I enter is numbered. Can someone tell me why? And how to stop the numbers? Thanks.
 
Old 09-06-2016, 07:38 AM   #2
kjhambrick
Senior Member
 
Registered: Jul 2005
Location: Round Rock, TX
Distribution: Slackware64 14.2 + Multilib
Posts: 1,423

Rep: Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829
Bob Barry --

Maybe it's in your PS1 Variable ?

Code:
echo $PS1
Look for the strings '\#' or '\!' in PS1 ( no quotes )

If that's the case, you can temporarily change it by resetting PS1.

Code:
man bash    # search for the PROMPTING Section
To make a permanent change ...

Code:
man bash    # search for the INVOCATION Section
1. look in ~/.bashrc for PS1= ... if it's there, fix it
2. look in ~/.bash_profile ...( ditto )
3. look in ~/.bash_login ...( ditto )
4. look in ~/.profile ...( ditto )
5. look in /etc/bashrc ( if it exists, ditto )
6. look in /etc/profile ...( ditto )

HTH.

-- kjh

Last edited by kjhambrick; 09-06-2016 at 07:42 AM. Reason: add '\!'
 
Old 09-06-2016, 10:46 AM   #3
Bob Barry
LQ Newbie
 
Registered: Sep 2016
Posts: 4

Original Poster
Rep: Reputation: Disabled
SOLVED: it was "!" in PS1

Thanks, it was a leading "!" in the PS1 in /etc/profile. Users of pdksh and ksh (me) were subjected to this, bash and csh users probably never noticed. Many thanks.
 
Old 09-06-2016, 01:00 PM   #4
kjhambrick
Senior Member
 
Registered: Jul 2005
Location: Round Rock, TX
Distribution: Slackware64 14.2 + Multilib
Posts: 1,423

Rep: Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829
Thanks for the feedback Bob Barry.

I see the '!' macro setting for PS1 in /etc/profile for ksh and pdksh.

I'll keep that in mind !

-- kjh
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware for the minimal WM/CLI warrior JWJones Slackware - Installation 29 05-24-2014 10:04 AM
Echo sequence of numbers with '0' padding for length of 3 chars in CLI koobi Programming 9 11-16-2009 04:40 AM
How to add e menu entry to KDE start menu over CLI browny_amiga Linux - General 7 02-08-2009 03:05 PM
Emacs problem with Slackware CLI Lufbery Slackware 6 01-13-2007 10:26 AM
slackware entry in lilo decimal3 Linux - Newbie 2 09-26-2004 04:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration