LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-09-2007, 08:27 PM   #1
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Rep: Reputation: 15
Sendmail not receiving mail


Hi, I've been trying to configure sendmail to receive mail but have had absolutely no such luck, this is the second go at it. I have a clean install of 10.2 and have followed shilo's guide to get sendmail working. Like before I CAN send mail to web accounts fine using my ISP SMTP server which is earthlink. My box is behind a d link router and all neccesary ports have been set to forward to my slack box. When I initially tested sending an email as user to root as soon as i typed the r my address filled in as stated in shilo's guide BUT thats is not happening anymore nor can i send email from my user account to root at all. When I send an email to my hotmail account or yahoo account I DO get the authentication process and have to enter my earthlink username and password so that is working fine. When I reply from those accounts it takes at least a day to get the unable to deliver to message. I'm am so frustrated I've never been able to get this to work. Here is some output from the following commands

# host

sbitsnetworks.selfip.net has address my.static.isp.address (which by the way is what i used to register at dyndns.org)

# cat /etc/resolv.conf
search selfip.net nameserver which.is.my.dlinkrouter inside address i.e. gateway(Is this correct? or should it be the ip of the dns servers they gave me?)

I read so many howto tutorials and threads i've lost count, can someone please help me?

A couple more bits about my network. To connect to the internet on my slack box i did netconfig using 192.168.0.xxx as the IP address and 192.168.X.X (the router address) to get out to the internet. The dns IP entry is the same as the router(gateway) entry.

please throw me a bone I'm down but not out and i'm not giving up

cool

thank you
 
Old 04-10-2007, 01:29 PM   #2
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Original Poster
Rep: Reputation: 15
I guess i should add that earthlink does block port 25 they told me to use port 587 so do i need to adjust sendmail to listen on that port? here is the output of netstat -tpan | grep sendmail

tcp 0 0.0.0.0.0:587 0.0.0.0:* LISTEN
451/sendmail: accep
tcp 0 0.0.0.0.0:25 0.0.0.0:* LISTEN
451/sendmail: accep

anyone? please help
 
Old 04-10-2007, 01:57 PM   #3
pbaldera
LQ Newbie
 
Registered: Nov 2005
Location: New York City
Distribution: RHEL3,4,5
Posts: 29

Rep: Reputation: 15
You need to setup a smart relay host to route your outgoing email trough earthlink's smtp server. Go to /etc/mail, you will find a sendmail.cf file. vi the file and look from a "Smart" relay entry. You should setup and entry that should look something like this. DSsmtpserver.earthlink.com. Note that this is just and example and not the real name of the server. Let me know how it goes.
 
Old 04-10-2007, 02:27 PM   #4
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Original Poster
Rep: Reputation: 15
I can SEND mail thru earthlinks smtp server just fine I cannnot RECEIVE mail is my issue.
 
Old 08-20-2007, 03:00 PM   #5
molafish
LQ Newbie
 
Registered: Aug 2007
Posts: 21

Rep: Reputation: 0
similar problem

I am running into a similar issue.

I can send mail through my own sendmail MTA on port 25 (so the ISP is not blocking it, or at least outbound traffic on it).

I can telnet in to my MX mail record domain name on port 110. It responds with +OK.

But no mail arrives from remote MTAs? Local users can pass mail back and forth though...

Raidmax: unless your box is its own nameserver you should be setting your IP's DNS servers in the nameserver lines in resolv.conf. Then restart named:
Quote:
/etc/rc.d/rc.bind restart

Last edited by molafish; 08-20-2007 at 03:02 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail not receiving mail please help Raidmax Slackware 19 07-26-2006 05:03 PM
Receiving mails using sendmail mageshbabu.m Linux - Networking 2 01-19-2006 03:00 PM
problem receiving pop3 mail from postfix mail server GEN_Electric Linux - Software 2 02-14-2005 02:43 PM
Sendmail - problem receiving external mail manudath Linux - Wireless Networking 7 12-21-2004 01:14 PM
problems with sendmail receiving mail isostat1 Linux - Newbie 2 01-12-2004 08:28 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration