Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 05-15-2007, 04:07 AM   #1
Registered: Feb 2007
Location: Dallas
Distribution: Gentoo x86 & x86_64
Posts: 190

Rep: Reputation: 30
Unhappy Samba glitch

I recently re-arranged my networking setup. I installed a wireless router for my laptop. In order for the laptop to receive information from my LAN under Windoze, I had to basically install the wireless router as a firewall between the DSL modem, and the rest of the LAN. The DSL feeds the "untrusted" port on the router, and the rest of the LAN is attached through one of the "trusted" ports. Effectively, it changed my IP addresses on all the machines on my LAN. Instead of being in the neighborhood of, they are now in the range of

What this has effectively done is rendered Samba completely blind. While Samba still sees the name of my work group, it cannot see one single computer when I am going through Konqueror. If I use Xfsamba, it still shows the old IP addresses (in the range). It does not show the new IP addresses, nor does it connect to the computers on my LAN. If I use Konqueror, and I type in my Samba addresses in the form, smb://, I can actually connect to the computer in question. This tells me that there is a file that has the old IP addresses locked in it, and for some reason, it won't release those IP addresses and use the new addresses. This is happening on all the Slackware machines on the LAN.

What I need to know is the specific file(s) that contain these old IP addresses. The Samba documentation is less than forthcoming on this issue. According to that documentation, this file is called "lmhosts" and is supposed to be stored in the /etc/samba directory. However, this is not how things are done in Slackware. Obviously, there is a file somewhere that contains this information, and I need to change it so I can work with Samba again. Returning the wireless router and the LAN back to the way it was is right out. While Samba won't operate properly, under Windoze, I can share files and printers by way of the wireless router. Since I do a lot of file (and printer) sharing, it's a must that the wireless setup can do this.

While all my machines that run Slackware are also dual boot, and therefore can connect to one another through Windoze and NetBEUI, I want my Samba back. There's something infinitely cool about file sharing between Windoze and Slackware.

I am asking only those who have experienced this problem to reply. I know there is much that is theoretical when it comes to problem solving with Linux. I am not interested in theory. I am interested in getting my Samba back. Please, if you know the file that is causing my misery, please let me know. I don't care what it takes to get things back in operation. I want my Samba back!

Blessed be!
Old 05-15-2007, 04:59 AM   #2
Senior Member
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
According to this: edit your /etc/hosts and symlink to /etc/samba/lmhosts
Old 05-16-2007, 02:37 AM   #3
Registered: Feb 2007
Location: Dallas
Distribution: Gentoo x86 & x86_64
Posts: 190

Original Poster
Rep: Reputation: 30
Cool Getting the situation handled.

I checked out the link that you listed. It was helpful to a great degree. However, there was an inconsistency (lmhosts is unnecessary), so I am going to post how I actually got things back into working order.

1) I got the IP addresses for all the machines on the LAN and created a text file with those addresses and the associated machine names.
2) I added those IP addresses and computer names to the /etc/hosts file on all the Slackware machines.
3) I made absolutely sure that the workgroup name was placed into the /etc/samba/smb.conf file.
4) I opened the /var/cache/samba/browse.dat file and deleted all entries leaving a blank file
5) I rebooted the system.
6) At that point, I could get to the systems by entering the IP address in konqueror in the form smb:// This step repopulated the /var/cache/samba/browse.dat file.
7) I made sure that all the entries in the /etc/samba/smb.conf were the same on all the Slackware machines. The only difference was the use of the line interfaces = wlan0 to be absolutely sure the laptop used the wireless adapter.
8) I rebooted all the Slackware machines.

At that point, things started to work properly. I can't tell you how happy I am that at last, I have samba working properly through the wireless adapter. That was one of my goals when I first started setting up the wireless adapter to work under Linux. Now I am going to go to the "coolest thing you have done with Linux" and post this.

Thanks for the link and the information.

Blessed be!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Glitch with new Oracle Ad pixellany LQ Suggestions & Feedback 2 10-30-2006 01:47 PM
Knode Glitch SnowSurfAir Linux - Software 0 11-29-2004 06:55 PM
LQ Search glitch ppuru LQ Suggestions & Feedback 9 09-02-2004 08:31 AM
Is it a glitch? qulnxsh Linux - Software 1 04-28-2003 01:58 AM
a small glitch jayraj Linux - General 2 10-28-2002 02:32 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:04 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration