Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 07-17-2003, 01:29 AM   #1
LQ Newbie
Registered: Jul 2003
Location: USA
Distribution: Debian, Solaris
Posts: 3

Rep: Reputation: 0
root vs. user file permissions

Hello all this is my first post to this forum. I installed Slackware 9 for the first time about two weeks ago. Because of the Hardware I have on my computer, I recompiled the kernel and I did so successfully because of the excellent help I found on this forum. So I would like to start off by saying thank you for that Now for my question. My computer is attached to a 7 disk scsi mass storage device, this is where Slackware resides. On a disk other than the one that I installed Slackware on I have files that I would like to access. My problem is that I can only seem to get to these files while I am logged on as root. I have tried many different methods to change the permissions of the directories I would like to access and I have had no luck. The disk I am trying to access is formatted with the FAT32 file system (this is the case because my computer is dual booting with win2k.)

Other than the problem above, Slackware has been a great experience for me. I have tried other distro's in the past. I liked them all BUT none of them have compared to the positive experience I have had with Slackware.
Old 07-17-2003, 04:31 AM   #2
Registered: Jul 2003
Location: --> X <-- You are here.
Distribution: Slackware, OpenBSD
Posts: 305

Rep: Reputation: 53
If your FAT32 disk is installed under /mnt (for instance), you should probably modify your "fstab" (man fstab is your friend) to make the disk accessible by all.

Another solution is to add yourself to the "disk" user group. Also, make sure that your user name is in the "wheel" group.

Sorry if this is short, but I am sure other users of this forum will supply better answers... <grin>
Old 07-17-2003, 04:42 AM   #3
Registered: Apr 2003
Location: Warsaw, Poland
Distribution: Slackware current
Posts: 133

Rep: Reputation: 15
You must add "user" or "users" option to proper line in your fstab file (/etc/fstab). Read manual for "mount" command, there all mount options are really well described.
Old 07-17-2003, 07:22 AM   #4
LQ Newbie
Registered: Jul 2003
Location: USA
Distribution: Debian, Solaris
Posts: 3

Original Poster
Rep: Reputation: 0
Thank you for the suggestions. I will try them later on tonight.
Old 07-17-2003, 01:06 PM   #5
Registered: Jul 2003
Distribution: Slackware
Posts: 392

Rep: Reputation: 55
Also, the uid and gid mount options may be of interest to you.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
file permissions and other info ok when root, but not ok with other user benobi Linux - Newbie 3 10-17-2005 01:28 PM
Using root permissions with another user JWT2 Linux - Security 11 10-06-2005 08:13 PM
blfs non-root user permissions frostillicus Linux From Scratch 2 04-16-2005 09:56 PM
Root permissions for a user Neutron1998 Linux - Newbie 1 09-30-2004 05:28 PM
User Permissions?Root? bongski55 Slackware 7 06-17-2003 07:13 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:30 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration