LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-13-2005, 07:41 PM   #1
NX-01
LQ Newbie
 
Registered: May 2005
Location: Boone, NC
Distribution: Slackware, Fedora, Ubuntu, Debian
Posts: 22

Rep: Reputation: 15
Radeon X600 and Quake 3


Hello I have a Radeon X600 XT and I'm having trouble getting Quake 3 to run correctly. I've installed the fglrx drivers and that went off without a hitch. I'm getting around 3300 FPS @ 24 bit in glxgears, so the drivers seem to be there and working, but when I go to run Quake 3 (yes 3 not 4) it runs at about .5 frames a second. I can't quite figure out what is wrong, I've Googled about and have been unable to find a solution.

I'm running Slack 10.2 kernel 2.6.14.2, I'm using the the external AGPgart module for fglrx.

Any suggestions? (yes I've gotten the "get an nVidia card you moron" advice a lot, but for right now that's not an otion. :-P

Thanks
 
Old 11-15-2005, 01:06 PM   #2
mylqname
LQ Newbie
 
Registered: Oct 2005
Distribution: Slackware
Posts: 6

Rep: Reputation: 0
It sounds like the fglrx drivers are not working.
Try: glxinfo | grep render
and see if 'direct rendering' is a yes or no.
If it is yes, try fgl_glxgears.

I may be wrong, as I have only briefly tested fglrx and 2.6.14, but I do not think the ATI drivers support this kernel yet. I could be wrong.

anyone else got them working ?
 
Old 11-15-2005, 05:46 PM   #3
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Mine says yes on 2.6.12.6
but get alot of errors with fgl_glxgears
Code:
[fglrx] module loaded - fglrx 8.19.10 [Nov  9 2005] on minor 0
[fglrx] ACPI power management is initialized.
[fglrx] free  PCIe = 54804480
[fglrx] max   PCIe = 54804480
[fglrx] free  LFB = 55504896
[fglrx] max   LFB = 55504896
[fglrx] free  Inv = 0
[fglrx] max   Inv = 0
[fglrx] total Inv = 0
[fglrx] total TIM = 0
[fglrx] total FB  = 0
[fglrx] total PCIe = 16384
spurious 8259A interrupt: IRQ7.
[fglrx] free  PCIe = 54804480
[fglrx] max   PCIe = 54804480
[fglrx] free  LFB = 55504896
[fglrx] max   LFB = 55504896
[fglrx] free  Inv = 0
[fglrx] max   Inv = 0
[fglrx] total Inv = 0
[fglrx] total TIM = 0
[fglrx] total FB  = 0
[fglrx] total PCIe = 16384
[fglrx] free  PCIe = 54804480
I have one of those Xpress on a laptop;
01:05.0 VGA compatible controller: ATI Technologies Inc ATI Radeon XPRESS 200M 5955 (PCIE)
4223 frames in 5.0 seconds = 844.600 FPS
4220 frames in 5.0 seconds = 844.000 FPS
4221 frames in 5.0 seconds = 844.200 FPS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radeon X600 PCI-E, Kernel 2.6.12 NX-01 Slackware 41 07-03-2007 06:14 PM
help with radeon x600 rooster33 SUSE / openSUSE 10 11-02-2005 12:53 PM
Can't use a ATI MOBILITY RADEON X600 under mandrake 10 hpwit Linux - Hardware 0 10-13-2005 06:24 AM
Radeon X600, unknown chip? feeble2 Linux - Hardware 1 08-12-2005 07:20 PM
Ati Radeon X600 pro 256mb Manolis Linux - Hardware 2 03-03-2005 09:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration