LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-30-2008, 05:26 PM   #1
sixer
LQ Newbie
 
Registered: Mar 2008
Posts: 1

Rep: Reputation: 0
programs_font_size


I am using Slackware 12.0 (2.6.21.5) I changed my kde font size with qtconfig, but it took effect only on kde programs. I am using other ones, such as codeblocks, eclipse, skype,pidgin and their menu font size is too small and I can't find a way to make them bigger.
 
Old 03-30-2008, 06:06 PM   #2
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978
Have a look at this article. In particular you may be interested in gtk-qt-engine, which is available for Slackware 12.
 
Old 03-31-2008, 02:05 AM   #3
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 451

Rep: Reputation: 42
I personally like http://slackbuilds.org/repository/12...p/gtk-chtheme/

aye: screenshot

Last edited by MannyNix; 03-31-2008 at 02:07 AM.
 
Old 04-02-2008, 10:37 AM   #4
Su-Shee
Member
 
Registered: Sep 2007
Location: Berlin
Distribution: Slackware
Posts: 509

Rep: Reputation: 41
On the other hand, a simple entry in .gtkrc.mine will do the trick:

Code:
style "user-font" {
        font_name = "Bitstream Vera Sans 8"
}

widget_class "*" style "user-font"

gtk-font-name="Bitstream Vera Sans 8"
gtk-xft-antialias = 1 
gtk-xft-hinting=1     
gtk-xft-hintstyle=full 
gtk-xft-rgba=rgb 
gtk-xft-dpi=98304
gtk-icon-theme-name="Iris"
... and so on
Don't put it into .gtkrc-2.0, because that's where applications (like gtk-theming apps or Gnome configuration dialogs) write into.
 
Old 04-02-2008, 02:13 PM   #5
iiv
Member
 
Registered: Jun 2007
Location: Russia, Moscow Region
Distribution: Slackware
Posts: 167

Rep: Reputation: 30
Quote:
Originally Posted by colucix View Post
Have a look at this article. In particular you may be interested in gtk-qt-engine, which is available for Slackware 12.
Does it reduce speed of GTK-based applications?
 
Old 04-09-2008, 12:30 AM   #6
Stroker
Member
 
Registered: Dec 2006
Location: The Nature Coast
Distribution: Slackware 01001101
Posts: 83

Rep: Reputation: 18
1) Create this file:
/etc/X11/xinit/.Xresources

Make perms: root root 644

2) Put this in it:
Xft.dpi: 180

3) Reboot or Restart X for it to take effect.

4) Adjust the dpi value in the above file until the menus look good in your Gtk applications like The Gimp, Firefox, etc., (use multiples of 6).

5) Now adjust your KDE fonts:
KDE Control Center > Appearance & Themes > Fonts > Adjust All Fonts > Tick the size check box > choose the size you want.

Done.

This is exactly what the "Force fonts DPI" select box in KDE Control Center does, except they only give you three choices Disabled, 96 DPI, or 120 DPI.

You'll also notice that this adjusts the fonts in the right frame of KDE Control Center when you choose a directory in the left frame.

For more information see man X under the RESOURCES header and man xrdb.

If you perfer to set it per user, instead of system wide, then create the file here:

~/.Xresources


Edit: Although this does work. I now believe it is technically not the best/correct solution.

Last edited by Stroker; 06-22-2008 at 03:50 PM.
 
Old 06-18-2008, 09:36 PM   #7
harryhaller
Member
 
Registered: Sep 2004
Distribution: Slackware-14.0
Posts: 452

Rep: Reputation: Disabled
Thanks Stroker - you solved a problem that has plagued me for months.

I have now got rid of the .gtkrc-2.0 file and, as you quite rightly say, kept it simple.

Quote:
Originally Posted by Stroker View Post
Keep It Simple Slackers. Just use the X resource data base. That's what it's there for. First make sure X is configured to match your monitors resolution read here. Then do these in the order listed.

1) Create this file:
/etc/X11/xinit/.Xresources

Make perms: root root 644

2) Put this in it:
Xft.dpi: 180

3) Reboot or Restart X for it to take effect.

4) Adjust the dpi value in the above file until the menus look good in your Gtk applications like The Gimp, Firefox, etc., (use multiples of 6).
Quote:
Originally Posted by Stroker View Post
For more information see man X under the RESOURCES header and man xrdb.

If you perfer to set it per user, instead of system wide, then create the file here:

~/.Xresources
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration