LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-17-2010, 11:53 AM   #1
danielldaniell
Member
 
Registered: Apr 2009
Location: Hungary
Distribution: Slackware, OpenBSD
Posts: 55

Rep: Reputation: 16
nov.16 -current update broke cryptsetup


Hi!

After the recent -current upgrades, cryptsetup won't open a luks partition. It just hangs:
/sbin/cryptsetup luksOpen /dev/sda11 danielldocuments
Enter passphrase for /dev/sda11: blah
<hangs>



# strace -p 7363
Process 7363 attached - interrupt to quit
read(4, "asd\n", 512) = 4
ioctl(4, SNDCTL_TMR_CONTINUE or TCSETSF, {B38400 opost isig icanon echo ...}) = 0
write(4, "\n", 1) = 1
close(4) = 0
brk(0x809a000) = 0x809a000
getpid() = 7363
rt_sigaction(SIGINT, {0xb77f6fa0, [INT], SA_RESTART}, {SIG_DFL, [], 0}, 8) = 0
open("/dev/sda11", O_RDONLY|O_LARGEFILE) = 4
ioctl(4, BLKSSZGET, 0xbf87e4cc) = 0
close(4) = 0
open("/dev/urandom", O_RDONLY|O_LARGEFILE) = 4
read(4, "@\333", 2) = 2
semget(0xd4ddb40, 1, IPC_CREAT|IPC_EXCL|0600) = 65538
semctl(65538, 0, IPC_64|SETVAL, 0xbf87e298) = 0
close(4) = 0
semop(65538, {{0, 1, 0}}, 1) = 0
open("/dev/sda11", O_RDONLY|O_LARGEFILE) = 4
ioctl(4, BLKRAGET, 0xbf87e4e8) = 0
close(4) = 0
ioctl(3, DM_DEV_CREATE, 0x807a060) = 0
ioctl(3, DM_TABLE_LOAD, 0x807a060) = 0
ioctl(3, DM_DEV_SUSPEND, 0x8079fe0) = 0
semget(0xd4ddb40, 1, 0) = 65538
semop(65538, {{0, -1, IPC_NOWAIT}}, 1) = 0
semop(65538, {{0, 0, 0}}, 1


What gives?

# uname -rv
2.6.35.7-smp #2 SMP Mon Oct 11 14:52:09 CDT 2010

cryptsetup-1.1.3-i486-1
 
Old 11-17-2010, 12:03 PM   #2
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,914

Rep: Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177Reputation: 6177
It works here on x86_64. Maybe sure that you have the latest batch of updates, because otherwise the previous aaa_elflibs (if installed out of order) was causing problems for LVM. I wouldn't be surprised if that's also your issue with cryptsetup.
 
Old 11-17-2010, 12:23 PM   #3
danielldaniell
Member
 
Registered: Apr 2009
Location: Hungary
Distribution: Slackware, OpenBSD
Posts: 55

Original Poster
Rep: Reputation: 16
I've got the latest aaa_* packages; ran ldconfig, rebooted, waited, showered... Still no luck.

# ls -l /var/log/packages/aaa_*
-rw-r--r-- 1 root root 2161 2010-11-17 19.20.44 /var/log/packages/aaa_base-13.1-i486-2
-rw-r--r-- 1 root root 2644 2010-11-17 19.20.49 /var/log/packages/aaa_elflibs-13.2-i486-3
-rw-r--r-- 1 root root 11893 2010-11-17 19.20.54 /var/log/packages/aaa_terminfo-5.7-i486-2
 
Old 11-17-2010, 01:03 PM   #4
danielldaniell
Member
 
Registered: Apr 2009
Location: Hungary
Distribution: Slackware, OpenBSD
Posts: 55

Original Poster
Rep: Reputation: 16
While I tried to compile the cryptsetup-1.1.3 source, it complained about a missing libdevmapper.h file. Noticed that it really wasn't not preset on my system, and that the Slackware package (lvm2) which provides this, is indeed not installed.
After installpkg lvm2, cryptsetup works. Don't know why it wouldn't complain about anything but just hang forever.

Yet another time when I got reminded that one should install every package in a Slackware distribution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cryptsetup bug in -current Rupa Slackware 16 06-01-2010 02:46 PM
cryptsetup problem on -current BCarey Slackware 5 05-06-2010 03:45 PM
Slackware64-current Segmentation Fault in cryptsetup Ron Parker Slackware 2 08-19-2009 02:04 PM
-current broke open gl bird603568 Slackware 2 07-15-2005 08:16 PM
Xorg broke after update to current coffeedemon Slackware 1 11-10-2004 12:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration