LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-16-2005, 02:16 PM   #1
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,158

Rep: Reputation: 61
mysql 4.0.24 to mysql 4.1.12 upgrade problem


Hi everybody,

Last night i upgraded from mysql 4.0.24 to 4.1.12 from slackware current. After upgrade, I'm having problems with mysql.

PHPMyAdmin now gives me the following message when i try to administer mysql

Code:
cannot load mysql extension;
please check PHP configuration
Refer Documentation
I referred the documentation and it says.

Quote:
To connect to a MySQL server, PHP needs a set of MySQL functions called "MySQL extension". This extension may be part of the PHP distribution (compiled-in), otherwise it needs to be loaded dynamically. Its name is probably mysql.so or php_mysql.dll. phpMyAdmin tried to load the extension but failed.

Usually, the problem is solved by installing a software package called "PHP-MySQL" or something similar.
I've also checked php.ini file for "mysql.so" extension and it is not commented out.

I have also recompiled php taking cues from slackware php 5.0.4 package and adding couple more compile switches. Here's the compile i've used.

Quote:
./configure --prefix=/usr --disable-static --with-apxs=/usr/sbin/apxs --sysconfdir=/etc
--enable-discard-path --with-config-file-path=/etc/apache --enable-safe-mode --with-openssl
--with-mhash --enable-bcmath --with-bz2 --with-pic --enable-calendar --enable-ctype
--with-gdbm --with-db3 --enable-dbase --enable-ftp --with-iconv --with-exif --enable-exif
--with-gd --enable-gd-native-ttf --with-jpeg-dir=/usr --with-png --with-gmp --with-mysql=shared,/usr --with-mysqli=/usr/bin/mysql_config --with-mysql-sock=/var/run/mysql --with-gettext=shared,/usr --with-expat-dir=/usr --with-xml --enable-wddx --with-mm=/usr --enable-trans-sid --enable-shmop --enable-sockets --with-regex=php --enable-sysvsem --enable-sysvshm --enable-yp --enable-memory-limit --with-tsrm-pthreads --enable-shared --disable-debug --with-zlib=/usr --enable-yp --with-libxml-dir=/usr --enable-sqlite-utf8 --enable-mbstring
Should i be using the two mysql switches highlighted above?

After all this, i'm getting the phpmyadmin error i mentioned before. I'm stumped at this now. I'll appreciate if someone knows this and can help me out.

Also if you read the quote on this post, the possible answers mentions a "PHP-MyQSL" package
to install to get rid of this error. Where can i find this package, if it exists?

Thanks
Tux,
 
Old 07-16-2005, 02:28 PM   #2
Nathanael
Member
 
Registered: May 2004
Location: Karlsruhe, Germany
Distribution: debian, gentoo, os x (darwin), ubuntu
Posts: 940

Rep: Reputation: 33
check the php.ini file ans see if the mysql extention gets loaded twice!
 
Old 07-16-2005, 02:38 PM   #3
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,158

Original Poster
Rep: Reputation: 61
Nope, it's not getting loaded twice.
 
Old 07-16-2005, 02:48 PM   #4
Nathanael
Member
 
Registered: May 2004
Location: Karlsruhe, Germany
Distribution: debian, gentoo, os x (darwin), ubuntu
Posts: 940

Rep: Reputation: 33
check the extention file is in the right location?
 
Old 07-16-2005, 03:15 PM   #5
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,158

Original Poster
Rep: Reputation: 61
Thanks for the reply Nathanael, I was actually trying to find out the same thing. I figured out that extension were in /usr/lib/php/extensions/no-debug-no-zts-20041030 directory instead of /usr/lib/php/extensions.

I actually then made a symlink of mysql.so into /usr/lib/php/extensions. Now i can use phpmyadmin. However, I have a new problem. I also run a webserver with php and mysql. I'm using wordpress and openbook. After the upgrade (and now that i'm able to use phpmyadmin), wordpress is complaining that

Quote:
Your PHP installation appears to be missing the MySQL which is required for WordPress.
I've checked the php configuration via web and i see that php is recognizing mysqli support.

Tux,
 
Old 07-16-2005, 04:02 PM   #6
Nathanael
Member
 
Registered: May 2004
Location: Karlsruhe, Germany
Distribution: debian, gentoo, os x (darwin), ubuntu
Posts: 940

Rep: Reputation: 33
i have no idea what wordpress is, but could there be some version issues? ie: wordpress expecting to find mysql 4.0 and not 4.1?
 
Old 07-16-2005, 04:06 PM   #7
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,158

Original Poster
Rep: Reputation: 61
Wordpress is a php based blogging software. I however, tried reading the mysql error log and found that I needed to fix table privileges. The new mysql installation came with a script to do that.

# /usr/bin/mysql_fix_privilege_tables

I ran that script but it was giving me the same error and was kinda pissing me off. In a moment of desperation, I decided to reboot...and voila!!! after reboot everything works. I have no idea why that reboot worked since I'd tried restarting mysql server to no avail.

Anyway I would like to thank you for taking time and helping me solve this thing

Thanks again Nathanael

Tux
 
Old 08-13-2005, 06:43 PM   #8
php4u
LQ Newbie
 
Registered: Oct 2003
Posts: 15

Rep: Reputation: 0
similar problem with CentOS (RHEL)

need help with a recent install of phpMyAdmin. It was working for several weeks, then stopped. The versions include;
PHP 4.3.9 (cgi) (built: Jul 7 2005 21:38:20)
mysql Ver 14.7 Distrib 4.1.10a, for redhat-linux-gnu (i686)
phpMyAdmin 2.6.3-pl1
Server version: Apache/2.0.52
...SeLinux is disabled

phpinfo = --with-mysql=shared,/usr

When I try to pull up the phpMyAdmin index page, I get the following error;
cannot load mysql extension;

I do not see any errors in the messages, access, or error logs.

I have configured this application many times before with much success...this one has me stumped.

Thank you in advance for any suggestions!
Ralph
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. NoviceW Linux - Networking 17 09-17-2014 02:13 PM
Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock welery Linux - Software 19 03-06-2014 07:19 AM
ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. suziecorbett Linux - Software 8 10-09-2008 01:52 AM
mysql error Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. Dannux Linux - Software 3 03-24-2006 08:44 AM
problem with apt after mysql upgrade davesbedroom Red Hat 1 11-10-2005 05:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration