LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-08-2004, 06:30 PM   #1
edM
Member
 
Registered: Nov 2003
Location: U.K.
Distribution: Slackware-12
Posts: 137

Rep: Reputation: 15
modem / tty prob after a rebuild


hi,

i was rebuilding my kernal, adding SATA support, unfortunately i lost the config file so i had to go through and uncheck all unnecessary drivers etc.

After the rebuild i tried to dial up using PPP and got this error:

Code:
 root@c10:# 
                 #/usr/sbin/pppd : ln file /etc/ppp/options : unrecognized option ' /dev/ttyS0
there is no /dev/modem in /dev

i checked that i had selected all PPP options in kernal config, but i must of deselected something, but going through all the kernal options again i couldnt see anything which might be the problem.

as always thankyou for your help.

Ed.
 
Old 08-08-2004, 06:44 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: earth
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
/dev/modem is commonly just a symlink to a serial
device ... if you don't have those either (PPP is complaining
about /dev/ttyS0 , not /dev/modem in the first place)
you probably disabled them ... how did you "lose"
your .config, btw?



Cheers,
Tink
 
Old 08-08-2004, 06:58 PM   #3
edM
Member
 
Registered: Nov 2003
Location: U.K.
Distribution: Slackware-12
Posts: 137

Original Poster
Rep: Reputation: 15
i was fiddling around with the config file (as you do) and ran mrproper, not knowing what it does until later, the only other backup was just the default settings.

so how do i enable them?


thanks
 
Old 08-08-2004, 07:06 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: earth
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
Uh-huh ... :}
Good practice tip: once you compiled and installed
a new kernel, put a copy of .config into /boot with it.
I usually do a cp .config /boot/config-<version>

In .config search for CONFIG_SERIAL, set it to
m or y ...


Cheers,
Tink
 
Old 08-08-2004, 07:10 PM   #5
edM
Member
 
Registered: Nov 2003
Location: U.K.
Distribution: Slackware-12
Posts: 137

Original Poster
Rep: Reputation: 15
will do, thanks mate.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
external modem prob globeTrotter Linux - Hardware 3 08-20-2004 05:27 AM
change tty => system crashes (ati driver/tty resolution) mosca Debian 6 08-05-2004 08:37 AM
Modem Prob hey_joe Linux - Newbie 3 10-27-2003 12:28 PM
modem conection prob NSKL Linux - Software 2 03-12-2002 12:14 PM
A Simple Prob With Modem Mewizard Linux - Newbie 2 05-18-2001 02:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration