LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-14-2019, 02:32 PM   #1
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 911

Rep: Reputation: Disabled
MATE Caja: Open in terminal


Is there a way to configure the Caja open-in-terminal extension to open the user's preferred terminal rather than mate-terminal?

Thanks.
 
Old 04-14-2019, 05:12 PM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,831

Rep: Reputation: Disabled
Not specifically for CAJA, but it honors the general setting that you can change:
  • from the menu: System => Preferences =>Personal => Preferred Applications => System => Terminal Emulator.
  • from the Control Center: (either type mate-control-center or from the menu: System =>Control Center) in the Personal group.
 
Old 04-14-2019, 05:41 PM   #3
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 911

Original Poster
Rep: Reputation: Disabled
I had already tried that. No luck.

I'm using Xfce in a Current VM. I installed the MATE 1.22 packages. I verified xfce4-terminal is the preferred terminal. When I launch Caja and select Open in terminal, mate-terminal opens.

I don't know if this is hard-coded.

Background:
Dues to recent changes in MATE, I am looking at migrating to Xfce.

I don't like Thunar because the file manager does not support expanding or collapsing directories in the file pane. Caja supports this. The Thunar side pane supports expanding and collapsing, but I prefer to do this in the file pane. Memory muscle and all that going way back to the KDE 3 Konqueror days. As a side note, I always get frustrated when I have to use the Windows File Explorer at work because that file manager also does not support direct expanding and collapsing of directories.

I started looking at other file managers. So far xfe is wickedly fast but does not support direct expanding and collapsing. I suppose I need to look at others. Would be so simple if Caja just honored by preferred selections.
 
Old 04-14-2019, 05:57 PM   #4
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,831

Rep: Reputation: Disabled
I am puzzled: why does it work in Mate 1.18, then?

I tried changing to xfce4-terminal, xterm, uxterm, konsole, LXTerminal, all worked.

It didn't work with Mlterm, but that my mistake: I updated brltty to version 6 and didn't remember to rebuilt Mlterm aginst it. Will do.

Last edited by Didier Spaier; 04-14-2019 at 06:05 PM.
 
Old 04-14-2019, 06:26 PM   #5
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 911

Original Poster
Rep: Reputation: Disabled
Quote:
I am puzzled: why does it work in Mate 1.18, then?
Interesting. I don't have any system running MATE 1.18, but the user's terminal preference in MATE 1.16 is honored too.

I just updated my Current VM to MATE 1.22 and forgot to create a snapshot. I could restore from a backup to test 1.20, but instead I wanted to see if the problem was Slackware only. In a Xubuntu 18.04 VM (Xfce desktop) I added the Caja packages. I verified preferences were set to xfce4-terminal, as would be expected in Xubuntu. Same breakage. As an additional test I removed the mate-terminal package. Selecting the menu option results in no terminal opening at all. Nothing in the xsession-error log.

Looks like the regression was introduced in 1.20 and is a MATE bug rather than Slackware.
 
Old 04-15-2019, 02:42 AM   #6
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 117

Rep: Reputation: 83
I'm running MATE 1.22 and have no problems setting the default terminal using System => Preferences =>Personal => Preferred Applications => System => Terminal Emulator.
Could it be a VM issue, since you say that you're running -current VM?
 
Old 04-15-2019, 12:50 PM   #7
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 911

Original Poster
Rep: Reputation: Disabled
Quote:
I'm running MATE 1.22 and have no problems setting the default terminal using System => Preferences =>Personal => Preferred Applications => System => Terminal Emulator.
The problem is not setting the preferred app. The problem is Caja does not honor that preference.
 
Old 04-15-2019, 12:58 PM   #8
Turbocapitalist
Senior Member
 
Registered: Apr 2005
Distribution: Linux Mint, Devuan, OpenBSD
Posts: 3,909
Blog Entries: 3

Rep: Reputation: 1858Reputation: 1858Reputation: 1858Reputation: 1858Reputation: 1858Reputation: 1858Reputation: 1858Reputation: 1858Reputation: 1858Reputation: 1858Reputation: 1858
Quote:
Originally Posted by upnort View Post
The problem is not setting the preferred app. The problem is Caja does not honor that preference.
Have you checked for a bug report on that? If there is one, there may be a way to tick a box saying it also affects you. Without such a tick box, you'll have to contribute some information towards defining or solving the problem in the form of a comment, but remember that "me too" comments don't help and will not advance a solution. If there is no bug report, and you can meet the requirements for filing one, then please do. It may seem a bit inconvenient on the surface but it helps improve the software and is really just the cost of doing business when you use Free and Open Source Software.
 
Old 04-15-2019, 01:50 PM   #9
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 117

Rep: Reputation: 83
Quote:
Originally Posted by upnort View Post
The problem is not setting the preferred app. The problem is Caja does not honor that preference.
Sorry, I omitted the obvious: when I choose another terminal as ppreferred (e.g xfce4), caja does honor my choice. Which is why I wondered if the fact thar you're running -current on VM could have anything to do with it.

Last edited by kgha; 04-15-2019 at 01:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
(caja:27198): GLib-GObject-WARNING error when opening trash with caja via terminal on Debian 9 MATE backport. linustalman Linux - Software 1 08-17-2018 01:04 PM
[SOLVED] Caja (Mate file manager) cannot write to USB haertig Linux - Software 1 09-24-2016 07:31 PM
mate/caja : mount -oloop / umount problems burdi01 Slackware 15 04-01-2013 11:57 AM
LXer: How to use location entry in Caja in Linux Mint MATE LXer Syndicated Linux News 0 08-02-2012 09:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration