LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-20-2003, 08:39 PM   #1
major.tom
Member
 
Registered: Jun 2003
Location: Canada
Distribution: Slackware (current); Gentoo (newbie)
Posts: 142

Rep: Reputation: 15
kernel 2.4.21 with ataraid


I've been trying to get the letest kernel to work with my Promise FastTrak 100 RAID card, without any luck.

I keep getting Kernel panic messages saying it couldn't mount the filesystem at root. I've tried rebuilding the kernel several times, including support for the FastTrak to no avail.

The previous one was working fine by. Does anyone have any ideas?

Here's my lilo.conf...

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
append="ataraid.i"
boot = /dev/ataraid/d0
message = /boot/boot_message.txt
prompt
timeout = 100
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x64k
vga = 791
# DOS bootable partition config begins
other = /dev/ataraid/d0p3
label = DOS/Win2k
table = /dev/ataraid/d0
# DOS bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/ataraid/d0p8
label = Linux
read-only
# Linux bootable partition config ends


Cheers!

Garry
 
Old 06-22-2003, 06:17 PM   #2
major.tom
Member
 
Registered: Jun 2003
Location: Canada
Distribution: Slackware (current); Gentoo (newbie)
Posts: 142

Original Poster
Rep: Reputation: 15
I think I figured out what I was missing. I got up and running (eventually) but missed one crucial step.

After upgrading kernel-ide, I should've copied over the config, System.map and bzImage (aka vmlinuz) from the /kernel/ataraid.i folder into /boot and re-run lilo.

Needless to say, I don't think I'll make this mistake again.

Live and learn,

Garry

Last edited by major.tom; 06-22-2003 at 06:18 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel 2.6 and ataraid - Does it work yet? pepsilvr Linux - General 0 06-22-2004 12:13 PM
Kernel 2.6.5 ATARaid Tunarle Linux - Hardware 0 04-14-2004 07:17 PM
Slackware 9.1/Kernel 2.6.0 & ATARAID HPT372 kwiksand Slackware 3 12-27-2003 09:01 PM
How to boot on ataraid in kernel 2.6 jobdrb Linux - General 0 12-17-2003 10:48 AM
Kernel 2.6.. can't boot AtaRaid jobdrb Linux - Software 0 12-17-2003 10:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration