LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-29-2004, 11:05 AM   #1
easywebdev
LQ Newbie
 
Registered: Mar 2004
Location: Donegal, Ireland
Distribution: Slackware 9.1
Posts: 7

Rep: Reputation: 0
kde3.2 $PATH and .bash_profile


Hi folks, first post here and I would just like to say a huge thanks to all the Slackware gurus whos posts have helped me immensely in my migration from Mandrake to Slackware.
With this forums help I have installed slackware9.1 built a custom 2.6.3 kernel, installed vmware and had everything working perfectly up until I updated kde to kde 3.2.

Now I have a problem, after upgrading to kde3.2 I have no .bash_profile, .bashrc files and when I start a shell I get the default bash prompt, and root does not seem to have kde in its path as I cant start any kde apps as root from the console.
/etc/profile doesnt seem to be parsed at boot, I've edited /etc/X11/xdm/Xsession to use .bash_profile instead of the default .profile but its not parsed at boot.

I can get my .bash_profile in place by "# source .bash_profile" and "# source /etc/profile"
or running konsole with -ls but I want to get this done at boot and get kde into roots $PATH.

When I "# source /etc/profile" roots $PATH is set properly
Kde3.2 is installed system wide in /opt/kde

Has anyone else gone through this already and would like to share their knowledge?

TIA

Last edited by easywebdev; 03-29-2004 at 11:13 AM.
 
Old 03-29-2004, 11:34 AM   #2
pbhj
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware 12; Ubuntu 7.10
Posts: 358

Rep: Reputation: 31
You can alter the path using something like:
Code:
export path="$path:/opt/kde:/any/path"
But just to be certain, type "export" at the bash prompt first ("set" works too) and then you can always cut and paste the old path ...
HTH

PS: This might help too http://www.comptechdoc.org/os/linux/...x_sushell.html

Last edited by pbhj; 03-29-2004 at 11:37 AM.
 
Old 03-29-2004, 05:42 PM   #3
easywebdev
LQ Newbie
 
Registered: Mar 2004
Location: Donegal, Ireland
Distribution: Slackware 9.1
Posts: 7

Original Poster
Rep: Reputation: 0
I've got my users working by reading man bash and a few other posts here by creating a .bash_profile and adding --ls to the konsole shortcut, path is set correctly now as I source /etc/profile in .bashrc when I startx.

I cant find a way to automatically source /etc/profile for root when I su in konsole though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Damn - KDE3.4 and now back to KDE3.2 with old settings shazam75 Mandriva 1 05-21-2005 01:22 AM
After removing kde3.2, and installing kde3.3...fonts look bad. RoaCh Of DisCor Linux - Software 3 10-23-2004 09:27 PM
Adding Java to my path in the .bash_profile file .... jmax24 Linux - General 5 04-20-2004 02:14 PM
kshell in path & .bash_profile dmartinez Linux - Newbie 3 03-31-2003 11:15 PM
.bash_profile & path Syncrm Linux - General 11 01-30-2002 02:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration