LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-03-2014, 03:06 AM   #1
notKlaatu
Senior Member
 
Registered: Sep 2010
Location: Lawrence, New Zealand
Distribution: Slackware
Posts: 1,075

Rep: Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725
KDE 4.13.3 [alien] annoying KDE polkit and wallet prompts


I installed Alien's KDE 4.13.3 on 14.1 and its great. All except for two annoying popups that appear everytime I log in. The first is a polkit prompt for my root password, apparently needed by Balloo for a Folder Watch list or something? and the other is KWallet, which now asks me for my user password (the one I JUST typed into KDM in order to log into my desktop) so that Network Manager can sign on to my home wifi.

Maybe I never noticed the kwallet one before or maybe it's new. But the polkit thing is definitely new.

Anyone else seeing this? More importantly, anybody know the magical bits I need to flip in order to make this go away?

Screenshot:
http://imgur.com/hnHnOVr,WEYCEae
http://imgur.com/hnHnOVr,WEYCEae#1

Last edited by notKlaatu; 09-03-2014 at 03:09 AM. Reason: image
 
Old 09-03-2014, 04:09 AM   #2
a4z
Senior Member
 
Registered: Feb 2009
Posts: 1,727

Rep: Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742
how did you install?
did you do the remove parts?
Quote:
On Slackware 32-bit:
# upgradepkg --reinstall --install-new x86/deps/*.t?z
# upgradepkg --reinstall --install-new x86/kde/*.t?z
# removepkg kdeadmin
# removepkg kdenetwork
# removepkg kdesdk
# removepkg kdetoys
# removepkg kwallet
# removepkg kdnssd

On Slackware 64-bit:
# upgradepkg --reinstall --install-new x86_64/deps/*.t?z
# upgradepkg --reinstall --install-new x86_64/kde/*.t?z
# removepkg kdeadmin
# removepkg kdenetwork
# removepkg kdesdk
# removepkg kdetoys
# removepkg kwallet
# removepkg kdnssd
 
Old 09-03-2014, 04:53 AM   #3
notKlaatu
Senior Member
 
Registered: Sep 2010
Location: Lawrence, New Zealand
Distribution: Slackware
Posts: 1,075

Original Poster
Rep: Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725
Yes, I followed the upgrade instructions in the README file, as I do with each AlienBOB KDE build.
 
Old 09-03-2014, 05:05 AM   #4
notKlaatu
Senior Member
 
Registered: Sep 2010
Location: Lawrence, New Zealand
Distribution: Slackware
Posts: 1,075

Original Poster
Rep: Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725
Well, I found in System Settings > Global Policy Configuration

a place where I can assign myself as "system administrator". This makes it so that polkit now asks for my user password instead of my root password, which is nice... but that's three user passwords just to login to a KDE desktop: one to get past KDM, one to get past polkit, and one to get past kwallet. I must be missing something...
 
Old 09-03-2014, 05:23 AM   #5
notKlaatu
Senior Member
 
Registered: Sep 2010
Location: Lawrence, New Zealand
Distribution: Slackware
Posts: 1,075

Original Poster
Rep: Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725
OK I "solved" the kwallet problem by changing my kwallet passwd to an empty string, a solution which I believe is known as the "Mac and Windows Solution".

I'd still be interested in hearing if anyone else is suddenly or recently experiencing this issue. Possibly it's been happening for years and I just sublimated until polkit started bugging me.

Polkit is still an issue, however.
 
Old 09-03-2014, 05:28 AM   #6
schmatzler
Member
 
Registered: Jan 2011
Location: Germany
Distribution: Slackware64 -current + Multilib
Posts: 405

Rep: Reputation: 178Reputation: 178
I just opened up kwallet when I first installed Slackware, unticked the box where it said "Activate" and it never bothered me again.
 
Old 09-03-2014, 04:51 PM   #7
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Brú na Bóinne, IE
Distribution: Slackware, NetBSD
Posts: 1,886

Rep: Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362
Quote:
Originally Posted by notKlaatu View Post
I'd still be interested in hearing if anyone else is suddenly or recently experiencing this issue. Possibly it's been happening for years and I just sublimated until polkit started bugging me.
You're not the only one. I've had this problem as well but I didn't bother trying to solve it because I've given up fighting these brainless regressions in KDE (and Linux generally). Another infuriating issue I had recently with KDE was its insistence on updating some God-only-knows-what background mail cache despite my shutting down Kmail completely. For someone on a metered 3G connection this is nothing less than bad manners on the part of the developers. When I close my mail client I want the connection to my IMAP server broken there and then; I don't want some stupid background process continuing to download thousands of mail headers and/or bodies just because the devs think I should prefer it to work that way.
It's a sad indictment of KDE that it first came out around the same time as Windows 95 yet Windows 95 still works better as a straightforward, business-friendly desktop. KDE has made enormous strides, and in many ways it is a hugely impressive desktop, perhaps the most impressive of them all, but in too many other ways it remains patronizing and clunky, and still far behind the understated elegance and simplicity of Windows 95 and Windows 2000.
I intend to give KDE one more chance with this new version 5. If they don't get it right over the next two years that's bye bye from me. They're on the go since the mid-1990s. No more excuses.

Edit: this is not a criticism of Slackware or Alien Bob.

Last edited by Gerard Lally; 09-03-2014 at 05:37 PM.
 
Old 09-05-2014, 11:11 AM   #8
a4z
Senior Member
 
Registered: Feb 2009
Posts: 1,727

Rep: Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742
I have also one polkit mesasage
its on an installation in a virtual box
put latest KDE on it
and on startup, first login into kde the polkit message comes

any idea what this is caused by?

System Settings / Policy Action has tons of options

what is this?
 
Old 09-07-2014, 11:35 AM   #9
a4z
Senior Member
 
Registered: Feb 2009
Posts: 1,727

Rep: Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742
kde_baloo_filew is the reason for the polkit password question,

that explains also why I have this just in the test installation, on other installation baloo is turned of,

however, strange thing, this should not be the case and and I wounder why I have this and why not more people have this problem, seem to be nothing usual
 
1 members found this post helpful.
Old 09-07-2014, 11:56 AM   #10
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,693

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
I see it on every reboot. I've just never mentioned it or been that annoyed just yet.
 
Old 09-07-2014, 05:05 PM   #11
notKlaatu
Senior Member
 
Registered: Sep 2010
Location: Lawrence, New Zealand
Distribution: Slackware
Posts: 1,075

Original Poster
Rep: Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725
So it's Baloo causing the issue? thanks for that.

I guess I'll just look into how te disable Baloo. I do not see an option for that in Sys Settings > Desktop Search but I'll hunt around and post the results.
 
Old 09-07-2014, 07:28 PM   #12
notKlaatu
Senior Member
 
Registered: Sep 2010
Location: Lawrence, New Zealand
Distribution: Slackware
Posts: 1,075

Original Poster
Rep: Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725Reputation: 725
OK, it's ugly and there's probably a better way to do it, but this:

Code:
chmod -x /usr/bin/baloo_file /usr/bin/baloo_file_extractor
makes the polkit popup not appear.

There has to be some group or policy thing I'm supposed to add my user to, or something, but so far I haven't found it. Until then, this ugly hack does stop the popup.
 
Old 01-20-2015, 08:20 PM   #13
Musikolo
Member
 
Registered: Jul 2003
Distribution: Arch Linux x64
Posts: 115

Rep: Reputation: 15
System Settings --> Desktop Search --> Uncheck "Enable Desktop Search".

This is what I did and it worked for me.

Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE updated to Alien's Lastst KDE Packages ozanbaba Slackware 3 06-29-2014 10:24 AM
Fedora 19 and Yumex - and polkit-kde Galaxy_Stranger Fedora 1 08-24-2013 11:44 AM
PolKit - Permission Errors In KDE cordesir Linux From Scratch 8 12-27-2012 01:53 PM
polkit-kde-auth and libglib-2.0.so.0.2800.6 SeRi@lDiE Slackware 9 11-28-2011 11:10 AM
LXer: KDE extends Polkit support to polkit-1 LXer Syndicated Linux News 0 12-26-2009 12:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration