LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-22-2011, 05:06 PM   #1
cristi92b
Member
 
Registered: May 2011
Posts: 91

Rep: Reputation: Disabled
Installing nvidia driver 13.37-amd64


Can you tell me how to install this driver?

I disabled X server and I blacklisted nouveau kernel, but when I try to install the driver it says Error: Could not create the kernel module.
 
Old 05-22-2011, 05:21 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863
Please post the exact steps you do to install the driver, and the exact error messages. Also make sure you have the development tools installed, and the kernel headers.
 
Old 05-22-2011, 06:46 PM   #3
cristi92b
Member
 
Registered: May 2011
Posts: 91

Original Poster
Rep: Reputation: Disabled
1.Downloaded NVIDIA-Linux-x86_64-256.53.run to Desktop
2.rebooted and started with runlevel 3, logged in as root
3.
cd Desktop
sudo sh NVIDIA-Linux-x86_64-256.53.run
(install failed - created /etc/modprobe.d/ )
4.
cd /etc/modprobe.d/
nano blacklist.conf
(added "blacklist nouveau" line and saved)
5. reboot
6.
cd Desktop
sudo sh NVIDIA-Linux-x86_64-256.53.run
(Error: unable to build nvidia kernel module.)
7.
cd /etc/
rm modprobe.d -r
(deleted modprobe.d folder to be able to start runlevel 4 when rebooting)
---------------------------------------------------------------------------
This is /var/log/nvidia-installer.log :

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun May 22 23:31:22 2011
installer version: 256.53

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
no cc version check : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
compat32 install chroot : (not specified)
compat32 install prefix : (not specified)
compat32 install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '2091'
of a runnning X server.
 
Old 05-22-2011, 06:49 PM   #4
cristi92b
Member
 
Registered: May 2011
Posts: 91

Original Poster
Rep: Reputation: Disabled
How do I know if I have development tools and kernel headers installed?
 
Old 05-22-2011, 07:25 PM   #5
afreitascs
Member
 
Registered: Aug 2004
Distribution: Debian
Posts: 443

Rep: Reputation: 30
Quote:
Originally Posted by cristi92b View Post
How do I know if I have development tools and kernel headers installed?
what is your video card ?
 
Old 05-22-2011, 07:29 PM   #6
cristi92b
Member
 
Registered: May 2011
Posts: 91

Original Poster
Rep: Reputation: Disabled
nvidia geforce 210
 
Old 05-22-2011, 07:35 PM   #7
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 229Reputation: 229Reputation: 229
Quote:
Originally Posted by cristi92b View Post
1.Downloaded NVIDIA-Linux-x86_64-256.53.run to Desktop
2.rebooted and started with runlevel 3, logged in as root
3.
cd Desktop
sudo sh NVIDIA-Linux-x86_64-256.53.run
If you already logged in as root there is no need for the "sudo" here.

Log in as root (not sure if you downloaded the file to root's Desktop or someone else's)
Code:
telinit 3
cd /path/to/Desktop
chmod +x NVIDIA-Linux-x86_64-256.53.run
./NVIDIA-Linux-x86_64-256.53.run
Quote:
Originally Posted by cristi92b View Post
Using: nvidia-installer ncurses user interface
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '2091'
of a runnning X server.
Looks to me that you might have still had X running. The `telinit 3` command will drop you back to runlevel 3 without rebooting.
And make sure you don't still have a user logged in running startx.

Last edited by mRgOBLIN; 05-22-2011 at 07:37 PM.
 
Old 05-23-2011, 12:59 AM   #8
cristi92b
Member
 
Registered: May 2011
Posts: 91

Original Poster
Rep: Reputation: Disabled
Probably I typed sudo sh NVIDIA-Linux-x86_64-256.53.run 2 times, because there's no "Error: unable to build nvidia kernel module" in the log file. I know because I tried 2 times before and I got a different error in the log file.

I'll try again and post the new log file.
 
Old 05-23-2011, 01:50 AM   #9
cristi92b
Member
 
Registered: May 2011
Posts: 91

Original Poster
Rep: Reputation: Disabled
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Mon May 23 09:43:27 2011
installer version: 256.53

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
no cc version check : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
compat32 install chroot : (not specified)
compat32 install prefix : (not specified)
compat32 install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 256.53.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/2.6.37.6/source'
-> Kernel output path: '/lib/modules/2.6.37.6/build'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Performing Xen check.
-> Cleaning kernel module build directory.
executing: 'cd ./kernel; make clean'...
-> Building kernel module:
executing: 'cd ./kernel; make module SYSSRC=/lib/modules/2.6.37.6/source SYS
OUT=/lib/modules/2.6.37.6/build'...
NVIDIA: calling KBUILD...
make -C /lib/modules/2.6.37.6/build \
KBUILD_SRC=/usr/src/linux-2.6.37.6 \
KBUILD_EXTMOD="/tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel" -f /usr/sr
c/linux-2.6.37.6/Makefile \
modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/generated/autoconf.h or include/config/auto.conf are
missing.";\
echo " Run 'make oldconfig && make prepare' on kernel src to fix it.
"; \
echo; \
/bin/false)
mkdir -p /tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/.tmp_versions ; r
m -f /tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/.tmp_versions/*
make -f /usr/src/linux-2.6.37.6/scripts/Makefile.build obj=/tmp/selfgz1970/N
VIDIA-Linux-x86_64-256.53/kernel
cc -Wp,-MD,/tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/.nv.o.d -nos
tdinc -isystem /usr/lib64/gcc/x86_64-slackware-linux/4.5.2/include -I/usr/sr
c/linux-2.6.37.6/arch/x86/include -Iinclude -I/usr/src/linux-2.6.37.6/inclu
de -include include/generated/autoconf.h -I/tmp/selfgz1970/NVIDIA-Linux-x8
6_64-256.53/kernel -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigr
aphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration
-Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mtune=generic
-mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -f
stack-protector -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS
_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -pipe -Wno-sign-compare -fno-asynchron
ous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -fno-omit-frame-poi
nter -fno-optimize-sibling-calls -pg -Wdeclaration-after-statement -Wno-poin
ter-sign -fno-strict-overflow -fconserve-stack -DCC_HAVE_ASM_GOTO -I/tmp/s
elfgz1970/NVIDIA-Linux-x86_64-256.53/kernel -Wall -MD -Wsign-compare -Wno-ca
st-qual -Wno-error -D__KERNEL__ -DMODULE -DNVRM -DNV_VERSION_STRING=\"256.53
\" -mcmodel=kernel -mno-red-zone -UDEBUG -U_DEBUG -DNDEBUG -DMODULE -D"KBU
ILD_STR(s)=#s" -D"KBU
ILD_BASENAME=KBUILD_STR(nv)" -D"KBUILD_MODNAME=KBUILD_STR(nvidia)" -c -o /t
mp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/nv.o /tmp/selfgz1970/NVIDIA-
Linux-x86_64-256.53/kernel/nv.c
In file included from include/linux/kernel.h:17:0,
from include/linux/sched.h:54,
from include/linux/utsname.h:35,
from /tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/nv-l
inux.h:27,
from /tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/nv.c
:13:
include/linux/bitops.h: In function 'hweight_long':
include/linux/bitops.h:49:41: warning: signed and unsigned type in condition
al expression
In file included from /usr/src/linux-2.6.37.6/arch/x86/include/asm/uaccess.h
:573:0,
from include/linux/poll.h:14,
from /tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/nv-l
inux.h:84,
from /tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/nv.c
:13:
/usr/src/linux-2.6.37.6/arch/x86/include/asm/uaccess_64.h: In function 'copy
_from_user':
/usr/src/linux-2.6.37.6/arch/x86/include/asm/uaccess_64.h:54:6: warning: com
parison between signed and unsigned integer expressions
/tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/nv.c: At top level:
/tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/nv.c:426:5: error: unknown
field 'ioctl' specified in initializer
/tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/nv.c:426:5: warning: initi
alization from incompatible pointer type
make[4]: *** [/tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel/nv.o] Error
1
make[3]: *** [_module_/tmp/selfgz1970/NVIDIA-Linux-x86_64-256.53/kernel] Err
or 2
make[2]: *** [sub-make] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

--------------------------------------------------------------

I followed the steps as before. Do you think I should copy all that /etc/modprobe.d/nvidia-installer-disable-nouveau.conf contains to /etc/modprobe.d/blacklist.conf ?

Last edited by cristi92b; 05-23-2011 at 01:56 AM.
 
Old 05-23-2011, 02:06 AM   #10
zasavage
Member
 
Registered: Sep 2010
Location: Bloemfontein , South Africa
Distribution: Slackware 13.37 and Slackware 14
Posts: 201

Rep: Reputation: 6
@cristi92b

Have you by any chance upgraded your kernel or did you not do a full install ?

I use that driver everyday on 5 or 6 machines and not once has it failed on a stock full install slackware version !

Regards

LAwrence
 
Old 05-23-2011, 02:16 AM   #11
cristi92b
Member
 
Registered: May 2011
Posts: 91

Original Poster
Rep: Reputation: Disabled
I did not upgraded the kernel but I did a full install.
My kernel version is 2.6.37

Last edited by cristi92b; 05-23-2011 at 02:25 AM.
 
Old 05-23-2011, 02:23 AM   #12
zasavage
Member
 
Registered: Sep 2010
Location: Bloemfontein , South Africa
Distribution: Slackware 13.37 and Slackware 14
Posts: 201

Rep: Reputation: 6
Try this driver

download

and follow previous posters instructions

270.41.19 Certified
Release Date:

2011.05.20
Operating System:

Linux 64-bit
Language:

English (U.S.)
File Size:

47.3 MB

Regars

Lawrence
 
Old 05-23-2011, 02:30 AM   #13
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
Quote:
Originally Posted by cristi92b View Post
I followed the steps as before. Do you think I should copy all that /etc/modprobe.d/nvidia-installer-disable-nouveau.conf contains to /etc/modprobe.d/blacklist.conf ?
The installer will fail to even run if nouveau is loaded -- unless you force it to run.

Black list nouveau -- reboot to run level 3 NOT run level 4 and run the Nvidia installer as root from run level 3. As soon as you enter run level 4, nouveau is auto loaded.
 
Old 05-23-2011, 02:47 AM   #14
cristi92b
Member
 
Registered: May 2011
Posts: 91

Original Poster
Rep: Reputation: Disabled
@zasavage thanks! I'll try that

@disturbed1 that's what I did. With blacklisted nouveau you can not enter run level 4.
 
Old 05-23-2011, 03:53 AM   #15
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863Reputation: 4863
The solution is there in the error message. Your kernel source is not properly configured:
Quote:
echo " ERROR: Kernel configuration is invalid."; \
echo " include/generated/autoconf.h or include/config/auto.conf are
missing.";\
echo " Run 'make oldconfig && make prepare' on kernel src to fix it.
"; \
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Help. Nvidia Driver Issue on Debian amd64 feeblebrain Linux - Newbie 4 03-22-2011 10:20 PM
2.6.22-2-amd64 NVIDIA driver issues war1025 Debian 3 10-31-2007 10:31 AM
Nvidia driver w/ AMD64 + Mandrake10 Natfly Linux - Software 1 06-22-2004 01:36 PM
nVidia AMD64 Driver does not install Beaker Mandriva 0 06-14-2004 07:16 PM
Linux 9 (AMD64) and Nvidia driver goulartca Linux - Software 12 03-17-2004 11:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration