LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-03-2017, 11:41 PM   #1
ahTh6aaf
LQ Newbie
 
Registered: Jul 2017
Posts: 7

Rep: Reputation: Disabled
How to install VirtualGL in Slackware 14.2?


Hello!

I want to stream games to my old laptop from my slackware 14.2 machine. However, when I tried to install VirtualGL I'm having some issues following the configuration found in https://virtualgl.org/vgldoc/2_2_1/#hd005 ... I downloaded the source code, compiled and created the .txz file for the 32 and 64 versions following the BUILDING.md file.

I am able to do installpkg and run /opt/VirtualGL/bin/vglserver_config (y/y/n) which finished with an error related to nvidia:

Code:
rmmod: ERROR: module nvidia is in use by: nvidia_modeset
I added the root and my user to the vglusers group, rebooted, then connected via ssh to do the Sanity Check but in the command:

Code:
xdpyinfo -display :0
I'm getting:

Code:
Invalid MIT-MAGIC-COOKIE-1 keyxdpyinfo: unable to open display ":0"
Also, when I connect via VNC and when I run any program with vglrun, I'm getting the error:
Code:
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
Also, when I try to play dota I'm getting an OpenGL error :/
I'm running out of ideas with this program...

Thanks for any help!
 
Old 12-04-2017, 12:44 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,240
Blog Entries: 3

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
https://virtualgl.org/Main/HomePage
you want to use the uodated one that page you had was very old.
it all has been moved to github

https://github.com/VirtualGL/virtual...er/BUILDING.md

Last edited by Drakeo; 12-04-2017 at 12:45 AM.
 
Old 12-06-2017, 12:48 PM   #3
ahTh6aaf
LQ Newbie
 
Registered: Jul 2017
Posts: 7

Original Poster
Rep: Reputation: Disabled
Thanks for your reply.

I reinstalled vgl following the building instructions again, 32 and 64bit but vglserver_config gave the same error about nvidia:

Code:
# /opt/VirtualGL/bin/vglserver_config 

1) Configure server for use with VirtualGL
2) Unconfigure server for use with VirtualGL
X) Exit

Choose:
1

Restrict 3D X server access to vglusers group (recommended)?
[Y/n]
y

Restrict framebuffer device access to vglusers group (recommended)?
[Y/n]
y

Disable XTEST extension (recommended)?
[Y/n]
n
... Creating vglusers group ...
groupadd: group 'vglusers' already exists
Could not add vglusers group (probably because it already exists.)
... Granting read permission to /etc/opt/VirtualGL/ for vglusers group ...
... Creating /etc/modprobe.d/virtualgl.conf to set requested permissions for
    /dev/nvidia* ...
... Attempting to remove nvidia module from memory so device permissions
    will be reloaded ...
rmmod: ERROR: Module nvidia is in use by: nvidia_modeset
... Granting write permission to /dev/nvidia0 /dev/nvidiactl for vglusers group ...
... Granting write permission to /dev/dri/card0 for vglusers group ...
... Modifying /etc/X11/xorg.conf.d/99-virtualgl-dri to enable DRI permissions
    for vglusers group ...
... Adding vglgenkey to /etc/X11/xdm/Xsetup_0 script ...
... Enabling XTEST extension in /etc/X11/xdm/Xservers ...
... Setting default run level to 5 (enabling graphical login prompt) ...

Done. You must restart the display manager for the changes to take effect.

IMPORTANT NOTE: Your system uses modprobe.d to set device permissions. You
must execute rmmod nvidia with the display manager stopped in order for the
new device permission settings to become effective.
I ran this command in init 3.

In the same way, after rebooting, when running a program using vglrun I'm getting

Code:
$ vglrun glxgears
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object 'libvglfaker.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.


Last edited by ahTh6aaf; 12-06-2017 at 12:50 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie VirtualGL Help mpapet Linux - Desktop 1 10-20-2016 02:06 PM
How to select GPU using VirtualGL over VNC vwong Linux - Software 0 01-15-2016 06:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration