LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-12-2017, 04:57 PM   #1
bsmile
LQ Newbie
 
Registered: Oct 2017
Posts: 27

Rep: Reputation: Disabled
Red face how to get back source file as well as check whether x-win is xfce?


I tried to reduce space so I skipped getting the source file in time of installation, which turns out to be a big mistake. Now how can I possibly get the source file back to its intended location within the installed slackware instead of reinstalling it in the virtualbox? (I have reinstalled slackware with source files included, so this should not be an issue any more.)

Also the GUI looks very much like KDE although I specifically chose xfce as default, how can I double check that the current desktop is xfce instead of KDE? If KDE, how can I change to xfce for the next reboot?

I don't like to wait at the beginning of linux reboot, where can I change the booting setting to boot immediately?

Last edited by bsmile; 11-12-2017 at 06:03 PM.
 
Old 11-12-2017, 05:12 PM   #2
bsmile
LQ Newbie
 
Registered: Oct 2017
Posts: 27

Original Poster
Rep: Reputation: Disabled
just checked by setting /etc/inittab option 4 to 3 and reboot the system, then issue startxfce4 at command line to manually initialize xfce, and it turns out that indeed the system automatically goes to kde at booting time although I set the default to be xfce. I also checked with xwmconfig and indeed the default is xfce4, so how can I possibly do with this situation? Thanks,
 
Old 11-12-2017, 05:34 PM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,728

Rep: Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099
Runlevel 3 (console login) uses xwmconfig where you selected XFCE as the default. But in runlevel 4, when the display manager starts (which will be KDM if you did a full install) you make the choice of your desktop in the KDM dropdown menu before you login. That choice you make will remain the default afterwards, but you are correct that the initial OS default will be KDE.
 
Old 11-12-2017, 05:40 PM   #4
bsmile
LQ Newbie
 
Registered: Oct 2017
Posts: 27

Original Poster
Rep: Reputation: Disabled
I tried to make xfce as my default desktop by consulting https://superuser.com/questions/6859...t-system-start to manually revise it to be xfce, which works, but this is really not what I want as it seems I cannot change my default to KDE if needed. Also, it seems the very initial x is still KDE by that way, although after log in it changes to xfce. Is this what Alien mentioned "the initial OS default will be KDE"? Thanks

Last edited by bsmile; 11-12-2017 at 05:48 PM.
 
Old 11-12-2017, 05:46 PM   #5
bsmile
LQ Newbie
 
Registered: Oct 2017
Posts: 27

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
Runlevel 3 (console login) uses xwmconfig where you selected XFCE as the default. But in runlevel 4, when the display manager starts (which will be KDM if you did a full install) you make the choice of your desktop in the KDM dropdown menu before you login. That choice you make will remain the default afterwards, but you are correct that the initial OS default will be KDE.
Thanks for your input. I don't understand two things,

If runlevel 3, then it will stop at command line and I have to manually input startxfce4 to enter xfce.
If runlevel 4, I don't quite remember I had seen any dropdown menu during system booting.

Did I do anything wrong?

(It seems I cannot delete my post after it is posted, is this the case in LQ?)
 
Old 11-12-2017, 06:11 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,728

Rep: Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099
Quote:
Originally Posted by bsmile View Post
Thanks for your input. I don't understand two things,
If runlevel 3, then it will stop at command line and I have to manually input startxfce4 to enter xfce.
No. You run "xwmconfig" to select your default desktop, and then you run "startx" to start X with that default desktop. You should not have a reason to run startxfce4 directly.

Quote:
If runlevel 4, I don't quite remember I had seen any dropdown menu during system booting.
Did I do anything wrong?
Look again. If there's no session selection to be found then perhaps you are not starting KDM but XDM - in which case you did not perform a full install.

Quote:
(It seems I cannot delete my post after it is posted, is this the case in LQ?)
Deleting posts after you posted them is sneaky. What you can do is alter the text of your post after posting it. But I would suggest you only do that to add information, not to remove information.
 
Old 11-12-2017, 06:12 PM   #7
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware, Crux, NetBSD
Posts: 1,318

Rep: Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784
Quote:
Originally Posted by bsmile View Post
I don't like to wait at the beginning of linux reboot, where can I change the booting setting to boot immediately?
Change /etc/lilo.conf and run lilo afterwards:

Code:
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 30     # 3 seconds
 
Old 11-12-2017, 06:13 PM   #8
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,728

Rep: Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099Reputation: 4099
Quote:
Originally Posted by bsmile View Post
I tried to reduce space so I skipped getting the source file in time of installation, which turns out to be a big mistake. Now how can I possibly get the source file back to its intended location within the installed slackware instead of reinstalling it in the virtualbox? (I have reinstalled slackware with source files included, so this should not be an issue any more.)
This part of your OP does not make sense. Slackware runs just fine without adding all its source code. The only useful package which contains actual source code is the "kernel-source" package and you only need that one if you want to build a tweaked kernel of your own, or in case you want to compile a 3rd-party kernel module.
 
Old 11-12-2017, 06:37 PM   #9
bsmile
LQ Newbie
 
Registered: Oct 2017
Posts: 27

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
This part of your OP does not make sense. Slackware runs just fine without adding all its source code. The only useful package which contains actual source code is the "kernel-source" package and you only need that one if you want to build a tweaked kernel of your own, or in case you want to compile a 3rd-party kernel module.
I think I had skipped the kernel-source package when installing the slackware, which caused the issue. Now I reinstalled the system with the source files included, install guest addition is not an issue any more.
 
Old 11-12-2017, 06:56 PM   #10
magicm
Member
 
Registered: May 2003
Distribution: Slackware
Posts: 106

Rep: Reputation: 39
Quote:
I don't like to wait at the beginning of linux reboot, where can I change the booting setting to boot immediately?
Although, @Gerard Lally response will reduce the pause to 3 seconds, if you really want to boot immediately, there's a section in /etc/lilo.conf (when generated by 'liloconfig')

Code:
# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
# prompt
Uncomment the prompt line (remove the leading #), and then run lilo

Change /etc/lilo.conf and run lilo afterwards:

Of course this assumes you only have one OS to manage
 
Old 11-12-2017, 08:20 PM   #11
bsmile
LQ Newbie
 
Registered: Oct 2017
Posts: 27

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by magicm View Post
Although, @Gerard Lally response will reduce the pause to 3 seconds, if you really want to boot immediately, there's a section in /etc/lilo.conf (when generated by 'liloconfig')

Code:
# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
# prompt
Uncomment the prompt line (remove the leading #), and then run lilo

Change /etc/lilo.conf and run lilo afterwards:

Of course this assumes you only have one OS to manage
Thanks for your help, this issue is finally resolved. Another similar issue is a username/password needs to be input before the booting can proceed. Is there way to let OS choose the default username to log in without asking for password? (like what is done with ubuntu: https://askubuntu.com/questions/1752...rdin-text-mode) Thanks,
 
Old 11-12-2017, 09:38 PM   #12
Gordie
Member
 
Registered: Aug 2007
Distribution: Slackware, Puppy
Posts: 307

Rep: Reputation: 90
Quote:
Originally Posted by bsmile View Post
Thanks for your help, this issue is finally resolved. Another similar issue is a username/password needs to be input before the booting can proceed. Is there way to let OS choose the default username to log in without asking for password? (like what is done with ubuntu: https://askubuntu.com/questions/1752...rdin-text-mode) Thanks,

You really should mark this thread as solved and start a new thread for your new question.

AFAIK it will only work for KDE
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Reality check needed:Source file has no ./configure file??? theKbStockpiler Linux - Newbie 6 10-05-2017 08:11 AM
file association for wifi internet connection to error "interface down" (ubuntu 4.4.0+xfce dsktp env) win 7 non-genuine grubmember Dun El Linux - Newbie 21 10-13-2016 12:24 PM
[SOLVED] Xfce: I can't log out from Xfce and go back to the login prompt jayhel Slackware - Installation 11 03-31-2014 06:52 AM
[SOLVED] Folder and file permissions in back-up not the same as in the source vjramana Linux - General 11 07-17-2013 06:29 PM
Errors When I copied Win files from Lin back to Win! dougp25 Linux - General 2 09-15-2004 06:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration