LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-14-2013, 08:59 AM   #1
flokofcgulls
Member
 
Registered: Apr 2013
Posts: 79

Rep: Reputation: Disabled
Error for wireless request "Set Nickname" (8B1C)


Hey folks, back again! I have a mostly working system now, and I'm figuring out the whole Slackware wireless thing.

After reading up on networking in the Slackware beginner's guide and Alien BOB's wiki, I figured I would just need to make the networkmanager script executable and configure my network information...but it turned out to not be that easy.

After doing this, when I start X I have the networkmanager running in the tray, and I can configure all of my wireless information, but it would never connect. I started poking around in the scripts and removing comments from lines like IFNAME=wlan0, and wpa_supplicant. After tinkering a bit last night it actually did connect, but then I had to try to figure out exactly what fixed it, which led to the error in the thread title.

I get this error
Code:
/etc/rc.d/rc.M:  wlan0 information: 'Any ESSID'
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.
I see this at boot, and I also see it when I manually restart the interface during troubleshooting...and I'm not really sure what it means?

When I booted the laptop this morning to read the exact error, I noticed that wlan0 is getting an IP address from dhcpd at boot now (it wasn't last night) but I cannot ping anything from the CLI. I was able to load a page in Firefox last night for the moment it was working, but I'd like it to work from the command line also.

So I guess I'm a little confused about the functionality of rc.inet1 versus networkmanager at this point. I thought the idea of networkmanager was that you didn't have to manually edit the scripts (not that I mind), but this persistent error makes me think I'm missing something here.
 
Old 05-14-2013, 09:58 AM   #2
perbh
Member
 
Registered: May 2008
Location: Republic of Texas
Posts: 204

Rep: Reputation: 32
Just 'blank out' all the entries in rc.inet1.conf and only use networkmanager
 
Old 05-14-2013, 01:14 PM   #3
flokofcgulls
Member
 
Registered: Apr 2013
Posts: 79

Original Poster
Rep: Reputation: Disabled
By "blank out" I assume you mean to comment out all the lines I un-commented to return the file back to it's default state after installation. I wasn't expecting that to help since it wasn't working originally, but I decided to go ahead and try it just to see what happens. Oddly enough, after doing this the connection was still working in X (I didn't check it at the command line.)

So I deleted the connection from networkmanager, restarted, and re-created the connection again...and now it's back like it was originally. It just sits there, never connecting. I tried to manually restart it by running /etc/rc.d/rc.inet1 wlan0_restart and I see the same error from the thread title again...and no connection. I also tried disabling and re-enabling with the hardware switch on the laptop, no change there either.

This leads me to think that there's some other part of the system that's controlling this, and not the rc.inet1 or wpa_supplicant files, but all the Slackware documentation seems to indicate that those files are where it all happens?

Any other ideas?
 
Old 05-14-2013, 09:13 PM   #4
thirdm
Member
 
Registered: May 2013
Location: Massachusetts
Distribution: Slackware,OpenBSD
Posts: 49

Rep: Reputation: Disabled
I had a similar puzzle when I installed on the weekend. The messages you're showing, though, are both harmless. What does ifconfig show? Have you tried manually running iwconfig and wpa_supplicant? What about configuring temporarily with an open network to take wpa out of the picture as suggested in that blog entry?

But yeah, I didn't like those messages either. The nickname message, if you search the internet, is something all kinds of people get. Most hits I see it's part of their output and not the thing they're complaining about, since nickname, whatever it's for, is not important. See its entry in the iwconfig man page. Or run the command iwconfig wlan0 nick olodeon. You'll see the same error, just saying nicknames are not something your card deals in.

I made a small modification so I could set a variable to avoid the message. Not sure who I thought I was writing this for. You could just as well remove the lines here that set the nickname and be done with it, but here it is:
Code:
diff --git a/rc.d/rc.wireless b/rc.d/rc.wireless
index 51623d5..9df0d7d 100755
--- a/rc.d/rc.wireless
+++ b/rc.d/rc.wireless
@@ -196,12 +196,14 @@ if [ -n "$MODE" ] ; then
         fi
 fi
 # This is a bit hackish, but should do the job right...
-if [ ! -n "$NICKNAME" ] ; then
-    NICKNAME=$(/bin/hostname)
-fi
-if [ -n "$ESSID" -o -n "$MODE" ] ; then
+if [ "$NICKNAME" != "NICKNAME_UNSUPPORTED" ] ; then
+    if [ ! -n "$NICKNAME" ] ; then
+       NICKNAME=$(/bin/hostname)
+    fi
+    if [ -n "$ESSID" -o -n "$MODE" ] ; then
        echo "$0:  $IWCOMMAND nick $NICKNAME" | $LOGGER
        $IWCOMMAND nick $NICKNAME
+    fi
 fi
 # Regular stuff...
 if [ -n "$NWID" ] ; then
Then I set NICKNAME[4]=NICKNAME_UNSUPPORTED
in my rc.inet1.conf file.

The first part of your output, the 'Any ESSID' line is also confusing.
That's coming from the block in rc.wireless.conf between "START
SECTION TO REMOVE" and "END SECTION TO REMOVE". It's the INFO variable there
which this line in rc.wireless uses:
rc.wireless:[ -n "$VERBOSE" -a -n "$INFO" ] && echo "$0: $1 information: '$INFO'"
But those are the only two occurances of this INFO variable, so if
you partly take the blog's advice and put your settings in rc.inet1.conf
instead of rc.wireless.conf, that INFO thing will sneak into your
output even when you specify an ESSID, I think.

I deleted rc.wireless.conf as Alien Bob suggested elsewhere in same blog message.

So it sounds like you have a problem, but not one related to these messages.
 
Old 05-15-2013, 11:12 AM   #5
flokofcgulls
Member
 
Registered: Apr 2013
Posts: 79

Original Poster
Rep: Reputation: Disabled
Thanks for this new info, this was interesting! I messed with this for a while last night but I was too tired to post a reply.

While I was troubleshooting last night, I decided to uncheck the "enable wireless" box in networkmanager, and after doing that I could not re-check it again, and my wireless was permanently off, not even the hardware switch would turn it back on. Mysteriously, when I turned it on this morning to work on a reply, this was no longer the case and everything was back like it was. Seriously flaky! Starting to think maybe I should look into this wicd thing I've been hearing about...

So anyways, after reading through this latest reply, I discovered that if I manually run iwconfig from the terminal in KDE, it immediately prompts for the KDEWallet password, and then connects, no problem! If it will behave that way consistently, I can live with that, although it makes me think that the whole networkmanager thing is largely unnecessary if I still have to start it from the command line?

Also worth noting that I never saw the nickname error this morning that I was getting originally.

So, at the moment, wireless is working in KDE, but I'm still not able to connect outside of KDE. If I run iwconfig and wpa_supplicant before starting KDE, I get the following:

Code:
ioctl[SIOCSIWSCAN]: Device or resource busy
wlan0: Failed to initate AP Scan
This repeats four times, and then the following happens:

Code:
wlan0: Trying to associate with "my router's MAC here" (SSID='my SSID here' freq=2437 MHz)
wlan0: Associated with "my router's MAC here"
wlan0: WPA: No SSID info found (msg 1 of 4)
wlan0: CTRL-EVENT-DISCONNECTED bssid="my router's MAC here" reason=0
This second part repeats indefinitely until I manually kill it.

So we've made a little progress I guess. Sorry if this thread is kinda all over the place, but my problems getting wireless working have been incredibly inconsistent, seems like things are changing just from one day to the next without me making any changes in between.

I've done so much tinkering between these files I'm considering reformatting again and starting from scratch just to see if what I've learned so far will continue to work on a fresh install, but I'd like to wait and see if we can get it working on both sides first before taking that step.
 
Old 05-15-2013, 02:15 PM   #6
thirdm
Member
 
Registered: May 2013
Location: Massachusetts
Distribution: Slackware,OpenBSD
Posts: 49

Rep: Reputation: Disabled
When I last used Linux regularly there were not wireless cards, so I'm unfamiliar with all the helper programs (networkmanager, wicd, ...?). I also don't know anything about KDE. For me, ignoring all that stuff and focusing on the following files and programs (and their associated man pages, the slackware book, the brief documentation on the Slackware web page, and Alien Bob's "Configuring your network in Slackware" article) did the trick and wasn't painful:
Files: /etc/rc.d/{rc.inet1,rc.inet1.conf,rc.wireless,rc.wireless.conf}, /etc/wpa_supplicant.conf
Programs: wpa_supplicant, ifconfig, iwconfig, dmesg.

I think you should pick an approach and stick with it rather than bouncing around. Either get it working by editing config files or stay out of your text editor and let a program do the work. perbh's response to you suggests this networkmanager thing, whatever it is, may parse or set values in the conf files. If that's the case, you may confuse it editing them manually.

If it were me, I'd focus on getting wireless running at the command line by editing /etc/ files without having KDE running and without any helper tools. If that doesn't go well, simplify further by trying to configure wireless using no WPA (configure you router to be open), see if that much works reliably. Then incrementally add back in the additional pieces you need or want.

The messages you have there, "associate with "my router's MAC here"" and so on, suggest a script is pulling values from a variable assigned in a configuration file that neither you nor a program acting on your behalf filled in with reasonable values. But I don't recognize that phrase from the files I had to change (I'm not in front of my slackware system right now). If you grep -R "my router" /etc what file do you see it in?

At this point, I agree that it would be wise to get back to a clean slate. I don't know if that requires a reinstall necessarily. If you check the timestamps on the files changed under /etc you should see what you might have changed. Then maybe you could reinstate the originals of those files from slackware packages on the cd somehow (but first diff them to see what you changed). I don't have my slackware system in front of me, but I'd guess you could work back from file to package it belongs to using info in /var/adm/packages. There's probably a tool (other than grep?) to do that search for you, but I don't know what it might be.

Generally the first thing I do when I install a new system is to put the /etc/ directory into a git repository, which makes it easy to backtrack when you get yourself into trouble like this. If you don't use git or a similar tool, you could do the equivalent with rsync snapshots or saving off tar archives at each step in your process.
 
Old 05-15-2013, 04:29 PM   #7
flokofcgulls
Member
 
Registered: Apr 2013
Posts: 79

Original Poster
Rep: Reputation: Disabled
I've only been using Linux regularly for the past year, and all of these problems are throwing me into situations where I have little to no experience, which to me is a good thing. I'm using it as an opportunity to learn all the details of the system, with the goal of eventually mastering it. Most of the replies I get here require me to go do a few more hours of research and reading, experiment with what I've learned, and then report my results. So if I ever sound like maybe I don't know what I'm doing, that's probably why.

Quote:
I think you should pick an approach and stick with it rather than bouncing around. Either get it working by editing config files or stay out of your text editor and let a program do the work. perbh's response to you suggests this networkmanager thing, whatever it is, may parse or set values in the conf files. If that's the case, you may confuse it editing them manually.
I definitely agree with this philosophy, and I'm starting to think my ideas about how this is "supposed" to work might be a bit off. Generally when I think of a Linux system, I mentally separate it into the shell, and XWindows, with X being sort of an advanced front-end built on top of the command line. I had originally envisioned this networkmanager application to be a sort of modular front-end specifically for handling the networking tasks that are being performed by all these scripts and config files. This idea led to my reasoning that the graphical network configuration tools and the script-based tools were essentially one in the same, with the graphical tools simply providing a different way to interface with them. Since I'm still learning how all this works under the hood, I thought it would be convenient to work with the graphical utility to get things up and running quickly, and then exploring the text files at my own pace, although it hasn't worked out this way.

Quote:
If it were me, I'd focus on getting wireless running at the command line by editing /etc/ files without having KDE running and without any helper tools. If that doesn't go well, simplify further by trying to configure wireless using no WPA (configure you router to be open), see if that much works reliably. Then incrementally add back in the additional pieces you need or want.
I'm liking this idea as well.

Quote:
The messages you have there, "associate with "my router's MAC here"" and so on, suggest a script is pulling values from a variable assigned in a configuration file that neither you nor a program acting on your behalf filled in with reasonable values. But I don't recognize that phrase from the files I had to change (I'm not in front of my slackware system right now). If you grep -R "my router" /etc what file do you see it in?
This seems reasonable, but the values shown in the error message are indeed correct, so it's not clear exactly what it's not liking? Running that grep command with my router's MAC address turned up no results, so it must have been pulling it directly from the AP I guess?

Quote:
At this point, I agree that it would be wise to get back to a clean slate. I don't know if that requires a reinstall necessarily. If you check the timestamps on the files changed under /etc you should see what you might have changed. Then maybe you could reinstate the originals of those files from slackware packages on the cd somehow (but first diff them to see what you changed). I don't have my slackware system in front of me, but I'd guess you could work back from file to package it belongs to using info in /var/adm/packages. There's probably a tool (other than grep?) to do that search for you, but I don't know what it might be.
I hadn't considered this, but I'm curious to try it now. The only files I've made any changes to are /etc/rc.d/rc.inet1.conf and /etc/wpa_supplicant.conf, so if I can find those two files on the disc I would think it'd be easy to restore them. I'll look into it!

Since I originally opened this thread about the nickname error, I should probably close it and start a new one (after some more troubleshooting of course.)

So for anyone who happens to read this...this error is unrelated to any wireless communication or configuration, and shouldn't be causing any wireless problems. For slightly more detailed info, run man iwconfig and look under parameters.

Thanks for all the help and ideas, as always!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error for wireless request "Set Nickname" (8B1C) -- /etc/rc.d/rc.inet1.conf hellbillyJoker Linux - Networking 1 04-06-2010 07:24 PM
Fedora 10 iwconfig error: Error for wireless request "Set Encode" (8B2A) :SET failed mishkind Linux - Laptop and Netbook 2 05-10-2009 02:43 PM
Error for wireless request "Set Nickname" robogymnast Linux - Wireless Networking 5 09-23-2008 07:26 AM
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 01:16 PM
Wireless autoconnect (error for wireless request "set Nickname" (8B1C)) hellasyoda Slackware 7 05-19-2008 01:12 PM


All times are GMT -5. The time now is 07:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration