LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-03-2008, 03:22 PM   #1
jsmith6
Member
 
Registered: Feb 2006
Distribution: Slackware 13.1 / 13.37
Posts: 91

Rep: Reputation: 16
DisplaySize on Xorg.conf with nv/nvidia doesn't change my DPI


I used to set this on xorg.conf:

Code:
DisplaySize 270 200
Which gave me around 92 DPI in my 17 inch display. But on my new hardware, it just doesn't work. Not in "nv" nor in "nvidia" drivers.

The new hardware is:
CPU: Intel 8200
MOBO: Gigabyte EP35-DS4
RAM: 4GB
SOUND: onboard
VGA: Nvidia 8800GT

I tried setting UseEdidDpi which I found on the Gentoo Wiki but nothing changed.

When I type:

Code:
xdpyinfo | grep dimensions
xdpyinfo | grep resolution
xrdb -query | grep dpi
I get this:

Code:
  dimensions:    1024x768 pixels (333x241 millimeters)
  resolution:    78x81 dots per inch
Xft.dpi:	91
The last line, "Xft.dpi: 91" comes from my ~/.Xresources which, in an effort to enforce 91 DPI, has this line: "Xft.dpi: 91". Removing that line and adding it back doesn't change anything.

So, how can I set/change my DPI?
 
Old 07-03-2008, 08:14 PM   #2
maddox1976
LQ Newbie
 
Registered: Oct 2005
Distribution: Slackware 10.2
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by jsmith6 View Post
I used to set this on xorg.conf:

Code:
DisplaySize 270 200
Which gave me around 92 DPI in my 17 inch display. But on my new hardware, it just doesn't work. Not in "nv" nor in "nvidia" drivers.

The new hardware is:
CPU: Intel 8200
MOBO: Gigabyte EP35-DS4
RAM: 4GB
SOUND: onboard
VGA: Nvidia 8800GT

I tried setting UseEdidDpi which I found on the Gentoo Wiki but nothing changed.

When I type:

Code:
xdpyinfo | grep dimensions
xdpyinfo | grep resolution
xrdb -query | grep dpi
I get this:

Code:
  dimensions:    1024x768 pixels (333x241 millimeters)
  resolution:    78x81 dots per inch
Xft.dpi:	91
The last line, "Xft.dpi: 91" comes from my ~/.Xresources which, in an effort to enforce 91 DPI, has this line: "Xft.dpi: 91". Removing that line and adding it back doesn't change anything.

So, how can I set/change my DPI?

I use this in xorg.conf and works for me:

Section "Device"

VideoRam 128
# Insert Clocks lines here if appropriate
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce FX 5700 Ultra"
Option "NvAGP" "1"
Option "RenderAccel" "true"
Option "ConnectedMonitor" "CRT"
Option "IgnoreDisplayDevices" "DFP, TV"
Option "UseEDID" "FALSE"
Option "DPI" "96 x 96"
 
Old 07-03-2008, 11:16 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540
I have a 17 inch LCD monitor with a native resolution of 1280 x 1024.

Usually I boot into runlevel 3. In my /usr/bin/startx I have the following:

serverargs="-dpi 120 -ac -nolisten tcp"

Occasionally I boot into runlevel 4 and I use the KDM display manager to manage logins. In my /etc/kde/kdm/kdmrc I have the following:

[X-:*-Core]
ServerArgsLocal=-dpi 120 -ac -nolisten tcp

I always boot into X at 120 dpi.

As a test, to xorg.conf I added a DisplaySize option for 96 x 96 dpi (DisplaySize 338 271). The DisplaySize option was ignored because the startx option took precedence.

You can manually test at the command line by running:

startx -- -dpi 92
 
Old 07-04-2008, 06:58 AM   #4
jsmith6
Member
 
Registered: Feb 2006
Distribution: Slackware 13.1 / 13.37
Posts: 91

Original Poster
Rep: Reputation: 16
One of these options made my CRT shut off when starting X:

Code:
VideoRam 128
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "RenderAccel" "true"
Option "ConnectedMonitor" "CRT"
Option "IgnoreDisplayDevices" "DFP, TV"
Option "UseEDID" "FALSE"
Option "DPI" "96 x 96"
Not a problem though, I just used only "DPI" "96 x 96" and now I have 96 DPI inside X. That's very nice, the fonts look smooth again :-) The only problem with this solution is that this works only with the "nvidia" driver, it doesn't work with "nv".

Then I tried this at the command line:

Code:
startx -- -dpi 92
And it works even with "nv". I didn't want to edit /usr/bin/startx (although I can keep a backup and so on) so I just created a new alias on /etc/profile.d/coreutils-dircolors.sh with:

Code:
alias startx='startx -- -dpi 96'
Thank you!
 
Old 07-04-2008, 07:42 AM   #5
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
It's been a while since I used nvidia, but I believe the line

Option "UseEDID" "FALSE"

is the option that is required to get DisplaySize to act as expected with the nvidia proprietary driver.

HTH
 
Old 07-04-2008, 03:10 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540
Quote:
alias startx='startx -- -dpi 96'
Good thinking with the alias!

Question:

1. Start X from runlevel 3 using your alias.
2. Toggle to another console session (Ctrl-Alt-F2).
3. Start X from there using your alias.

Does X start in the second console session?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia xorg.conf OR X windows xorg.conf? machines Slackware 3 04-06-2008 02:10 PM
DisplaySize and Modes in xorg ignored tramni1980 Slackware 5 12-14-2007 11:32 AM
Gentoo / Nvidia / Xorg.conf GaMeS Linux - Newbie 8 10-29-2005 05:38 AM
xorg.conf and nvidia problem scarryharry Slackware 8 05-20-2005 04:00 PM
NVidia TV out thru xorg.conf jobless_joe Linux - Software 7 02-22-2005 11:59 PM


All times are GMT -5. The time now is 04:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration