LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-04-2005, 08:16 AM   #1
samills70
Member
 
Registered: May 2004
Posts: 32

Rep: Reputation: 15
default terminal (on startup) too large...


Hi everyone,

I just installed linux 10.1 on my system and it seems that the run level 3 terminal (the one by default on startup I suppse it's called the curses terminal) is running at 1024x768 and I want to run it at 800x600. I have tried changing the lilo.conf under /etc to "vga = normal" but even this does not change the resolution. I know it's something small but I think it will be helpful with my learning process.

Regards
The_hatter
 
Old 04-04-2005, 08:21 AM   #2
Nobber
Member
 
Registered: Jun 2002
Location: Nova Scotia
Distribution: Debian (home), Kubuntu 7.04 (work)
Posts: 265

Rep: Reputation: 30
Have you tried setting the "vga=" line in /etc/lilo.conf to "vga=771", then running /sbin/lilo (to reinstall lilo), and rebooting?
 
Old 04-04-2005, 08:43 AM   #3
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Rep: Reputation: 30
as nobber suggests.

here's a full table of vga values:
Code:
colour depth     | 640x480  800x600  1024x768 1280x1024
256        (8bit)|   769      771       773      775
32000     (15bit)|   784      787       790      793
65000     (16bit)|   785      788       791      794
16.7 Mil.(24bit) |   786      789       792      795
 
Old 04-04-2005, 08:55 AM   #4
samills70
Member
 
Registered: May 2004
Posts: 32

Original Poster
Rep: Reputation: 15
Thanks guys

Been reading through the man pages on lilo but obviously didn't read them close enough to notice that you have to *lilo* under sbin to rewrite new file. Now I was also just curious, I can see there is a way to change resolution size but I don't see an option for setting the refresh rate... or is that only done once xfree86 is started up?

Regards
Me
 
Old 04-04-2005, 09:03 AM   #5
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Rep: Reputation: 30
AFAIK, yes only in X.
 
Old 04-04-2005, 09:21 AM   #6
Nobber
Member
 
Registered: Jun 2002
Location: Nova Scotia
Distribution: Debian (home), Kubuntu 7.04 (work)
Posts: 265

Rep: Reputation: 30
If you want finer control over your video settings in a hi-res text console, you could try SVGATextMode. A guide to setting it up can be found here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome terminal, default browser? c_olin3404 Slackware 3 07-21-2012 10:36 PM
gnome-terminal default geometry dunric Linux - Software 1 11-09-2005 02:02 AM
startup in a terminal chrisbhall Linux - Newbie 6 10-07-2004 02:20 PM
Executing files in a terminal by default Vnet1 Linux - Newbie 2 03-24-2004 12:54 PM
terminal at startup? lyinghappyeyes Linux - Newbie 2 08-27-2001 02:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration