LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-06-2004, 03:10 AM   #1
hayesben
LQ Newbie
 
Registered: Jul 2004
Location: Peterborough, England
Distribution: Slackware 10 (moving from RHEL 3 WS)
Posts: 27

Rep: Reputation: 15
Alsa & snd-intel8x0 error


I'm currently running Slackware 10 on a Asus Terminator DDR system (Athlon processor & SiS chipset). I recently re-installed Slack 10 and used swaret to update & upgrade the system. But on reboot, the X server kept falling over (back to a command prompt). After installing Dropline gnome, this overcame the Xserver issue. But, the Alsa system isn't running. The error that I am getting on bootup is a missing module - snd-intel8x0.

Question(s):

1) How do I go back and recreate this module? (this module is from the initial system install)
2) Has anyone else noticed this this problem when upgrading via swaret?

Ben
 
Old 10-06-2004, 03:18 AM   #2
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 243Reputation: 243Reputation: 243
The more quick and efficient solution in my mind is :

download alsa driver :
ftp://ftp.alsa-project.org/pub/drive...1.0.6a.tar.bz2

then unpack and configure it with only your audio card :
./configure --prefix=/usr \
--sysconfdir=/etc --with-oss=yes \
--with-sequencer=yes --with-cards=intel8x0

make
removepkg alsa-driver
make install (or checkinstall, up to you)
alsaconf
alsamixer
alsactl store
 
Old 10-06-2004, 10:31 AM   #3
hayesben
LQ Newbie
 
Registered: Jul 2004
Location: Peterborough, England
Distribution: Slackware 10 (moving from RHEL 3 WS)
Posts: 27

Original Poster
Rep: Reputation: 15
Cedrik

Thanks for that tip! I'll give that a go when I get back home tonight. That thought never crossed my mind.

Ben
 
Old 10-14-2004, 05:11 PM   #4
DAChristen29
Member
 
Registered: Dec 2002
Location: Johnstown, Co
Distribution: Mint (debian edition)
Posts: 541

Rep: Reputation: 30
im having the same problem. i get to the running of "alsamixer" part, then it says "no mixer elems found". what gives?
 
Old 10-14-2004, 07:41 PM   #5
usercsr
Member
 
Registered: Sep 2003
Location: Little Rock, Arkansas
Distribution: Slackware-Current
Posts: 129

Rep: Reputation: 15
regarding the "no mixer elems found" part, try adding "snd-intel8x0m" to the /etc/hotplug/blacklist file. reboot and run alsaconf
 
Old 10-21-2004, 04:34 PM   #6
Wondre
LQ Newbie
 
Registered: Jan 2003
Location: SoCal
Distribution: SlackWare 10
Posts: 17

Rep: Reputation: 0
blacklisting snd-intel8x0m did it for me. I now have sound for the first time ever in slackware (10).

Thanks, usercsr!!

add "snd-intel8x0m" to /etc/hotplug/blacklist
reboot
alsaconf (follow defaults)
 
Old 11-22-2004, 11:50 AM   #7
DAChristen29
Member
 
Registered: Dec 2002
Location: Johnstown, Co
Distribution: Mint (debian edition)
Posts: 541

Rep: Reputation: 30
when back to slackware 10 from suse 9.1, and got sound working again by blacklisting it.

thanks for the blacklisting suggestion.
 
Old 12-26-2004, 01:28 PM   #8
Adrohak
Member
 
Registered: Jun 2004
Location: Florida
Distribution: Gentoo
Posts: 148

Rep: Reputation: 15
I was having problems with this as well. I followed the steps and still had no sound. I ran alsaconf again and saw a message it displayed right before exiting and managed to highlight it:
Code:
/lib/modules/2.4.22/kernel/sound/acore/snd-page-alloc.o: insmod snd-intel8x0 failed
What would cause this?
 
Old 12-26-2004, 01:56 PM   #9
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 243Reputation: 243Reputation: 243
What steps did you follow ?
 
Old 12-26-2004, 02:55 PM   #10
Adrohak
Member
 
Registered: Jun 2004
Location: Florida
Distribution: Gentoo
Posts: 148

Rep: Reputation: 15
Quote:
Originally posted by Cedrik
download alsa driver :
ftp://ftp.alsa-project.org/pub/drive...1.0.6a.tar.bz2

then unpack and configure it with only your audio card :
./configure --prefix=/usr \
--sysconfdir=/etc --with-oss=yes \
--with-sequencer=yes --with-cards=intel8x0

make
removepkg alsa-driver
make install (or checkinstall, up to you)
alsaconf
alsamixer
alsactl store
 
Old 12-26-2004, 04:37 PM   #11
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
If I'm not mistaken, 9.1 comes with precompiled modules for ALSA. Or did you recompile your kernel and brake those?
 
Old 12-26-2004, 04:38 PM   #12
Adrohak
Member
 
Registered: Jun 2004
Location: Florida
Distribution: Gentoo
Posts: 148

Rep: Reputation: 15
Quote:
Originally posted by WMD
If I'm not mistaken, 9.1 comes with precompiled modules for ALSA. Or did you recompile your kernel and brake those?
Recompiled and broke them.
 
Old 12-26-2004, 04:42 PM   #13
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
Ok...my suggestion is to run just ./configure, without all those options. Proceed as usual after that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing ALSA: insmod snd-intel8x0 fails. BWebb Linux - Newbie 21 01-04-2007 10:01 AM
snd-intel8x0 can't be found after recompiling 2.4.26(NOT AN AVARAGE ALSA QUESTION!!!) kornerr Linux - General 5 06-02-2005 12:02 PM
snd-intel8x0, alsamixer and more jasone Slackware 7 04-09-2005 04:33 AM
ALSA & 2.4.27/2.6.8.1,snd.o KMcD Slackware 2 08-27-2004 07:57 AM
I say snd-intel8x0, you say i810_audio! - ALSA on P4GE-V motherboard robertmarkbram Linux - Hardware 0 06-06-2003 03:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration