LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-09-2017, 11:36 PM   #1
Geist
Member
 
Registered: Jul 2013
Distribution: Slackware 14 / current
Posts: 46

Rep: Reputation: Disabled
[JACK/ALSA] Timidity++ not producing any sound under Jack using its ALSA output since a "current" upgrade.


Solution, for now:
Turns out the libao output drivermode thingamajigger works fine.
Good enough to hold me over to a clean system session eventually.

--------------------------------------------------------------------------------------------------------
I'm sure everyone can taste the vomit in their mouthes at that problem already.

Anyway, I'm using JACK 1 as my everyday audio solution. To get ALSA output I use loopback devices and some copypasted asoundrc voodoo I know naught about.

Here it is:
Code:
# playback PCM device: using loopback subdevice 0,0
pcm.amix {
    type dmix
        ipc_key 219345
        slave.pcm "hw:Loopback,0,0"
        slave.period_time 0
        slave.buffer_time 0
        slave.period_size 2048    # jm: much smoother than 1024/8192!
        slave.buffer_size 32768
        slave.rate 48000

}

# capture PCM device: using loopback subdevice 0,1
pcm.asnoop {
  type dsnoop
  ipc_key 219346
  slave.pcm "hw:Loopback,0,1"
}

# duplex device combining our PCM devices defined above
pcm.aduplex {
  type asym
  playback.pcm "amix"
  capture.pcm "asnoop"
}

# ------------------------------------------------------
# for jack alsa_in and alsa_out: looped-back signal at other ends
pcm.ploop {
  type plug
  slave.pcm "hw:Loopback,1,1"
}

pcm.cloop {
  type dsnoop
  ipc_key 219348
  slave.pcm "hw:Loopback,1,0"
}

# ------------------------------------------------------
# default device

pcm.!default {
  type plug
  slave.pcm "aduplex"
}
pcm.card0 {
  type plug
  slave.pcm "aduplex"
}
It seems to be one of those standard things Google spits at you when you look for that kinda thing.

This works fine, everything except Timidity++ is working out fine SDL Applications, Firefox, the works.
EVen Timidity++ works fine using its JACK driver, but there are some complications in a certain use case.

Which is using GNU Solfege.
A program for musical ear training and whatnot. It generates a lot of MIDI data and since Timidity++ doesn't seem to have a JACK based daemon mode (very likely PEBKAC, wouldn't be surprised, but alas), the only way to hear anything is spawn a new instance of a "one shot" Timidity++ instance every time.

This wouldn't be so bad in theory but it produces some crackling which isn't so nice on the ears.

I recompiled Timidity++ a bunch of times. I tried it with and without JACK, I tried different SBOpkg repos, etc.

After a big, big update using the "current" branch which I pushed ahead of me for ages and therefore had a metric bleeptonne of new packages, it suddenly stopped.
Checked /etc/asound configs and everything, too.

I can't suss this out. I tried downgrading the alsa libs and whatnot to the stable release and recompiling things, but that too didn't work out. Possibly PEBKAC again since that introduced some weirdness with some other programs I didn't write down.

Any from the top of your heads help to possibly avoid a "clean house" and everything?
Which I will do if this can't be solved more or less effortlessly. Including your efforts.

Last edited by Geist; 09-10-2017 at 04:13 AM.
 
Old 09-09-2017, 11:46 PM   #2
Darth Vader
Senior Member
 
Registered: May 2008
Location: Romania
Distribution: DARKSTAR Linux 2008.1
Posts: 1,290

Rep: Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525
You say nothing about the PulseAudio...

You do not noticed it in your system?

I ask this because the PulseAudio and JACK are friendly just like a dog with a cat.

Last edited by Darth Vader; 09-10-2017 at 07:35 PM.
 
Old 09-10-2017, 03:02 AM   #3
Geist
Member
 
Registered: Jul 2013
Distribution: Slackware 14 / current
Posts: 46

Original Poster
Rep: Reputation: Disabled
I commented out the "standard rerouting to pulse" directive in /etc/asound.conf

autospawn = no
allow-autospawn-for-root = no

is also in the pulse client config.

Is that not enough to banish the pulse demon?
But you're right, I'll double check the pulse stuff. The torrent of "new configs" after the update made my eyes roll back into my head.
I might have messed up some merging.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] USB sound devices, ALSA, and JACK pcCoder Linux - Hardware 11 12-17-2015 09:24 PM
Getting all programs that use sound to use the JACK driver (through alsa or oss) somnum Linux - Hardware 3 03-03-2011 06:28 PM
Bristol 10.4 configure not finding JACK,ALSA, or "X11 include file" on Ubuntu studio scwerllguy Linux - Software 7 06-03-2007 05:43 PM
Sound Problems (headphone jack) with Alsa specialist125 Linux - Laptop and Netbook 5 03-12-2007 12:50 AM
Linux sound - oss/alsa/arts/esd/jack - AAAARGH dcs3jah Linux - Software 3 08-07-2006 06:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration