LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > PrathamOS
User Name
Password
PrathamOS This forum is for the discussion of PrathamOS.

Notices


Reply
  Search this Thread
Old 07-18-2018, 02:22 AM   #16
ThePrathamOS
LQ Newbie
 
Registered: Jun 2018
Posts: 26

Rep: Reputation: Disabled

Quote:
Originally Posted by zaivala View Post
I tried the latest version of Discord, I tried installing the Mullvad app (I can get Mullvad through other ways of tweaking VPN usage, but the app is so easy and works in variants of Ubuntu 16.04 but not 18.04), and I tried installing my favorite Office package, SoftMaker Office. Each one reported having a dependency not met -- just one, each, with two of them being a library. I may or may not be able to find a way to install those libraries, but I'm really not THAT much a power user.
I am going to get all of them working for u...
give me a day...
 
Old 07-20-2018, 01:10 AM   #17
ThePrathamOS
LQ Newbie
 
Registered: Jun 2018
Posts: 26

Rep: Reputation: Disabled
Quote:
Originally Posted by zaivala View Post
I tried the latest version of Discord, I tried installing the Mullvad app (I can get Mullvad through other ways of tweaking VPN usage, but the app is so easy and works in variants of Ubuntu 16.04 but not 18.04), and I tried installing my favorite Office package, SoftMaker Office. Each one reported having a dependency not met -- just one, each, with two of them being a library. I may or may not be able to find a way to install those libraries, but I'm really not THAT much a power user.


Open Terminal & execute commands one by one...Will install all Three...

But MullVad has problems itself...its mentioned on their site.so we will have to wait till it gets sorted out..

https://mullvad.net/en/guides/instal...-client-linux/
-------------

cd Downloads
setupapt
axel https://dl.discordapp.net/apps/linux...cord-0.0.5.deb
sudo apt-get install libc++1 libc++abi1 -y
sudo gdebi -n discord-0.0.5.deb
axel -n 50 http://www.softmaker.net/down/softma...3-01_amd64.deb
sudo gdebi -n softmaker-office-2018_933-01_amd64.deb
wget https://mullvad.net/media/client/mullvad_67-1_all.deb
wget http://archive.ubuntu.com/ubuntu/poo...ntu1_amd64.deb
sudo gdebi -n libappindicator1_12.10.1+18.04.20180322.1-0ubuntu1_amd64.deb
wget http://archive.ubuntu.com/ubuntu/poo...ntu1_amd64.deb
sudo gdebi -n python-appindicator_12.10.1+18.04.20180322.1-0ubuntu1_amd64.deb
sudo apt-get install python-appdirs python-netifaces resolvconf -y
sudo gdebi -n mullvad_67-1_all.deb
 
Old 07-21-2018, 12:55 PM   #18
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 129
Blog Entries: 12

Rep: Reputation: 14
Mullvad has problems with 18.04-based distros. Worked fine in other Debian and Ubuntu from 17.10 and earlier. Anyhow, I can find a way around that through openvpn or a similar program, I'm using it (can't remember the name) to get Mullvad to work in 18.04-based distros (Ubuntu MATE and Linux Mint 19).

I have not tried installing through Terminal, only using GDebi, which has worked. (referring to all three programs) I will try that and report back.
 
Old 07-21-2018, 01:06 PM   #19
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 129
Blog Entries: 12

Rep: Reputation: 14
zaivala@zaivala-PrathamOS-201807210141:~/Downloads/Linux Apps$ sudo gdebi mullvad*
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: resolvconf

zaivala@zaivala-PrathamOS-201807210141:~/Downloads/Linux Apps$

=====

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: libc++1

zaivala@zaivala-PrathamOS-201807210141:~/Downloads/Linux Apps$


=====

zaivala@zaivala-PrathamOS-201807210141:~/Downloads/Linux Apps$ gdebi softmaker-office-2016_765-01_i386.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: libxmu6

zaivala@zaivala-PrathamOS-201807210141:~/Downloads/Linux Apps$
 
Old 07-21-2018, 02:04 PM   #20
ThePrathamOS
LQ Newbie
 
Registered: Jun 2018
Posts: 26

Rep: Reputation: Disabled
Quote:
Originally Posted by zaivala View Post
zaivala@zaivala-PrathamOS-201807210141:~/Downloads/Linux Apps$ sudo gdebi mullvad*
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: resolvconf

zaivala@zaivala-PrathamOS-201807210141:~/Downloads/Linux Apps$

=====

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: libc++1

zaivala@zaivala-PrathamOS-201807210141:~/Downloads/Linux Apps$


=====

zaivala@zaivala-PrathamOS-201807210141:~/Downloads/Linux Apps$ gdebi softmaker-office-2016_765-01_i386.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: libxmu6

zaivala@zaivala-PrathamOS-201807210141:~/Downloads/Linux Apps$


Please run the commands in the exact order...
also please run

sudo apt-get install -f

before trying again...the apt-repo might be corrupted..
 
Old 07-22-2018, 11:37 PM   #21
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 129
Blog Entries: 12

Rep: Reputation: 14
I will try that tomorrow.

In the meantime, I went to update my copy, and was given a download link which started a download of an .api program. PrathamOS asked me if I wanted to open it with FoxIt Reader or Other. What do I use to do this update?
 
Old 07-23-2018, 12:10 AM   #22
ThePrathamOS
LQ Newbie
 
Registered: Jun 2018
Posts: 26

Rep: Reputation: Disabled
Quote:
Originally Posted by zaivala View Post
I will try that tomorrow.

In the meantime, I went to update my copy, and was given a download link which started a download of an .api program. PrathamOS asked me if I wanted to open it with FoxIt Reader or Other. What do I use to do this update?

Just open a terminal and write prathamos-update and press enter...updates will be installed...
 
Old 07-23-2018, 12:49 AM   #23
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 129
Blog Entries: 12

Rep: Reputation: 14
LOL I used sudo apt update, upgrade, and autoremove. I;ll try yours and see if anything changes.
 
Old 07-23-2018, 10:31 AM   #24
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 129
Blog Entries: 12

Rep: Reputation: 14
Quote:
Just open a terminal and write prathamos-update and press enter...updates will be installed...
I tried that and nothing happened. I tried it again and was told it was already running. Seven hours later, it said it was still running. I shut the computer down. I have very fast Internet, should not be the case. This morning I opened it up again and tried.

zaivala@zaivala-PrathamOS-201807210141:~$ prathamos-update
/usr/bin/prathamos-update: line 58: mpv: command not found
Another Instance Is Already Running!!
zaivala@zaivala-PrathamOS-201807210141:~$


Despite the updates I did using sudo apt upgrade (reported yesterday), I still report as running 1.0, not 1.2.
 
Old 07-23-2018, 10:33 AM   #25
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 129
Blog Entries: 12

Rep: Reputation: 14
zaivala@zaivala-PrathamOS-201807210141:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
libavresample3
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.
zaivala@zaivala-PrathamOS-201807210141:~$
 
Old 07-24-2018, 01:50 PM   #26
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: ferenOS 2017.04, SolusOS, geckolinux
Posts: 129
Blog Entries: 12

Rep: Reputation: 14
For days now, the system has said it is updating. I can't let your OS take over my computer. I have set Grub to boot to my other OSes first, but PrathamOS has set itself at top of the list after boot, presumably because it thinks it is not done yet. I have updated everything I can upgrade, and it still is set at 1.0 and says it needs to update.

Time to cut bait. I will install another friendly OS here to get my Grub back. Two hours work just to get my system back.
 
Old 07-25-2018, 12:13 AM   #27
ThePrathamOS
LQ Newbie
 
Registered: Jun 2018
Posts: 26

Rep: Reputation: Disabled
Quote:
Originally Posted by zaivala View Post
For days now, the system has said it is updating. I can't let your OS take over my computer. I have set Grub to boot to my other OSes first, but PrathamOS has set itself at top of the list after boot, presumably because it thinks it is not done yet. I have updated everything I can upgrade, and it still is set at 1.0 and says it needs to update.

Time to cut bait. I will install another friendly OS here to get my Grub back. Two hours work just to get my system back.

Great !!

I would suggest that is the best way to go for you...Couple of points..
  • "can't let your OS take over my computer" => No one is interested in your computer...none as for PrathamOS
  • grub thing.. => any OS which gets installed gets the grub...Its a linux thing...
  • next time around...if you try another "NOT SO FRIENDLY OS", please go through the documentation and if that Distro has a dedicated YouTube Channel just for visualization of every aspect of the OS, DO TRY TO FOLLOW IT

Good Luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Greetings From PrathamOS [32 & 64 BIT Debian Sid+XFCE] PrathamOS LinuxQuestions.org Member Intro 3 08-12-2016 04:16 PM
Ethics of dumping an abusive forum administrator by duplicating their forum Ulysses_ General 38 09-04-2015 10:28 AM
use linux Forum or ubuntu forum for bypassing loading in grub1.5 Limji Linux - Newbie 1 02-16-2011 09:57 PM
Is the forum at http://forum.freespire.org/ dead ? freespirit me General 16 11-13-2008 09:21 AM
Copying a phpbb3 forum contents to a different forum; no admin access on source forum Maligree General 1 08-11-2008 12:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > PrathamOS

All times are GMT -5. The time now is 06:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration