LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 06-02-2005, 08:44 AM   #1
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 49
Upgrading GAIM


I wonder how do I upgrade my GAIM with Mandrake.

I have GAIM 1.3 to be updated over v0.82.1 which i downloaded from here

I tried the following to update.

Code:
rpm -iU gaim-1.3.0-0.mdk10.0.i586.rpm

I got this Error regarding a conflict.

Code:
warning: gaim-1.3.0-0.mdk10.0.i586.rpm: V3 DSA signature: NOKEY, key ID 4c292fcc
        file /usr/lib/libgaim-remote.so.0.0.0 from install of gaim-1.3.0-0.mdk10.0 conflicts with file from package libgaim-remote0-0.82.1-2mdk
Agitated, I did this.

Code:
rpm -iv gaim-1.3.0-0.mdk10.0.i586.rpm
I got this.


Code:
warning: gaim-1.3.0-0.mdk10.0.i586.rpm: V3 DSA signature: NOKEY, key ID 4c292fcc
Preparing packages for installation...
        file /usr/lib/libgaim-remote.so.0.0.0 from install of gaim-1.3.0-0.mdk10
.0 conflicts with file from package libgaim-remote0-0.82.1-2mdk
        file /usr/bin/gaim from install of gaim-1.3.0-0.mdk10.0 conflicts with f
ile from package gaim-0.82.1-2mdk
        file /usr/bin/gaim-remote from install of gaim-1.3.0-0.mdk10.0 conflicts
 with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/autorecon.so from install of gaim-1.3.0-0.mdk10.0 con
flicts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/docklet.so from install of gaim-1.3.0-0.mdk10.0 confl
icts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/extplacement.so from install of gaim-1.3.0-0.mdk10.0
conflicts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/gaim-remote.so from install of gaim-1.3.0-0.mdk10.0 c
onflicts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/gestures.so from install of gaim-1.3.0-0.mdk10.0 conf
licts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/history.so from install of gaim-1.3.0-0.mdk10.0 confl
icts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/iconaway.so from install of gaim-1.3.0-0.mdk10.0 conf
licts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/idle.so from install of gaim-1.3.0-0.mdk10.0 conflict
s with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/libgg.so from install of gaim-1.3.0-0.mdk10.0 conflic
ts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/libirc.so from install of gaim-1.3.0-0.mdk10.0 confli
cts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/libjabber.so from install of gaim-1.3.0-0.mdk10.0 con
flicts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/libmsn.so from install of gaim-1.3.0-0.mdk10.0 confli
cts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/libnapster.so from install of gaim-1.3.0-0.mdk10.0 co
nflicts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/libnovell.so from install of gaim-1.3.0-0.mdk10.0 con
flicts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/liboscar.so from install of gaim-1.3.0-0.mdk10.0 conf
licts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/libyahoo.so from install of gaim-1.3.0-0.mdk10.0 conf
licts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/libzephyr.so from install of gaim-1.3.0-0.mdk10.0 con
flicts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/notify.so from install of gaim-1.3.0-0.mdk10.0 confli
cts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/relnot.so from install of gaim-1.3.0-0.mdk10.0 confli
cts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/spellchk.so from install of gaim-1.3.0-0.mdk10.0 conf
licts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/ssl-gnutls.so from install of gaim-1.3.0-0.mdk10.0 co
nflicts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/ssl-nss.so from install of gaim-1.3.0-0.mdk10.0 confl                                           icts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/ssl.so from install of gaim-1.3.0-0.mdk10.0 conflicts                                            with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/statenotify.so from install of gaim-1.3.0-0.mdk10.0 c                                           onflicts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/ticker.so from install of gaim-1.3.0-0.mdk10.0 confli                                           cts with file from package gaim-0.82.1-2mdk
        file /usr/lib/gaim/timestamp.so from install of gaim-1.3.0-0.mdk10.0 con                                           flicts with file from package gaim-0.82.1-2mdk
        file /usr/share/applications/gaim.desktop from install of gaim-1.3.0-0.m                                           dk10.0 conflicts with file from package gaim-0.82.1-2mdk
        file /usr/share/man/man1/gaim-remote.1.bz2 from install of gaim-1.3.0-0.                                           mdk10.0 conflicts with file from package gaim-0.82.1-2mdk
        file /usr/share/man/man1/gaim.1.bz2 from install of gaim-1.3.0-0.mdk10.0                                            conflicts with file from package gaim-0.82.1-2mdk
        file /usr/share/man/man3/Gaim.3pm.bz2 from install of gaim-1.3.0-0.mdk10                                           .0 conflicts with file from package gaim-0.82.1-2mdk
        file /usr/share/pixmaps/gaim/smileys/default/theme from install of gaim-                                           1.3.0-0.mdk10.0 conflicts with file from package gaim-0.82.1-2mdk
        file /usr/share/pixmaps/gaim/status/default/msn.png from install of gaim                                           -1.3.0-0.mdk10.0 conflicts with file from package gaim-0.82.1-2mdk




How do I UPDATE GAIM exactly?

Last edited by duffmckagan; 06-02-2005 at 08:48 AM.
 
Old 06-02-2005, 09:14 AM   #2
Boby
Member
 
Registered: Feb 2004
Posts: 781

Rep: Reputation: Disabled
You are using:
Code:
rpm -iU gaim-1.3.0-0.mdk10.0.i586.rpm
The "i" option is used for installing not upgrading, and the "U" option is for upgrading.
To upgrade you have to use:
Code:
rpm -U gaim-1.3.0-0.mdk10.0.i586.rpm
For a nicer display of the upgrading process try:
Code:
rpm -Uhv gaim-1.3.0-0.mdk10.0.i586.rpm
Also please take a look at the rpm manual
Code:
man rpm
Good luck!
Boby
 
Old 06-02-2005, 09:26 AM   #3
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 49
Thanks man.

I am still getting this error when I try your commands of rpm -U and rpm -Uhv


Code:
warning: gaim-1.3.0-0.mdk10.0.i586.rpm: V3 DSA signature: NOKEY, key ID 4c292fcc
        file /usr/lib/libgaim-remote.so.0.0.0 from install of gaim-1.3.0-0.mdk10.0 conflicts with file from package libgaim-remote0-0.82.1-2mdk
 
Old 06-02-2005, 10:54 PM   #4
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 49
I am finally done with upgrading GAIM.....I upgraded to GAIM 1.3

I did the following things.

Using MCC< I removed the current version of GAIM.

Then using
Code:
rpm -iv gaim <filename>.rpm
Cheers.
 
Old 06-02-2005, 11:47 PM   #5
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 49
It has now disappeared from my Start menu, and How do i get it back?

Where is GAIM installed anyways?
 
Old 06-03-2005, 04:06 AM   #6
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
"NOKEY, key ID 4c292fcc" this means you are missing the gpg key for the rpm. This is not your problem, it won't stop you doing anything. If you want to stop this sort of thing you must get the gpg key offa the website you got the rpm from.

The package conflict is more important - you'll probably find the libgaim files are in a different rpm which you must install first.

Interestingly, you removed the old gaim ... I wonder if you now have libgaim 1.3 installed? (Another possibility is that the rpm is configured badly and tries to upgrade gaim before libgaim?)

Now you are faced with inserting a launcher in your menues. It ain't where the old gaim was, but that wouldn't help you anyways as the old gaim icon would just start the old gaim right.

Binary files are usually in /sbin or /usr/sbin or /usr/share/sbin or something similar. You can use some sort of search routing to look for the "gaim" files ... one of them will be right. You also want to read the documentation.

If in doubt read "man grep" and use grep to find the files you want.

You could try "man gaim" and "info gaim" just to see if the manpage got installed - it will have information you need anyway. And "apropos gaim" should be interesting too.

Now you know why so many folk prefer to use source installs.
 
Old 06-03-2005, 06:33 AM   #7
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 49
Thanks for your time man.
You gave a lot of information.

There was as a symlink present in /usr/bin and so I managed to create a pointer to that and placed it on the Menu.

I don't know whether libgaim is installed or not. There wasn't a seperate RPM needed for installing that.
GAIM 1.30 is working absolutely fine. So, I am not wondering about the libgaim stuff.
 
Old 06-03-2005, 07:06 PM   #8
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
I found libgaim-remote in rpmfind.net: it is a separate package from gaim.
http://rpmfind.net/linux/rpm2html/se...&system=&arch=

You lose some functionality, but my guess is that you don't use it anyway.

Last edited by Simon Bridge; 06-03-2005 at 07:08 PM.
 
Old 06-03-2005, 11:44 PM   #9
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 49
I tried the link, but I can't find one for GAIM 1.3, which I have newly installed.

Maybe those files were installed with the GAIM setup itself?

Last edited by duffmckagan; 06-03-2005 at 11:53 PM.
 
Old 06-04-2005, 12:47 AM   #10
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
You could querie the rpm file you installed gaim from to see?

rpm -ql gaim<etc>.rpm
 
Old 06-04-2005, 02:17 AM   #11
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 52
Mandrake uses the Debian menu system which builds the menus from the files in /usr/lib/menu

If you got a package off rpmfind that wasn't built specifically for Mandrake it may not create the menu entries there as other systems have different menu systems.

To fix this problem create the file /usr/lib/menu/gaim with the following contents:
Code:
?package(gaim):  command="soundwrapper /usr/bin/gaim"  needs="X11"  icon="gaim.png"  section="Internet/Instant Messaging"  title="Gaim"  longtitle="Multi-protocol Instant Messaging Client"  startup_notify="true"
 
Old 06-04-2005, 02:21 AM   #12
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 49
I did it.

This is the message that I get. Yet, GAIM is working perfect.

Code:
package gaim-1.3.0-0.mdk10.0.i586.rpm is not installed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
missing msn/icq protocol after upgrading to gaim 1.1.2 Gustaf Slackware 1 02-03-2005 10:32 PM
Upgrading Gaim Ian_Hawdon Linux - Software 8 02-03-2005 10:40 AM
Upgrading gaim-->1.02, Mandrake 10.0 SamerAdra Linux - Newbie 3 10-28-2004 08:04 PM
Gaim/MSN protocols and problems upgrading Gaim and Kopete. sergeantroach Linux - Software 5 11-01-2003 08:27 PM
Problem Installing/Upgrading Gaim 0.60 or Gaim 0.71 AskMe Linux - Newbie 1 10-25-2003 08:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 12:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration