LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 11-16-2017, 01:05 PM   #1
anmolp
LQ Newbie
 
Registered: Nov 2017
Posts: 2

Rep: Reputation: Disabled
Wind river linux: configure wireless interface


I am running wind river linux 7 on a dell 5000 machine. By default it comes with eth1 and wlan0 as bridged interfaces. I want to use them separately, so i removed bridging my network configuration before and after looks like:

with bridging:

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ifname 'eth1 wlan0'

without bridging:

config interface 'lan'
option proto 'dhcp'
option ifname 'eth1'

config interface 'wifi'
option proto 'dhcp'
option ifname 'wlan0'


route -n gives:

Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.128.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.128.0 192.168.128.1 255.255.255.0 UG 0 0 0 eth0
192.168.128.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0


both eth0 and wlan0 got assigned ip's now, but there's no route added for wlan0 and hence i can only ping eth0. pinging wlan0 gives request timeout.
I can manually add a route with iface as wlan0 and that works too but is there any proper way of configuring this ? [adding routes manually using 'route' are not persistent across reboots too ]
 
Old 11-17-2017, 11:41 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 19,257
Blog Entries: 28

Rep: Reputation: 6119Reputation: 6119Reputation: 6119Reputation: 6119Reputation: 6119Reputation: 6119Reputation: 6119Reputation: 6119Reputation: 6119Reputation: 6119Reputation: 6119
What is your wireless chipset?

The diagnostics in this post may help you.

This is the first time I've heard of Wind River Linux.
 
Old 11-18-2017, 01:51 AM   #3
anmolp
LQ Newbie
 
Registered: Nov 2017
Posts: 2

Original Poster
Rep: Reputation: Disabled
hi frankbell,

'lspci' gives the following output:

03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88W8897 [AVASTAR] 802.11ac Wireless

i do see wlan0 in ifconfig output, the wireless interface also gets an ip address assigned. The problem is it's not pingable from other machines on same network. I think i am missing something in configuration because the output of 'route -n' does not show wlan0's route. Manually adding the route works perfectly fine but i want to know the correct way to configure it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel Buys Wind River to Push Linux DragonSlayer48DX Linux - News 0 06-06-2009 04:45 PM
Wind River Linux 3 nirmit Linux - Distributions 1 05-28-2009 09:42 AM
wind river linux pdp_122 Linux - Software 1 03-11-2009 02:58 PM
LXer: Wind River spins MID Linux LXer Syndicated Linux News 0 06-07-2008 07:21 PM
LXer: Wind River Having a Real Time With Linux LXer Syndicated Linux News 0 08-01-2006 07:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 01:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration