LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 09-30-2016, 08:07 AM   #1
mdce4
LQ Newbie
 
Registered: Sep 2016
Posts: 3

Rep: Reputation: Disabled
Can't connect to wireless network using wpa_supplicant - OSWA-Assistant


Hello,
I have been trying to work with OSWA-Assistant. Its a version of linux used for wireless auditing. I'm having trouble getting my wifi usb adapter to connect to my wireless network. I have not gotten anywhere with Google, and I'm about at the limit of my abilities. Any ideas you have would be great.

I have the Alfa AWUS036H wireless USB adapter. OSWA will recognize the wifi adapter, and it shows up as wlan0 if I do "iwconfig". However, no matter what i do, I can't get it to connect to my wifi network. I am running WPA2-PSK [AES] as the security option on my wireless router.

I keep getting a "Segmentation fault", and "failed to set GTK to the driver" among other things. I can get you a screen shot of all the results if you want them.

Here is the command that i run.
wpa_supplicant -Dmadwifi -iwlan0 -c/etc/wpa_supplicant.conf -dd



Here is a copy of my /etc/wpa_supplicant.conf:
#do not remove or modify the next 4 lines
ctrl_interface=/var/run/wpa_supplicantctrl_interface_group=0ap_scan=1fast_reauth=1
#select 1 or 2 below, depending on your AP configuration
eapol_version=1

network={
ssid="monkey1" scan_ssid=1 key_mgmt=WPA-PSK proto=WPA2
pairwise=CCMP TKIP
group=CCMP TKIP
psk="........."}


Is there any mistake that you can see on this configuration?

Thanks

By the way, this is my first post on here, so just wanted to say its good to meet you all.
 
Old 10-01-2016, 03:54 AM   #2
end
Member
 
Registered: Aug 2016
Posts: 236

Rep: Reputation: Disabled
re

hi

i run it this way on arch

wpa_supplicant -D nl80211 -c /etc/wpa_supplicant.conf -i wlp2s0 -B
after this run dhclient.
my script

Code:
#!/bin/bash

sudo wpa_supplicant -D nl80211 -c /etc/wpa_supplicant.conf -i wlp2s0 -B
dhclient
i newer use madwifi driver and only that i found that worked for me is this nl80211 driver
 
Old 10-02-2016, 03:57 PM   #3
mdce4
LQ Newbie
 
Registered: Sep 2016
Posts: 3

Original Poster
Rep: Reputation: Disabled
I tried it with nl80211 driver, but I got error message that it does not support that driver. If I put in the command without any driver at all, i.e.

wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -dd

it starts scanning for available networks. A list of available wireless networks in my area comes up, but then i get message
"no suitable AP found" for each one of them. It skips right over the network that i configured in wpa_supplicant.conf, giving the message: "skip - no WPA/RSN IE". I can disable this scan by changing "ap_scan" from 1 to 0.
In this case, I see this message:
"could not read SSID from driver". I still have no luck either way.

I have tried this on 2 different wireless networks and it does the same thing on both of them. I guessing its still a driver issue. Any other ideas that I could try?
 
Old 10-02-2016, 04:14 PM   #4
end
Member
 
Registered: Aug 2016
Posts: 236

Rep: Reputation: Disabled
re

try this

-Dnl80211,wext

and try remove proto=WPA2

my wpa_supplicant.conf

Code:
network={
ssid="670746 2"
scan_ssid=1
key_mgmt=WPA-PSK
psk="...."
}
and my wireless use TKIP+AES

Last edited by end; 10-02-2016 at 05:24 PM.
 
Old 10-03-2016, 04:44 PM   #5
mdce4
LQ Newbie
 
Registered: Sep 2016
Posts: 3

Original Poster
Rep: Reputation: Disabled
It keeps give me an error for unsupported driver on that n180211 when I tried it. I think if I can somehow get that nl80211 driver installed on my system maybe it would work.

I have the driver CD for the Alfa AWUS036H.
I was able to mount the CD on the linux system, but it won't compile the Makefile for some reason. I got this error: "make: /lib/modules/2.6.19/build: no such file or directory. Stop" This directory does seem to exist, so I don't know why it does this.

Is there a package I can download with this driver? Maybe that would be easier.
 
Old 10-03-2016, 05:28 PM   #6
end
Member
 
Registered: Aug 2016
Posts: 236

Rep: Reputation: Disabled
re

hy,

that error when compailing make indicate missing linux headers so you need linux headers for your os.
try search linux headers for your distribution and try make again.

post after that we will figur out somehow

nl not n1

try enter sudo wifi-menu see is it installed and try connect that way. is alpha only card on your pc

Last edited by end; 10-03-2016 at 05:30 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot connect to secure network (wpa_supplicant) ieatbunnies Linux - Newbie 1 05-13-2010 07:56 PM
problems connecting to wireless network using wpa_supplicant locash Linux - Wireless Networking 1 10-15-2008 11:15 PM
Failed to connect to the secure network using wpa_supplicant Kirinor SUSE / openSUSE 1 03-27-2008 06:58 AM
Unable to connect to TKIP encrypted network using BCM43xx & wpa_supplicant SlackwareInAZ Slackware 1 09-07-2006 07:22 AM
FC4 + madwifi + wpa_supplicant. Authenticates, but cannot connect to network jspam Linux - Wireless Networking 0 11-05-2005 03:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 11:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration