LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-29-2004, 01:49 PM   #1
donbellioni
Member
 
Registered: Mar 2004
Location: UK
Distribution: Slackware 10
Posts: 137

Rep: Reputation: 15
VMware - Cant get fullscreen mode


Im using VMware 4.5.2 on slackware and when i try to go fullscreen in my guest o/s (Windows XP ) i get the error:

Code:
XFree86 direct graphics (DGA extension) initialization failed.
Cannot switch to full screen mode.
Am i missing something in my X installation?
Im not really sure how to resolve this.

Any ideas?

Cheers.
 
Old 08-29-2004, 02:57 PM   #2
donbellioni
Member
 
Registered: Mar 2004
Location: UK
Distribution: Slackware 10
Posts: 137

Original Poster
Rep: Reputation: 15
I got past the DGA issue with help from this http://www.vmware.com/support/gsx2/t...2.html#1017082 but now im getting this error when trying to go full screen:

Code:
DVGA is not supported since the host uses kernel framebuffer
Full screen VGA initialization failed.
Cannot switch to full screen mode.
Could someone recommend something for me to do?

Thanks.
 
Old 08-30-2004, 03:36 AM   #3
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
Quote:
DVGA is not supported since the host uses kernel framebuffer
You need to install the correct driver for your video card, rather than using the generic framebuffer. I really can't tell you anything further without knowing more about your system.

Wouldn't it make sense to at least mention what video card you're using when asking a question like this?

Enjoy!
--- Cerbere
 
Old 08-30-2004, 01:50 PM   #4
donbellioni
Member
 
Registered: Mar 2004
Location: UK
Distribution: Slackware 10
Posts: 137

Original Poster
Rep: Reputation: 15
Sorry, i thought it was an issue with the kernel and not the video card/driver. Its a nVidia Geforce FX 5200 64MB Graphics Card.

In response to your suggestion, the correct graphics driver is already installed, namely the official nvidia driver for this card, for linux.

Thanks for the reply.
 
Old 08-31-2004, 06:26 AM   #5
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
While you may have the driver installed, I don't think you're actually using it, or you wouldn't be getting an error about the framebuffer. Look through /etc/lilo.conf for a line that reads vga=###. If you find this line where ### is a three-digit number, then you're using the VESA framebuffer. Comment this out and add the line vga=normal, then run lilo and reboot.

Chances are that you won't be able to enter X until you make a few config changes to x.org. Afraid I can't help much with that, since I'm still (happily) using Slack 9.0 with XFree86. Basically, you want to be sure that the /etc/X11/xorg.conf file has a section like the following:
Code:
Section "Device"
    Identifier  "NVIDIA"
    Driver      "nvidia"
    #VideoRam    65536
    # Insert Clocks lines here if appropriate
EndSection
Notice this specifies loading the driver 'nvidia' (older drivers used 'nv') rather than 'vesa' or 'fbdev'. Then verify that the Screen section has a Device corresponding to the Identifier above, like so:
Code:
Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA"
    Monitor     "My Monitor"
    Option      "NoLogo" "true"
. . .
Enjoy!
--- Cerbere
 
Old 08-31-2004, 02:29 PM   #6
donbellioni
Member
 
Registered: Mar 2004
Location: UK
Distribution: Slackware 10
Posts: 137

Original Poster
Rep: Reputation: 15
Ah there was a "vga = 773" line in lilo.conf.

Working now, thanks a lot for your help.

This isnt that important, its preferance more than anything else, but is it possible to set vga to normal just before x loads? Its just that the boot text is huge now and and id prefer it to stay like it did whilest vga=773 was set during bootup.

No biggie if it cant be done.

Thanks again.
 
Old 09-02-2004, 05:35 AM   #7
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
I'm glad it worked for you. The 773 value corresponds to 1024x768 and only 256 colors, so hopefully you're getting a better image in X, now.

As far as setting the console resolution, I haven't found a way to do that, but then I didn't try too hard. Most of the time, I startx right after I boot, then open a couple of aterms (in fact, I've set my .xinitrc to start one aterm when X starts).

You can find lots of info about the framebuffer in the linux kernel source documentation. Look in /usr/src/linux/Documentation/fb/ (at least that's where it is in the 2.4.## source).

The following excerpt from /usr/src/linux/Documentation/fb/vesafb.txt gives me an idea that you might try:
Code:
You should compile in both vgacon (for text mode) and vesafb (for
graphics mode). Which of them takes over the console depends on
whenever the specified mode is text or graphics.

The graphic modes are NOT in the list which you get if you boot with
vga=ask and hit return. The mode you wish to use is derived from the
VESA mode number.
Maybe if you set vga=ask in lilo.conf, and enter one of the values provided at the prompt, then it will only set the framebuffer for the text console. If this works, then you can edit lilo.conf again to set 'vga' to whatever value you used. Just a thought.

Let us know if you can get it working. I kinda miss seeing Tux when I boot up ;-)

Enjoy!
--- Cerbere
 
Old 09-02-2004, 01:23 PM   #8
donbellioni
Member
 
Registered: Mar 2004
Location: UK
Distribution: Slackware 10
Posts: 137

Original Poster
Rep: Reputation: 15
Thanks.

Ill post back when i try it out, might be a while now tho now ive discovered i need to get a replacement hard drive from Dell due to bad blocks.

Eek!

Thanks for the help.
 
Old 09-14-2004, 09:06 PM   #9
aldebX
LQ Newbie
 
Registered: Sep 2004
Location: Rome
Distribution: SuSE
Posts: 1

Rep: Reputation: 0
Thumbs up

Hi guys!!
First of all I'd like to thank very much Cerbere as his answer actually solved my problem with VmWare too!
Anyway I wonder if there is any solution for the (little) drawback I noticied: after having set vga=#x### to normal during the boot process my screen has a very low resolution, something like 640x480 I suppose, and it isn't any more graphical. Premised that I actually I don't care at all at the graphical boot, I wonder if I could rise the bootstrap screen resolution and if this is somehow related to the minimal resolution I set during XF86config-4 configuration ( 1024*768 800*600 640*480 @ 24bit ).
Thanks a lot again!!
 
Old 09-15-2004, 06:26 AM   #10
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
Hi aldebX. Welcome to LQ.org!

I'm happy to hear that my response was of some help with your vmware problem. As far as the text you see during boot-up, it shouldn't be affected by your XF86config file, since that file is only parsed when starting the X server. However, you can try changing 'vga=normal' to 'vga=ask' in your lilo.conf as I suggested in my last post. This will give you a few choices for the console (text-only) resolution, though none are as clear as those provided by the vesa framebuffer (in my opinion). But if you find that you like one of those, you can set that value for 'vga=' in lilo.conf.

And for those of you who are wondering, using 'vga=ask' doesn't display Tux at boot-up :-(

Enjoy!
--- Cerbere
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto leave vncviewer -fullscreen mode Consystor Linux - Software 3 09-05-2012 11:46 AM
KMail: Remove fullscreen mode spinifeX Linux - Newbie 1 02-13-2005 11:45 AM
Start firefox in fullscreen mode m33p Linux - Software 1 09-16-2004 05:13 PM
start konqueror in fullscreen-mode?? TKONeo Linux - Software 5 01-15-2004 12:29 PM
Trouble with fullscreen mode Likosin Linux - Software 1 08-04-2003 02:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration