LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-09-2008, 04:54 AM   #1
Hawkin
LQ Newbie
 
Registered: Jun 2008
Posts: 22

Rep: Reputation: 15
Version incompatible (OpenLDAP)


Hi @ all

I have read the „OpenLDAP Admin Guide” and the INSTALL documents.
First, I have installed the required software like OpenSSL 0.9.7+, Cyrus SASL 2.1.21 and an Berkeley DB with the Version 4.6.21.
Additional the POSIX regular expressions, but are they not a component of the base installation of Redhat Linux 9?!
I have downloaded OpenLDAP 2.4.9 from the openldap - website, which is compatible to BerkeleyDB version 4.6.21, at least according to the website http://www.openldap.org/faq/data/cache/44.html .
But when I have installed the software and want to configure the Distribution for building OpenLDAP by starting “configure”, the following error message appears:

checking for Berkeley DB major version... 4
checking for Berkeley DB minor version... 0
checking for Berkeley DB link (-ldb-4)...
no checking for Berkeley DB link (-ldb4)...
no checking for Berkeley DB link (-ldb)...
yes checking for Berkeley DB version match...
yes checking for Berkeley DB thread support...
yes checking Berkeley DB version for BDB/HDB backends...
no configure: error: BDB/HDB: BerkeleyDB version incompatible

I’ve tried to install the software according the steps in the Admin Guide, but it failed. Why does this not work? Do you have any other ideas?!

Thanks in advanced
 
Old 06-09-2008, 05:37 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,293

Rep: Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698
Quote:
checking for Berkeley DB major version... 4
checking for Berkeley DB minor version... 0
checking for Berkeley DB link (-ldb-4)...
I don't know how did you install the newer BerkeleyDB, but it seems that there is also an older version in your system (4.0.x) and the ./configure script is picking that, so it fails. YOu can either uninstall the older version and use your package manager to install the newer version or you can override the defaults in ./configure like this:
Code:
LDFLAGS=-L/path/to/BerkeleyDB.4.6/lib CPPFLAGS=-I/path/to/BerkeleyDB.4.6/include ./configure -other-options
 
Old 06-11-2008, 06:35 AM   #3
Hawkin
LQ Newbie
 
Registered: Jun 2008
Posts: 22

Original Poster
Rep: Reputation: 15
I've installed OpenLDAP according to the INSTALL and the README documents with the Requirements OpenSSL 0.9.7+, Cyrus SASL 2.1.21+, POSIX REGEX and the BerkeleyDB 2.4.10, the newest release.

I have unpacked the file openldap-2.4.10.tgz, read the Installs and README's and start the configure script. Afterwards i start "make depend" to create the dependencies, "make test" and concluding make install.
How can i uninstall the old version?! I have made a backup from openldap before executing the installation of openldap4.6.21...

According to the Install documents, but anyhow the installation get's failed...Höööö?!
When i have changed the configure of openldap, should i repeat the installation of openldap?!

Thanks in advanced,

Arne

Last edited by Hawkin; 06-11-2008 at 06:37 AM.
 
Old 06-11-2008, 07:40 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,293

Rep: Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698
Quote:
I have unpacked the file openldap-2.4.10.tgz, read the Installs and README's and start the configure script. Afterwards i start "make depend" to create the dependencies, "make test" and concluding make install.
Either you didn't run the plain "make" after "make depend" to actually build openldap, or you forgot to mention it.
AFAIK you cannot uninstall the older version compiled from source since Makefile does not provide a "make uninstall" option. You can delete the directories created from the previous installation. If you used ./configure --prefix=/some/dir they are located under /some/dir, else look in various places under /usr/local (/usr/local/etc/openldap, /usr/local/var and so on). I suggest you to leave the old version and install the newer in the same location, so the older files will be overwritten from the newer ones.
 
Old 06-12-2008, 03:55 AM   #5
Hawkin
LQ Newbie
 
Registered: Jun 2008
Posts: 22

Original Poster
Rep: Reputation: 15
Sry...forget to mention it...-.-
I have uninstalled the version of BerkeleyDB and OpenLDAP deleting the directories, afterwards i start an "updatedb" to get sure per locate ..., that all files from this both applications are deleted.
The next step is to install BerkeleyDB Version 4.6.21 per following Steps:

Unpacking the File db ...
change directory to /build_unix and execute ../dist/configure
make
make install

All of these steps were executed correctly and without any mistake. BerkeleyDB is installed under /usr/local/BerkeleyDB.4.6.21.

Then i unpacked the openldap-file with version 2.4.10, the newest release from openldap.
i start the configure with ./configure --prefix=/usr/local as you assumed me to do.
But the command ends after some minutes in a message meaning BerkeleyDB and OpenLDAP Version incompatible...
The "make depend" command affords "make: *** No rule to make target `depend'. Stop", same as the command "make" -> "make: *** No targets specified and no makefile found. Stop."

AAAAAH...this sucks...do you have any other idea?!

Greetings from germany
 
Old 06-12-2008, 04:28 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,293

Rep: Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698
I suggest you to use your distro's package manager to install the software you want to avoid this kind of problems. Else you should use LDFLAGS and CPPFLAGS to add the BerkeleyDB library and include path to the defaults that ./configure is using.
 
Old 06-12-2008, 06:50 AM   #7
Hawkin
LQ Newbie
 
Registered: Jun 2008
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bathory View Post
I suggest you to use your distro's package manager to install the software you want to avoid this kind of problems. Else you should use LDFLAGS and CPPFLAGS to add the BerkeleyDB library and include path to the defaults that ./configure is using.
Oha...the downloaded files from openldap and BerkeleyDB are *.tgz and *.tar, sadly not *.rpm. For installation in Red hat package manager i need rpm-files, isn't it?!

LDFLAGS/CPPFLAGS?, are this Environment Variables or similar?! I search for this in google and found this...

Quote:
LDFLAGS="-L/usr/local/lib -L/usr/local/BerkeleyDB.4.2/lib -L/usr/local/ssl/lib" CPPFLAGS="-I/usr/local/include -I/usr/local/BerkeleyDB.4.2/include -I/usr/local/ssl/include" ./configure --enable-bdb --enable-crypt --with-tls
OR
Is that correct?!

For my configuration:

LDFLAGS="-L/usr/local/lib -L/usr/local/BerkeleyDB.4.6/lib -L/usr/local/ssl/lib" CPPFLAGS="-I/usr/local/include -I/usr/local/BerkeleyDB.4.2/include -I/usr/local/ssl/include" ./configure --enable-bdb --enable-crypt --with-tls

The Paths are correct, but is this blog also correct from the syntax?!
Is this the way you mean?!
And what means
Quote:
include path to the defaults that ./configure is using
? prefix=/...?!

Thanks a lot for your help...
 
Old 06-12-2008, 07:03 AM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,293

Rep: Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698
Quote:
For installation in Red hat package manager i need rpm-files, isn't it?!
Yes you need rpms for RH. You can use pbone to search for the packages you want to install and their dependencies.
Quote:
LDFLAGS/CPPFLAGS?, are this Environment Variables or similar?
You use LDFLAGS/CPPFLAGS to extend the library and include search directories used by the ./configure script, as I told you in my 2nd post.
Code:
LDFLAGS=-L/path/to/BerkeleyDB.4.6/lib CPPFLAGS=-I/path/to/BerkeleyDB.4.6/include ./configure --prefix=/some/path --other-options
prefix is the location you want to install openldap (the default is /usr/local) and other-options are various other options you want (like --enable-bdb --enable-crypt --with-tls in the example you've posted).

Last edited by bathory; 06-13-2008 at 02:53 AM.
 
Old 06-12-2008, 10:39 AM   #9
Hawkin
LQ Newbie
 
Registered: Jun 2008
Posts: 22

Original Poster
Rep: Reputation: 15
okay, i have searched rpm's for openldap and found the version 2.4.8-5.fc9.i386, but when i want to install it after chmod 744 he missed some dependencies like libc.so.6 ... and so on, 6 different files.
But this files exists, for example libc.so.6 under /lib/libc.so.6 and so on... Any idea?!

Using LDFLAGS and CPPFLAGS performed no better result, the same failure i reported

Can you watch after 2 versions of BerkeleyDB and OpenLDAP with link, which are running without problems and where are no insecurities concerning the versions?!

I am so sry, but i'm the totally linux boon...
 
Old 06-13-2008, 03:21 AM   #10
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,293

Rep: Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698
Quote:
okay, i have searched rpm's for openldap and found the version 2.4.8-5.fc9.i386, but when i want to install it after chmod 744 he missed some dependencies like libc.so.6 ... and so on, 6 different files.
You didn't say what version of RH you have. The package you've found is compiled for Fedora 9 and it's more likely that it needs a newer libc that the one you have in your system. Since it's very risky to mess with glibc, look for older packages. May this will help you find the package that matches your RH version. Mind that you need 3 packages: openldap, openldap-servers, openldap-clients
Quote:
Using LDFLAGS and CPPFLAGS performed no better result, the same failure i reported
FYI I've just installed openldap 2.410 using BerkeleyDB 4.7.25 (from source) using the trick with LDFLAGS/CPPFLAGS to pick the new BerkeleyDB instead of the 4.4.20 that my Slackware comes with and it worked like a charm. So I guess you are doing something wrong. Are you sure about the path you use after -L and -I to point to the newly installed BerkeleyDB libraries and header files?
 
Old 06-13-2008, 06:14 AM   #11
Hawkin
LQ Newbie
 
Registered: Jun 2008
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Redhat Linux 9
Okay, thank you for your hint with the risk by including the libraries!
I get some informations about the installed openldap files per command rpm -qa | grep -i openldap, and it displayed the following:

Quote:
openldap-devel-2.0.27-8
openldap-2.0.27.8
I confess that i am a little bit confused, because i uninstalled and deleted the whole openldap application and directory.
For my complete openldap installation i need, as you said, openldap, openldap-clients and openldap-server.
Under your posted link to rpmfind.net i found then rpms of openldap-clients-2.0.27-8 and openldap-servers-2.0.27-8.
The installation proceed without any problems, but i want the openldap version 2.4 or newer, because BerkeleyDB 4.6 are known to work with openldap 2.4 or newer and my instructions are to use newer software...-.-
But this version are not deposited on rpmfind, where can i find them or an update from version 2.0.27-8 to 2.4 or higher?! rpmfind has only 2.0.27 ...

Must i configure SLAPD, too?! And when, what?!

Last edited by Hawkin; 06-13-2008 at 06:37 AM.
 
Old 06-13-2008, 06:43 AM   #12
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,293

Rep: Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698
Quote:
The installation proceed without any problems, but i want the openldap version 2.4 or newer, because BerkeleyDB 4.6 are known to work with openldap 2.4 or newer and my instructions are to use newer software...-.-
If you want to use newer sw, consider upgrading your OS to RHEL, if that's an option. You can use Fedora, or CentOS if you don't want to pay RH fees.
Else if you have to stay with RH 9, then your only chance is to install it from sources.
 
Old 06-16-2008, 05:48 AM   #13
Hawkin
LQ Newbie
 
Registered: Jun 2008
Posts: 22

Original Poster
Rep: Reputation: 15
Okay, I am using allready the install-routine from source...

At the begin of this thread, i have only openldap-devel and openldap installed, but i have needed openldap-clients and servers.
I tried a long time to install it from source with the release version 2.4.0 (*.tar.gz), but without any success.
With your link to rpmfind, i have found an *.rmp package for clients and for server. The installation was easy and succeed.

How can i install newer version of openldap from source?!
I know the routine of configure, compiling and so on, but how can i install or upgrade from 2.0.27 to 2.4.0 per source?!

And do you have any idea relative for this failure while installing imake?!

Quote:
root@localhost imake]# make World

Building configuration software

##############################################################
# Did you remember to check the configuration parameters in #
# the directory ./config and set BOOTSTRAPCFLAGS if needed? #
##############################################################

Mon Jun 16 11:06:36 CEST 2008

cd ./config; make -f Makefile.ini BOOTSTRAPCFLAGS="" clean; make -f Makefile.ini BOOTSTRAPCFLAGS=""
make[1]: Wechsel in das Verzeichnis Verzeichnis »/usr/local/src/imake/config«
rm -f ccimake imake.o imake
rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a tags TAGS make.log \#*
make[1]: Verlassen des Verzeichnisses Verzeichnis »/usr/local/src/imake/config«
make[1]: Wechsel in das Verzeichnis Verzeichnis »/usr/local/src/imake/config«
making imake with BOOTSTRAPCFLAGS=
cc -o ccimake -O -I../include ccimake.c
cc -c -O -I../include `./ccimake` imake.c
imake.c:103:1: warning: "_POSIX_SOURCE" redefined
In file included from /usr/include/stdio.h:28,
from imake.c:96:
/usr/include/features.h:167:1: warning: this is the location of the previous definition
imake.c: In function `LogFatal':
imake.c:444: conflicting types for `sys_errlist'
/usr/include/bits/sys_errlist.h:28: previous declaration of `sys_errlist'
make[1]: *** [imake.o] Fehler 1
make[1]: Verlassen des Verzeichnisses Verzeichnis »/usr/local/src/imake/config«
make: *** [World] Fehler 2
Have a good Start in the new week

Last edited by Hawkin; 06-16-2008 at 06:04 AM.
 
Old 06-16-2008, 08:47 AM   #14
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,293

Rep: Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698Reputation: 1698
Quote:
How can i install newer version of openldap from source?!
I know the routine of configure, compiling and so on, but how can i install or upgrade from 2.0.27 to 2.4.0 per source?!
If you don't want, or you can't install a newer OS, then you should go with the usual build from source routine (./configure, make, make depend, make install)
Quote:
And do you have any idea relative for this failure while installing imake?!
I have no idea, but if I was you, I'll follow the suggestions between the ###'s

Regards
 
Old 06-16-2008, 10:37 AM   #15
Hawkin
LQ Newbie
 
Registered: Jun 2008
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
(./configure, make, make depend, make install)
this is at the moment my default installation-routine and with this routine i tried to install openldap-clients and servers, but it failed everytime while starting ./configure from openldap with the message: version incompatible and aborted as described.

With this installation-routine, i can't install servers and clients, with *.rpms appeared no problems and the installation suceed. But only with an older version, because i can't find an newer rpm of openldap-clients and server and respectively exists no rpm for this both pieces of openldap...

The problem with imake and the posted failure is solved, so back to the roots ;-).

Edit: Ups...apparently imake isn't installed correctly...aarg!
Afterwards the installation of itools, which contains imake, i tried to install dicom3tools from david clunie according this page: README from itools

*checking the unzipped directory for other readme's and requirements
*checked, if PERLPATH is correct, point to /usr/local/bin/perl
in the directory /usr/local/bin/ exists two different perl-files: "perl" and "perl5.8.8", default is perl, correct?!
* "make World" for Building Distribution
* "make install" for Installing Distribution

But when i used imake to install dicom3tools per command imake -I./config -DInst ...., he cannot found imake...
Why does this failed?!

Best regards and thanks for your endurance

Last edited by Hawkin; 06-17-2008 at 04:36 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenLDAP complains of Berkeley DB version mismatch [GOD]Anck Slackware 7 06-08-2009 02:54 AM
OpenLDAP with ssl version compatability Vikas Sarin Linux - Networking 0 12-17-2006 09:46 PM
NFS version incompatible issue UltraSoul Solaris / OpenSolaris 2 10-21-2006 04:13 AM
Openldap BerkeleyDB version imcompatible kgao Linux - Software 3 04-12-2005 08:26 PM
Compiling Evolution 1.4 issues on Slackware 9 (incompatible db3 version) Obi-Wan_Kenobi Slackware 2 06-11-2003 12:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration