LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-25-2014, 12:25 PM   #1
DavidDiepUSC
Member
 
Registered: Jan 2008
Posts: 61

Rep: Reputation: 0
URL ftp://<my_servers_IPaddr> works with Chrome, but not so much with Firefox and IE.


Hi everyone,

I have my RHEL FTP server set up to allow for both userlist and anonymous access.

Everything works perfectly using Chrome as the browser, as when I enter ftp://<ipaddress>/ it comes back with the default directory listing.

However, for Firefox, it asks for a UserID and Password.

And much worse, for IE, it can't even display the page.

Has anyone ran into this one before and have some insightful suggestions?

Thanks!
 
Old 06-25-2014, 12:53 PM   #2
DJ Shaji
Member
 
Registered: Dec 2004
Location: Yo Momma's house
Distribution: Fedora Rawhide, ArchLinux
Posts: 518
Blog Entries: 15

Rep: Reputation: 106Reputation: 106
Quote:
Originally Posted by DavidDiepUSC View Post

I have my RHEL FTP server set up to allow for both userlist and anonymous access.
Yep.

You have to type ftp://anonymous@mysite to login anonymously. The same might work in IE too.
 
Old 06-25-2014, 01:10 PM   #3
DavidDiepUSC
Member
 
Registered: Jan 2008
Posts: 61

Original Poster
Rep: Reputation: 0
DJ,

I tried that and it comes back with a dialogue box asking for a userID and password. This is what I have for vsftpd.conf:

anonymous_enable=YES
no_anon_password=YES
anon_root=/odcdocs/Userguides/OCTO User Guides
local_root=/odcdocs/Userguides/OCTO User Guides
userlist_deny=NO
local_enable=YES
write_enable=YES

Any suggestions? Thanks.
 
Old 06-25-2014, 02:19 PM   #4
DJ Shaji
Member
 
Registered: Dec 2004
Location: Yo Momma's house
Distribution: Fedora Rawhide, ArchLinux
Posts: 518
Blog Entries: 15

Rep: Reputation: 106Reputation: 106
What version of firefox and vsftpd are you using? I just checked and my firefox takes me directly to the directory listing for anonymous when I use ftp://mysite. If I use ftp://user@mysite then it asks for a password. I have the latest firefox and vsftpd 2.3.5
 
Old 06-25-2014, 02:28 PM   #5
DavidDiepUSC
Member
 
Registered: Jan 2008
Posts: 61

Original Poster
Rep: Reputation: 0
DJ, i'm using firefox 30.0 and vsftpd is at 2.2.2.

Apparently its also doing it from Chrome (I had previously entered a userid and it was cached).
 
Old 06-25-2014, 03:48 PM   #6
DJ Shaji
Member
 
Registered: Dec 2004
Location: Yo Momma's house
Distribution: Fedora Rawhide, ArchLinux
Posts: 518
Blog Entries: 15

Rep: Reputation: 106Reputation: 106
Are you sure the anonymous login is really enabled? Did you restart vsftp after changing the configuration file? Try logging in as "anonymous" with a blank password and see if that works.
 
Old 06-26-2014, 06:55 AM   #7
DavidDiepUSC
Member
 
Registered: Jan 2008
Posts: 61

Original Poster
Rep: Reputation: 0
Hmm... it did fail with a 530 permission denied. Not sure what it is then... I've even rebooted.

Thanks!
 
Old 07-01-2014, 01:57 PM   #8
DavidDiepUSC
Member
 
Registered: Jan 2008
Posts: 61

Original Poster
Rep: Reputation: 0
Just in case anyone is curious, here is what I did to resolve this:

Made sure these parameters were specified:

anonymous_enable=YES
no_anon_password=YES
anon_root=$path
local_root=$path
userlist_deny=NO
userlist_enable=YES

Then updated the permissions for $path:
chmod 555 /$path

added "anonymous" to user_list
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
IPcamera doesn't works in firefox with linux but works in firefox with windows prowlerxpla Linux - Software 1 05-17-2014 03:17 PM
URL Handler opens Firefox instead of Chrome kcirick Slackware 7 05-11-2014 09:20 AM
[SOLVED] Squid server works for explorer and Chrome, but not for mozilla firefox sunil80 Linux - Newbie 1 01-30-2013 03:20 PM
/dev/dsp1 works in VLC (by default) but not in Firefox and Chrome lothario Linux - Hardware 4 08-06-2011 09:50 AM
Fedora 10 install via Windows XP filezilla ftp server; ftp Url error in kickstart O(V)eGA_l2el) Fedora 2 09-28-2009 09:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration