LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-19-2013, 11:13 PM   #1
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,285

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
"Upstart", /etc/init - GUI frontend?


Normally I dislike GUIs for simple tasks. But I find that my LinuxMint system uses this "upstart" startup thing that I don't really care for. Is there some quick and dirty way to see what is tasked to run when, and disable/enable things easily?

I am so used to dealing with /etc/init.d and /etc/rcX.d. I can easily see what is being started at any given runlevel by doing an ls on the appropriate directory and looking for files that start with a capitol "S".

Now I find that most of my system services use this "upstart" thing. I really don't have any desire to learn the syntax of the config files (although it appears simple), or learn a new way to figure out what is or is not tasked to run at different runlevels. I think "ls /etc/rcX.d" was perfectly fine for that need.

Example: I find that smbd is running on my system. I don't want that. I can no longer do the simple "mv /etc/rc2.d/S50smbd /etc/rc2.d/s50smbd; /etc/init.d/smbd stop" thing. Does "upstart" now mandate that I go into the /etc/init/smdb.conf file and hack away at its internals to stop smbd from automatically starting?

I should probably go an learn upstart anyway. But it's the same thing as me preferring old grub to new grub. Why change if you see no benefit and don't want to? Other than upstart appears to be what Ubuntu and its derivitives like to use, I personally see no need for the change.
 
Old 04-20-2013, 06:34 AM   #2
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,271

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Quote:
Is there some quick and dirty way to see what is tasked to run when, and disable/enable things easily?
I don't known about any GUI, but command "initctl show-config" can be handy. It format is not very nice, however you can see what is starting when.

About disabling (and overriding) you can create a file within "/etc/init" with the same name but extension ".override", for example to disable automatic start during boot up ftp server which I rarely use, I added file "/etc/init/vsftpd.override" with one line: "manual" and stopped by "service vsftpd stop".

Quote:
Why change if you see no benefit and don't want to?
Well, some of people see a benefits, it is nicely explained on Upstart site why it come to life (something about dynamic nature of todays hardware and software). The main reason was switching from tasks depending on other tasks to events which can occur anytime, not only during system start and not necessarily in specified order.

Last edited by eSelix; 04-20-2013 at 06:36 AM.
 
Old 04-20-2013, 02:38 PM   #3
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,285

Original Poster
Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
I imagine "chmod 000" on the appropriate /etc/init/ config file would probably do it too. I'll give that a try.
 
Old 04-20-2013, 04:25 PM   #4
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,285

Original Poster
Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Interesting. This "upstart" thing must think it is sooo important that it can override an obvious maneuver intended to keep it from starting something. Even with mode 000 on /etc/init/smbd.conf and nmbd.conf, this new "upstart" stuff with init starts them on a rebbot anyway.

I was expecting a complaint (that I could ignore) in some logfile due to the 000 permissions, not the thing outright ignoring an obvious, standard, and easily comprehensible setting. I am now liking "upstart" even less than I did before. It doesn't play by the rules of the OS.
 
Old 04-20-2013, 07:20 PM   #5
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,285

Original Poster
Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
SOLVED: "Upstart", /etc/init - GUI frontend?

SOLVED: Apparently, the correct way to permanently disable a service from auto-start is:

Code:
# echo manual > /etc/init/smbd.override; chmod 644 /etc/init/smbd.override
# echo manual > /etc/init/nmbd.override; chmod 644 /etc/init/nmbd.override
They seem to kind of hide this information. It is out there, but it didn't pop up without some searching. Anyway, I got is all covered now.

Thanks eSelix - somehow I missed seeing your earlier post saying exactly this. Not sure how I did that. Guess I was too fast on the scrolling down the webpage part...

Last edited by haertig; 04-20-2013 at 07:24 PM.
 
Old 04-21-2013, 12:52 PM   #6
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,271

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
000 mode did not prevent access by root and on that account "init" process read them. Also these are only config files so executable bit is not necessary. Anyway editing these *.conf files is not advisable because they can be changed after update and all changes need to be resolved manually.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] "init: Id "x" respawning too fast: disabled for 5 minutes." Gil@LQ Linux - Server 7 06-04-2013 04:49 AM
INIT: Id "x" respawning too fast: disabled for 5 minutes error in centos and GUI not SarahGurung Linux - Newbie 6 03-30-2012 04:15 PM
Please list some GUI frontend you know for "sudo" command. cshong Linux - Newbie 3 01-15-2011 05:06 PM
"init 3" freezes while checking "lm_sensors" diogobaeder Fedora 5 07-03-2006 08:40 AM
RH "null" beta system freezes right after printing "INIT" markus1982 Linux - Hardware 0 09-09-2002 04:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration