LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-21-2005, 09:34 PM   #1
kryptonite0110
Member
 
Registered: Mar 2005
Posts: 59

Rep: Reputation: 15
upgrading pango-1.4.0 to 1.8.1


during ./configure i get

checking for glib-2.0 >= 2.5.7 gobject-2.0 gmodule-no-export-2.0... Package gmodule-no-export-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gmodule-no-export-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gmodule-no-export-2.0' found
configure: error:
*** Glib 2.5.7 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.

but an echo $PKG_CONFIG_PATH will print /usr/local/src/glib-2.6.3 and that dir contains
gmodule-no-export-2.0.pc
pkg-config --modversion glib-2.0 returns 2.6.3, so why doesn't it detect gmodule-no-export-2.0.pc?

and also pkgtool doesn't have glib-2.6.3 listed... what'd i do this time?
 
Old 03-23-2005, 06:08 AM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
Re: upgrading pango-1.4.0 to 1.8.1

Quote:
Originally posted by kryptonite0110
during ./configure i get

checking for glib-2.0 >= 2.5.7 gobject-2.0 gmodule-no-export-2.0... Package gmodule-no-export-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gmodule-no-export-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gmodule-no-export-2.0' found
configure: error:
*** Glib 2.5.7 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.

but an echo $PKG_CONFIG_PATH will print /usr/local/src/glib-2.6.3 and that dir contains
gmodule-no-export-2.0.pc
pkg-config --modversion glib-2.0 returns 2.6.3, so why doesn't it detect gmodule-no-export-2.0.pc?

and also pkgtool doesn't have glib-2.6.3 listed... what'd i do this time?
your using the wrong directory for pkg-config. depending on where you installed glib ( i'll assume /usr/local judging by your post, which is usually wrong if your distro shipped with glib and the rest of the gnome libs):

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH

will point pkg-config to the correct file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error in the creation of `etc/pango/pango.modules` okeyla Linux - Newbie 3 07-02-2011 09:06 PM
Pango Half_Elf Linux - Software 2 05-21-2005 12:10 AM
Pango wants >=glib-2.4.0, I installed glib 2.4.7 and pango still says I need >=2.4.0 Locura Red Hat 5 11-01-2004 06:53 PM
Problem with fonts after upgrading to Pango 1.4.1 nazarioz Linux - Newbie 2 09-24-2004 11:54 PM
Problem with fonts after upgrading to Pango 1.4.1 nazarioz Linux - Software 2 09-24-2004 11:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration