LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-30-2011, 11:06 PM   #1
rupalim
LQ Newbie
 
Registered: May 2011
Posts: 1

Rep: Reputation: Disabled
Angry Upgrade redhat5 from glibc 2.5 to glibc 2.7


Hi Community,

I am in very much need to resolve the issue of Upgrade redhat5 from glibc 2.5 to glibc 2.7. The problem is when I run a binary compiled on our build setup (glibc 2.11) on Suse 11 (glibc 2.9) it works fine...

But the same binary do not work on redhat enterprise version 5 telling error as need glibc2.7 or sometimes segmentation fault for the same binary execution.

I tried upgrading the redhat glibc 2.5 to glibc 2.7, but not successful.
I am really worried about this issue.


Please do the needful.
 
Old 05-31-2011, 06:52 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,598

Rep: Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516
You can't. Or, you probably could, but it's a very bad idea. glibc is very tightly tied to the rest of the system and changing major versions will probably break everything. You need to build your binary differently.
 
Old 05-31-2011, 08:23 AM   #3
fpmurphy
Member
 
Registered: Jan 2009
Location: /dev/ph
Distribution: Fedora, Ubuntu, Redhat, Centos
Posts: 285

Rep: Reputation: 61
The normal way to overcome this problem is to build the application on the platform with the lowest version of the library. That means you should build it on the RHEL5 system and use it on Suse.

Last edited by fpmurphy; 05-31-2011 at 08:26 AM.
 
Old 05-31-2011, 08:25 PM   #4
Valery Reznic
ELF Statifier author
 
Registered: Oct 2007
Posts: 666

Rep: Reputation: 132Reputation: 132
Quote:
Originally Posted by fpmurphy View Post
The normal way to overcome this problem is to build the application on the platform with the lowest version of the library. That means you should build it on the RHEL5 system and use it on Suse.
Seconded. Usually the more ancient Linux used for build server the more portable executable will be.
If you have difficult moving build server to RHEL5 you can try statifier (http://statifier.sf.net) or Ermine (http://magicErmine.com)
Both of them create self-contained executable that not depend on present of specific version of shared library
 
Old 11-14-2013, 12:20 AM   #5
windows0710
LQ Newbie
 
Registered: Nov 2013
Posts: 1

Rep: Reputation: Disabled
Question

Quote:
Originally Posted by AlucardZero View Post
You can't. Or, you probably could, but it's a very bad idea. glibc is very tightly tied to the rest of the system and changing major versions will probably break everything. You need to build your binary differently.
Maybe it is... But there are many articles that it is possible to upgrade glibc2.5 to glic2.7 on RHEL5.X using "up2date glibc" command.
Actually, I 've to upgrade glibc2.5 to glibc2.9 on RHEL5.x. The following upgrade is impossible?
 
Old 11-14-2013, 12:28 AM   #6
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 1,635

Rep: Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567
Quote:
Originally Posted by windows0710 View Post
Maybe it is... But there are many articles that it is possible to upgrade glibc2.5 to glic2.7 on RHEL5.X using "up2date glibc" command.
Actually, I 've to upgrade glibc2.5 to glibc2.9 on RHEL5.x. The following upgrade is impossible?
Then maybe you should post to those articles, or follow their advice (at your own risk...).
 
1 members found this post helpful.
Old 11-14-2013, 08:31 AM   #7
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,598

Rep: Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516
I would very much doubt those articles, because RHEL 5 uses yum, not up2date.
You can "yum upgrade glibc" all you want .. you're only going to get glibc 2.5 on RHEL 5.
Again -- bad idea. Feel free to find another way, at your own risk, though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
upgrade glibc-2.3 to glibc-2.5 Tux-Slack Slackware 9 01-03-2011 06:40 AM
how to upgrade glibc-2.3 to glibc-2.4 safely on RHEL4? samengr Linux - Software 3 01-31-2009 01:30 PM
newb question on GNU glibc-2.3.1 upgrade to GNU glibc-2.3.2 clindy528 Slackware 1 11-10-2005 06:49 AM
Replacing glibc using linuxthreads for glibc using nptl (native positx thread library CestusGW Linux From Scratch 4 01-20-2005 07:26 AM
upgrade glibc-2.2.4 to glibc-2.3.2 on redhat 7.2 Shuja Red Hat 0 07-28-2004 06:10 AM


All times are GMT -5. The time now is 08:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration