LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-29-2005, 03:54 AM   #16
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77

Quote:
Originally posted by mrGenixus
This seems to be a bug in 2.6.11, I would google this, before posting any additional questions.

reddazz: How did you recompile your kernel?
Same as what everyone else is doing, but using the .config from Fedora (a new kernel and not a recompilation).
 
Old 03-29-2005, 07:38 PM   #17
wilu
LQ Newbie
 
Registered: Jan 2005
Location: Nowa Huta (Poland)
Distribution: Gentoo
Posts: 23

Original Poster
Rep: Reputation: 15
WOW!!!

IT WORKS

Solution is so SIMPLE!!
System needs an initial ramdisk to boot... but I didn`t mark this option in kernel.
In block devices section RAM DISK SUPPORT has to be compiled in (not as a module) and Initial RAM disk (initrd) support has to be activated
 
Old 03-30-2005, 11:35 AM   #18
mrGenixus
Member
 
Registered: Dec 2004
Location: Colorado, US
Distribution: gentoo, debian, ubuntu live gnome 2.10
Posts: 440

Rep: Reputation: 30
YOu weren't using an initrd? I can't believe I missed this!
 
Old 04-08-2005, 02:20 AM   #19
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 19,967

Rep: Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633
Can't be as simple as initrd. On the same day (yesterday), I emerged 2.6.11 on my Gentoo, and downloaded 2.6.11.6 for my new Slack install.

Both on the same laptop, neither using initrd. The Slack reboot fails with the initial console problem.
Have a feeling it might be ACPI or similar. Did put it in so I could test it on the Dell.
Will check it when I get back in the office next week - didn't have time as I was heading out the door.
 
Old 04-14-2005, 11:48 PM   #20
sarojkmohapatra
LQ Newbie
 
Registered: Jan 2005
Posts: 6

Rep: Reputation: 0
but all the above mentioned steps produce a fine result with kernel 2.4.xx then why the same does not wrok with 2.6.xx. is there any major change ?
 
Old 04-15-2005, 12:03 AM   #21
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 19,967

Rep: Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633Reputation: 3633
It gets weirder.
I updated to udev on the Gentoo install.
It issues the "inital console" message, but boots successfully.

The Slack install (same laptop remember), now works. Does the same as Gentoo (message, but continues to start-up o.k.). Previously it would issue the message, then re-boot automatically; looping continually.

The only change ??? - it was left powered off all night.
I kid you not. It now works, with *NO* kernel or boot-option changes.
 
Old 04-15-2005, 12:53 AM   #22
sarojkmohapatra
LQ Newbie
 
Registered: Jan 2005
Posts: 6

Rep: Reputation: 0
in block device driver make sure RAM disk support is enabled as part of kernel and not as a module. in file systems ext2/3 are part of kernel and not module. and finalii mkinitrd the new image and add it to grub/lilo
 
Old 04-19-2005, 06:34 AM   #23
sarnath
LQ Newbie
 
Registered: Apr 2005
Location: India
Posts: 1

Rep: Reputation: 0
Configure DEVFS and u r through!

I had this same problem and found the solution somewhere in the net.

Configure DEVFS and enable "Mount devfs on boot" and use the new kernel to bootup. That should get u off the problem.

I believe that the default FEDORA kernel comes with DEVFS configured. So the /dev entries do NOT actually go into the hard disk. In short, you do NOT have persistent /dev entries if u r running the FEDORA kernel.

So, if you try to boot a kernel that does not have DEVFS configured then the applications do not find /dev/ entries and the system stops.

I was able to boot without any RAMDISK. No initrd stuff is required.

I hope this helped.
 
Old 04-24-2005, 04:48 PM   #24
colincross
LQ Newbie
 
Registered: Apr 2005
Posts: 1

Rep: Reputation: 0
2 solutions

I believe the problem is with the use of udev in Fedora Core 3. Udev creates all of the entries in /dev at boot time, but the kernel tries to open /dev/console before udev has run. There are two ways to make sure /dev/console exists before your root filesystem has been mounted, and udev has run. Both have been mentioned in this thread, but I thought I'd try to explain why they solve the problem, and which is recommended.

The first (and better) way is to use mkinitrd to create an initial ramdisk, and attach it to your boot kernel in /etc/grub.conf. This creates a tiny compressed filesystem that is mounted as the root file system when the kernel first starts, and it provides basic /dev/ entries as well as any modules the kernel needs to load to find the real root filesystem. This requires initrd support compiled into your kernel, but any other drivers can be created as modules instead of being compiled in.

The second (and deprecated) way is to enable DEVFS, which creates a fake filesystem on /dev that provides all the required entries. The kernel team has decided that devfs is inappropriate, as the problem is better handled in userspace - thus the creation of udev. Devfs may dissappear in the future, and it may have compatibility problems with FC3, which is expecting udev.
 
Old 05-09-2005, 04:06 PM   #25
Bjorn S
LQ Newbie
 
Registered: May 2005
Posts: 2

Rep: Reputation: 0
Awesome! Thanks, that took care of the problem for me. I've never had to deal with initrd before FC 3, but doing it now enabled my kernel build to boot properly.

Bjorn.
 
Old 05-10-2005, 12:37 AM   #26
sarojkmohapatra
LQ Newbie
 
Registered: Jan 2005
Posts: 6

Rep: Reputation: 0
its fine to compile 2.6 on FC3. but what to do when I want 2.4 to cmile on FC3, GCC 3.4 is default in FC3 and creatss a large number of warning and erros in 2.4 kernel. any idea how to solve ?
 
Old 06-07-2005, 12:33 AM   #27
krindik
LQ Newbie
 
Registered: Jun 2005
Distribution: Fedora Linux
Posts: 10

Rep: Reputation: 0
hey,
have da same problem "unable to open initial console"
here is my situation
lost my boot partition together with FC3 kernel!?
now booting from a different partition from knopix kernels
cant boot FC3 with knopix kernel?
gives the above error
can u help me in some way

TIA
krindik
 
Old 06-16-2005, 11:15 AM   #28
JPlum
LQ Newbie
 
Registered: Jun 2005
Location: PA (USA)
Posts: 6

Rep: Reputation: 0
FWIW, I'm also seeing the same problem with a 2.6.11.11 kernel on a dual Opteron system installed with FC3 (which runs fine with stock FC3 updated kernels).

Curiosly the same kernel runs fine on a Dual Xeon (w/EMT64) system when copied there. Certainly I could have ommitted a driver needed for the Opteron but not the Xeon, but I can't see anything obviously console related that could be needed for the Opteron.
 
Old 06-16-2005, 11:04 PM   #29
krindik
LQ Newbie
 
Registered: Jun 2005
Distribution: Fedora Linux
Posts: 10

Rep: Reputation: 0
hi,

well i gotta work around this and my system works fine.
wat missing in the system seem to be /dev/console. so checked the /dev and found blank.
booted with knoppix and cp -dpR /dev/* /mnt/(root)/dev/
this works !
if u dont have knoppix i think booting to rescue mode and doing the same will do.


krindik
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to open initial console ayoub Linux - Newbie 9 11-22-2005 10:53 AM
error: unable to open an initial console gaco Linux - Newbie 5 08-18-2004 08:30 AM
Unable to open an initial console xanthas12 Linux - General 2 04-23-2003 02:38 AM
Warning: unable to open an initial console. tomkeys Linux From Scratch 1 02-24-2003 10:34 PM
unable to open initial console elettrozero Linux - General 2 03-29-2002 11:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration