LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-21-2004, 09:40 PM   #1
the_sLiDe
Member
 
Registered: Sep 2004
Distribution: Slack 10
Posts: 155

Rep: Reputation: 30
simple question about fluxbox


Hey guys. I know this is probably simple but i have no clue how to do this.... I want to make it so when i type startx fluxbox starts, not KDE. Thnx guys!
 
Old 10-21-2004, 10:02 PM   #2
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Rep: Reputation: 15
Two simple ways to do this:

1) change the global setting.
I dunno about redhat, but for your slack:
Code:
$ cd /etc/X11/xinit
$ mv xinitrc xinitrc.orig
$ ln -s xinitrc.fluxbox xinitrc

2) change your personal settings.
I also use fluxbox on slack, and this is how I do it.
All you need to do is set up one file in your home dir: ".xinitrc"
Don't forget to chmod +x it. You need it to be executable!

Here's mine:
Code:
#!/bin/bash

# # start xscreensaver
xscreensaver &

# start window manager and get PID
fluxbox &
WMPID=$!

#### Once we started fluxbox, run some stuff I like to use.
#### the ampersands (&) are important!
# run dockapps
~/.fluxbox/dockapps.sh &
# xcompmgr turns on shadows, fading, transparency, etc
xcompmgr -cfC &
# purty desktop!
kdesktop &
#####

# wait for fluxbox to terminate.
wait $WMPID
The way .xinitrc works, is startx runs it, and when it terminates, so does your X session. That's why we wait for the window manager to terminate at the end: that way, when you use fb's "logout" option, the x session ends.

Incidentally, you may want to do this while you're at it:
Code:
$ ln -s .xinitrc .xsession
.xsession works much like .xinitrc. It's the script called by X/K/GDM when you select "custom" under session type. So if you decide to use XDM instead of startx, you get the exact same session.


--S

(edit: turned off the fucking smileys)

Last edited by Sinope; 10-21-2004 at 10:03 PM.
 
Old 10-21-2004, 11:35 PM   #3
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,098

Rep: Reputation: 54
after you log in with slack, before you startx, type xwmconfig, scroll down to flux and choose it, then type startx...that will set it as your default.
 
Old 10-22-2004, 10:57 AM   #4
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
I created a .xinitrc file in my /home and enter the line "exec fluxbox"

If you want to go back to KDE as your default just remove the .xinitrc in your /home.

Kent
 
Old 11-08-2004, 04:09 PM   #5
chaosego
Member
 
Registered: Sep 2004
Location: Canada.
Distribution: Slackware 10, SuSE 9.1, VectorLinux 4.3
Posts: 56

Rep: Reputation: 15
Sinope:

I found your custom .xinitrc file very helpful, and I basically copy and pasted it, and modified it to come up with my own. I only have one problem. Now when I start flux the slit looks f*cked up. I can post screen shots of the difference, but the main thing is it doesn't really have an outline anymore. It's not nearly ass attractive.

I get the nice looking slit when I do "% startx" with NO ~/.xinitrc existing. However, as soon as I create the .xinitrc file, it gives me an ugly slit.

Any light, anyone can shed on this would be great.
 
Old 11-08-2004, 04:27 PM   #6
chaosego
Member
 
Registered: Sep 2004
Location: Canada.
Distribution: Slackware 10, SuSE 9.1, VectorLinux 4.3
Posts: 56

Rep: Reputation: 15
I just realized too, all the tabs for my windows are gone now!
 
Old 11-08-2004, 10:30 PM   #7
chaosego
Member
 
Registered: Sep 2004
Location: Canada.
Distribution: Slackware 10, SuSE 9.1, VectorLinux 4.3
Posts: 56

Rep: Reputation: 15
I would still be interested in the answer to this question, but I solved the problem by removing the ~/.xinitrc and just modifying the /etc/X11/xinitrc/xinitrc.fluxbox file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Fluxbox simple question, simple answer? generallimptoes Linux - Software 3 09-26-2005 03:03 PM
Simple Fluxbox Questions TomalakBORG Linux - Software 10 03-02-2005 12:41 PM
Simple fluxbox problem?? jacksmash Linux - Software 4 10-16-2004 04:12 AM
Simple fluxbox question... NonSumPisces Linux - Software 3 07-04-2004 07:21 PM
Installing Programs - A simple question from my simple mind jmp875 Linux - Newbie 6 02-18-2004 10:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration