LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-06-2015, 02:31 PM   #16
michaelk
Moderator
 
Registered: Aug 2002
Posts: 23,657

Rep: Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172

CentOS 6.6 32 bit here but I assume the difference could be due to running on a VPS.

Do you have a /usr/local/apache/bin/envvars

Last edited by michaelk; 07-06-2015 at 02:57 PM.
 
Old 07-06-2015, 05:29 PM   #17
Bashed
Member
 
Registered: Jul 2015
Posts: 123

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by michaelk View Post
CentOS 6.6 32 bit here but I assume the difference could be due to running on a VPS.

Do you have a /usr/local/apache/bin/envvars
Yes.

Content:

Quote:
# Licensed to the Apache Software Foundation (ASF) under one or more
# contributor license agreements. See the NOTICE file distributed with
# this work for additional information regarding copyright ownership.
# The ASF licenses this file to You under the Apache License, Version 2.0
# (the "License"); you may not use this file except in compliance with
# the License. You may obtain a copy of the License at
#
# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS,
# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
# See the License for the specific language governing permissions and
# limitations under the License.
#
#
# envvars-std - default environment variables for apachectl
#
# This file is generated from envvars-std.in
#
if test "x$LD_LIBRARY_PATH" != "x" ; then
LD_LIBRARY_PATH="/usr/local/apache/lib:$LD_LIBRARY_PATH"
else
LD_LIBRARY_PATH="/usr/local/apache/lib"
fi
export LD_LIBRARY_PATH
#
This is what the script developer said about the particular WP plugin:

Quote:
Please note the following major requirements of WP Twin:
- system() and exec() PHP functions should be allowed to run on the server.
- zip, unzip, mysql, mysqldump, grep, and sed have to be available commands on the server.
- The UID that scripts run under has to have rights to write files. (We have a test file that can confirm the UID and the commands above)
- The mySQL database user has to have FULL rights to the database.
The thing is, disable_functions in php.ini is blank anyway.

I ran a test file they gave me:

Results.

WPTwin Test File

UID:

cURL: cURL is installed

ZIP and MYSQLDUMP:
MySql Dump Path:
MySql Path:
zip Path:
unzip Path:
grep Path:
sed Path:

Notice: Undefined index: t in /home/---/public_html/wptwintest.php on line 39

Last edited by Bashed; 07-06-2015 at 05:31 PM.
 
Old 07-06-2015, 05:36 PM   #18
michaelk
Moderator
 
Registered: Aug 2002
Posts: 23,657

Rep: Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172Reputation: 5172
Did you try adding export PATH=$PATH:/usr/bin to /usr/local/apache/bin/envvars?
 
Old 07-06-2015, 05:41 PM   #19
Bashed
Member
 
Registered: Jul 2015
Posts: 123

Original Poster
Rep: Reputation: Disabled
Yes, restarted httpd but didn't fix the issue.

Errors

[Mon Jul 06 17:40:08 2015] [error] [client ] sh: which: command not found
[Mon Jul 06 17:40:19 2015] [error] [client ] sh: whoami: command not found
[Mon Jul 06 17:40:19 2015] [error] [client ] sh: zip: command not found
[Mon Jul 06 17:40:36 2015] [error] [client ] sh: mysqldump: command not found, referer: http://domain.com/wptwin.php
[Mon Jul 06 17:40:36 2015] [error] [client ] sh: zip: command not found, referer: http://domain.com/wptwin.php
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Apache error_log line: sh: zip: command not found AcorpComputers Linux - Server 2 06-09-2012 05:17 AM
ZIP 100drive atapi ide -not found!!!! chilibowl Linux - Hardware 3 11-02-2011 07:11 PM
How to zip several files to several zip with one command? thomas2004ch Linux - Newbie 4 02-08-2010 09:13 AM
bash: rpm: command not found && sudo: alien: command not found Java_Code Ubuntu 7 07-28-2006 12:57 AM
Klamav - virus found - Zip.ExceededFilesLimit rrsc16954 Mandriva 7 01-16-2006 07:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration