LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-01-2017, 10:13 AM   #16
maschelsea
Member
 
Registered: Dec 2016
Distribution: Slackware 64bit 14.2
Posts: 422

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by Shadow_7 View Post
Already in use is probably pulseaudio. Depending on your distro.

$ grep -i autospawn /etc/pulse/client.conf

If you change that to "autospawn = no", you can stop pulseaudio.

$ pulseaudio --kill

And with a pulse over jack setup you can restart it $(pulseaudio --start), after starting jackd. Without the autospawn=no, the init system will by default restart pulseaudio. Various other routes with snd-aloop plus other tricks.

I ran your grep command. autospawn was set to yes, so I loaded the file in vim and set autospawn = no. Then I issued 'pulseaudio --kill, which didn't work. So I checked ps and found the pulseaudio process and sent it a kill -9. After that jack started, and pulseaudio CLAIMS to start, but I have no sound in either mpg123 or pianobar.
Code:
root@caitlyn:~# grep -i autospawn /etc/pulse/client.conf
autospawn = yes
allow-autospawn-for-root = yes
root@caitlyn:~# vim /etc/pulse/client.conf
root@caitlyn:~# pulseaudio --kill
E: [pulseaudio] main.c: Failed to kill daemon: No such process
root@caitlyn:~# ps ax | grep pulseaudio
 1455 ?        Sl     0:01 /usr/lib64/xfce4/panel/wrapper-2.0 /usr/lib64/xfce4/panel/plugins/libpulseaudio-plugin.so 5 14680097 pulseaudio PulseAudio Plugin Adjust the audio volume of the PulseAudio sound system
 1609 ?        Sl     4:55 /usr/bin/pulseaudio --start --log-target=syslog
10101 pts/0    S+     0:00 grep pulseaudio
root@caitlyn:~# kill -9 1609
root@caitlyn:~# ps ax | grep pulseaudio
 1455 ?        Sl     0:01 /usr/lib64/xfce4/panel/wrapper-2.0 /usr/lib64/xfce4/panel/plugins/libpulseaudio-plugin.so 5 14680097 pulseaudio PulseAudio Plugin Adjust the audio volume of the PulseAudio sound system
10103 pts/0    S+     0:00 grep pulseaudio
root@caitlyn:~# jackd -d alsa -d hw:0 -r 48000 -n 3 -p 512
jackd 0.124.1
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:0|hw:0|512|3|48000|0|0|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 512 frames (10.7 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 3 periods for playback
^Z
[2]+  Stopped                 jackd -d alsa -d hw:0 -r 48000 -n 3 -p 512
root@caitlyn:~# bg
[2]+ jackd -d alsa -d hw:0 -r 48000 -n 3 -p 512 &


**** alsa_pcm: xrun of at least -773626593.280 msecs


root@caitlyn:~# ls /etc/rc.d
init.d/           rc.cpufreq*          rc.lxc                  rc.syslog*
rc.0@             rc.cups              rc.mcelog*              rc.sysstat
rc.4*             rc.cups-browsed      rc.messagebus*          rc.sysvinit*
rc.6*             rc.cups.orig         rc.modules*             rc.timidity
rc.K*             rc.dnsmasq           rc.modules.local*       rc.tor*
rc.M*             rc.font              rc.modules.local.orig*  rc.udev*
rc.S*             rc.fuse*             rc.modules.local~*      rc.ulogd*
rc.S.orig*        rc.gpm*              rc.mysqld*              rc.vboxautostart-service*
rc.acpid*         rc.httpd             rc.networkmanager*      rc.vboxballoonctrl-service*
rc.alsa*          rc.inet1*            rc.nfsd                 rc.vboxdrv*
rc.alsa-oss       rc.inet1.conf        rc.ntpd*                rc.wireless*
rc.atalk          rc.inet1.conf.new    rc.ntpd.orig*           rc.wireless.conf
rc.autofs         rc.inet1.orig*       rc.pcmcia               rc.yp
rc.bind           rc.inet2*            rc.php-fpm              rc0.d/
rc.bluetooth*     rc.inetd*            rc.pulseaudio           rc1.d/
rc.cgconfig       rc.ip_forward        rc.rpc                  rc2.d/
rc.cgconfig.orig  rc.local*            rc.samba                rc3.d/
rc.cgmanager*     rc.local.orig*       rc.saslauthd            rc4.d/
rc.cgproxy*       rc.local_shutdown*   rc.sendmail*            rc5.d/
rc.cgred          rc.local_shutdown~*  rc.serial               rc6.d/
rc.cgred.orig     rc.local~*           rc.snmpd
rc.consolekit*    rc.loop*             rc.sshd*
root@caitlyn:~# chmod +x /etc/rc.d/rc.pulseaudio 
root@caitlyn:~# /etc/rc.d/rc.pulseaudio start
Starting system PulseAudio daemon:  /usr/bin/pulseaudio --system --disallow-module-loading &
root@caitlyn:~# /etc/rc.d/rc.pulseaudio restart
Stopping PulseAudio:  /bin/killall pulseaudio
Starting system PulseAudio daemon:  /usr/bin/pulseaudio --system --disallow-module-loading &
root@caitlyn:~#
I think I'm going to have to change autospawn back to yes, and then reboot the computer to get back to the state I was in before. Do you have any other ideas? I'm sorry I'm being so whiney.
 
Old 06-01-2017, 11:42 AM   #17
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
pulseaudio over jackd requires extra configuration, which is probably not a distro default.

Here's how mine is setup:

FILE: $HOME/.asoundrc
Code:
ctl.pulse { type pulse fallback sysdefault }
pcm.pulse { type pulse fallback sysdefault }
ctl.!default { type pulse fallback sysdefault }
pcm.!default { type pulse fallback sysdefault }
Amended to FILE: /etc/pulse/client.conf
Code:
##### custom 20170522 #####
autospawn = no
Amended to FILE: /etc/pulse/default.pa
Code:
##### custom 20170522 #####
load-module module-native-protocol-tcp auth-ip-acl=192.168.2.0/24;127.0.0.1
set-default-sink jack_out
set-default-source jack_in
This allows sharing over tcp/ip with "other" users on the same machine on localhost, and over the network on a subnet. Kind of nice to not have to buy two high end interfaces and two sets of speakers. Plus it offloads a bit of processing from the main machine. The last two allow jack so I can run things like a 30 band EQ with calf plugins.

Amended to FILE: /etc/pulse/daemon.conf
Code:
##### custom 20170522 #####
default-sample-format = s16le
default-sample-rate = 48000
realtime-scheduling = no
exit-idle-time = -1
For all the "OTHER" users who did NOT start pulseaudio.

Amended to FILE: $HOME/.config/pulse/client.conf
Code:
default-server = 192.168.2.1
or
Code:
default-server = 127.0.0.1
Where the IP is the actual ip of the machine running pulseaudio. Plus extra packages installed

package: pulseaudio
package: pulseaudio-module-jack
package: pavucontrol
package: qjackctl

Once it's all started up I use qjackctl to ensure that pulseaudio is listed, which means it's good to go. If it doesn't show up I stop/start pulseaudio again.

$ pulseaudio --kill
$ pulseaudio --start

While pulse is NOT running is when you start jackd. You don't need pulseaudio or jackd though as timidity++ can run against alsa natively, it's been a while but "-iA -Os" as the flags for timidity to use alsa. Although it has to be compiled in a certain way, which is debians default options NOW, but older versions didn't and I had to custom compile that one. And double check those options. Once it's functional it should show up with aconnect (like qjackctl, more like jack_connect, but for alsa).

$ timidity++ -iA -Os &
$ aconnect -ol

Otherwise the pulse over jackd method covers all the bases. Option number 3 from below is what my setup is based off of and relative to debian jessie at the moment.

http://jackaudio.org/faq/pulseaudio_and_jack.html

.

Last edited by Shadow_7; 06-01-2017 at 11:47 AM.
 
Old 06-01-2017, 11:46 AM   #18
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Also check the logs as to WHY pulseaudio didn't start.

$ sudo less /var/log/syslog

or

$ sudo journalctl -a

for systemd-ish ways. with "/" and "pulse", then ENTER to search. Or press END if it's the very last thing you tried. Same hotkeys as less / man / ... aka whatever pager is default for your distro (probably less).
 
Old 06-01-2017, 11:51 AM   #19
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Also note that in client.conf if it starts with ;, then that is a comment. Distros often comment options when the value listed is the assumed default value.

FILE: /etc/pulse/client.conf
Code:
; autospawn = yes
autospawn = no
The NO is actually used, and not because it was listed last, but because it wasn't a comment.
 
Old 06-01-2017, 07:00 PM   #20
LilZebra
LQ Newbie
 
Registered: Dec 2015
Distribution: Fedora 24 Workstation (64-bit)
Posts: 22

Rep: Reputation: Disabled
So once I'm finished with JACK can I just use

Code:
pulseaudio --start
instead of deleting or renaming ~/.pulse ?

Last edited by LilZebra; 06-01-2017 at 07:18 PM.
 
Old 06-01-2017, 08:26 PM   #21
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Yes and no, with a pulse over jack setup, you start jack, THEN you start pulse and it "should" work. But you cannot start jack when pulse is already running. Plus it likely doesn't work out of the box at boot time, and needs manual intervention after every boot cycle. Sadly if you skype or modern browser, you kind of have to put up with pulse these days. If you're just doing local media creation, you can pretty much uninstall it and be golden. Or option 4 from the previous link of suspend PA.

As far as configurations for local users, ~/.pulse is OLD, the more recent (past 5+ years or more) use ~/.config/pulse/ for those things. In fact having ~/.pulse or /.pulse (if root oops) REALLY gets in the way of the proper functioning of pulse. I tend to delete all of the above if it's awkward and then start pulse again. Just be sure to use pavucontrol after you start it to manage levels and devices. With the short answer being to disable all the devices under Configuration in pavucontrol, except the one you actually want to use. Most anything beyond that with pulse over jack will be done with qjackctl or the jack_* options for fancy routing like the calf plugin for a 30 band EQ. Depending on how much RAM, CPU, and latency that you find acceptable.
 
Old 06-01-2017, 08:33 PM   #22
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Once it all works you should be able to get by with stop, start, and qjackctl to route. No need to delete anything unless you Oopsies by trying to stop or start pulse as root.

The networking stuff I showed earlier is supplemental if you ONLY use ONE user and otherwise don't network your audio. I tend to use multiple users, one per task, browser, game, youtube, and such. Plus multiple machines so nice to use one good sound card and one good set of speakers. Also nice to have hardware options like a headphone preamp to have some arms reach analog knobs and a mute button.
 
Old 06-02-2017, 01:31 PM   #23
maschelsea
Member
 
Registered: Dec 2016
Distribution: Slackware 64bit 14.2
Posts: 422

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Shadow_7 View Post
pulseaudio over jackd requires extra configuration, which is probably not a distro default.

Here's how mine is setup:

FILE: $HOME/.asoundrc
Code:
ctl.pulse { type pulse fallback sysdefault }
pcm.pulse { type pulse fallback sysdefault }
ctl.!default { type pulse fallback sysdefault }
pcm.!default { type pulse fallback sysdefault }
Amended to FILE: /etc/pulse/client.conf
Code:
##### custom 20170522 #####
autospawn = no
Amended to FILE: /etc/pulse/default.pa
Code:
##### custom 20170522 #####
load-module module-native-protocol-tcp auth-ip-acl=192.168.2.0/24;127.0.0.1
set-default-sink jack_out
set-default-source jack_in
This allows sharing over tcp/ip with "other" users on the same machine on localhost, and over the network on a subnet. Kind of nice to not have to buy two high end interfaces and two sets of speakers. Plus it offloads a bit of processing from the main machine. The last two allow jack so I can run things like a 30 band EQ with calf plugins.

Amended to FILE: /etc/pulse/daemon.conf
Code:
##### custom 20170522 #####
default-sample-format = s16le
default-sample-rate = 48000
realtime-scheduling = no
exit-idle-time = -1
For all the "OTHER" users who did NOT start pulseaudio.

Amended to FILE: $HOME/.config/pulse/client.conf
Code:
default-server = 192.168.2.1
or
Code:
default-server = 127.0.0.1
Where the IP is the actual ip of the machine running pulseaudio. Plus extra packages installed

package: pulseaudio
package: pulseaudio-module-jack
package: pavucontrol
package: qjackctl

Once it's all started up I use qjackctl to ensure that pulseaudio is listed, which means it's good to go. If it doesn't show up I stop/start pulseaudio again.

$ pulseaudio --kill
$ pulseaudio --start

While pulse is NOT running is when you start jackd. You don't need pulseaudio or jackd though as timidity++ can run against alsa natively, it's been a while but "-iA -Os" as the flags for timidity to use alsa. Although it has to be compiled in a certain way, which is debians default options NOW, but older versions didn't and I had to custom compile that one. And double check those options. Once it's functional it should show up with aconnect (like qjackctl, more like jack_connect, but for alsa).

$ timidity++ -iA -Os &
$ aconnect -ol

Otherwise the pulse over jackd method covers all the bases. Option number 3 from below is what my setup is based off of and relative to debian jessie at the moment.

http://jackaudio.org/faq/pulseaudio_and_jack.html

.
I've made all the suggested changes to the appropriate files. I have issued the following commands as my personal account user:
Code:
michael@caitlyn michael $ timidity -iA -Os &
[1] 30146
michael@caitlyn michael $ Requested buffer size 32768, fragment size 8192
ALSA pcm 'default' set buffer size 33868, period size 3760 bytes
TiMidity starting in ALSA server mode
Opening sequencer port: 128:0 128:1 128:2 128:3

michael@caitlyn michael $ aconnect -ol
client 128: 'TiMidity' [type=user]
    0 'TiMidity port 0 '
    1 'TiMidity port 1 '
    2 'TiMidity port 2 '
    3 'TiMidity port 3 '
client 129: 'rosegarden' [type=user]
    0 'record in       '
	Connected From: 0:1
    2 'external controller'
michael@caitlyn michael $ ps ax | grep pulseaudio
28474 ?        Sl     0:01 /usr/lib64/xfce4/panel/wrapper-2.0 /usr/lib64/xfce4/panel/plugins/libpulseaudio-plugin.so 5 14680097 pulseaudio PulseAudio Plugin Adjust the audio volume of the PulseAudio sound system
30168 pts/3    S+     0:00 grep pulseaudio
michael@caitlyn michael $ pulseaudio --start
N: [pulseaudio] main.c: User-configured server at 127.0.0.1, refusing to start/autospawn.
michael@caitlyn michael $ pulseaudio --start
At this moment, not only do I have no midi in rosegarden, I also have no sound anywhere in Linux, and my stupid pulseaudio applet keeps popping up to tell me that pulseaudio is not working. Pulseaudio will not start.
Code:
root@caitlyn:~# journalctl -a
-su: journalctl: command not found
root@caitlyn:~# grep pulseaudio /var/log/syslog 
Jun  1 16:56:37 caitlyn pulseaudio[1424]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service files
Jun  1 16:56:37 caitlyn pulseaudio[1443]: [pulseaudio] pid.c: Daemon already running.
And I don't know why pulseaudio will not restart. The only thing /var/log/messages tells me about it is that it will not start.
 
Old 06-02-2017, 02:02 PM   #24
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
You do NOT need the $HOME/.config/pulse/client.conf for the USER who STARTS pulseaudio. Alsa shares the sound card by default, pulse locks it down to the user who starts it. The networking half is to enable "sharing" by network or pseudo network (localhost). The user which starts pulseaudio is NOT sharing, it's the owner / bossman / head haunch.
 
Old 06-02-2017, 03:06 PM   #25
maschelsea
Member
 
Registered: Dec 2016
Distribution: Slackware 64bit 14.2
Posts: 422

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Shadow_7 View Post
You do NOT need the $HOME/.config/pulse/client.conf for the USER who STARTS pulseaudio. Alsa shares the sound card by default, pulse locks it down to the user who starts it. The networking half is to enable "sharing" by network or pseudo network (localhost). The user which starts pulseaudio is NOT sharing, it's the owner / bossman / head haunch.
Code:
michael@caitlyn michael $ cat .config/pulse/client.conf 
default-server = 127.0.0.1
root starts pulse at bootup.
 
Old 06-03-2017, 06:47 AM   #26
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Quote:
Originally Posted by maschelsea View Post
Code:
$ cat .config/pulse/client.conf 
default-server = 127.0.0.1
root starts pulse at bootup.
That's probably why it does not work for you. No "USER" has the permissions of root. In debian the polkitd (package policykit-1) and rtkit-daemon (package rtkit) handle the root side of the equation and pulseaudio runs as the user. Generally the same user who starts / logs into X11. Where the RT in rtkit stands for realtime, not root. All of which are deps of pulseaudio in debian. Having /.pulse or /root/.pulse and friends (like /root/.config/pulse/), which you'll have if you run pulseaudio as root, effectively breaks things.

$ mv $HOME/.config/pulse/client.conf $HOME/.config/pulse/zlient.conf
$ sudo kill -9 $(pgrep pulseaudio)
$ sudo rm -rf /root/.config/pulse
$ pulseaudio --start

And maybe things will work for you.

$ speaker-test -c 2 -l 1
 
Old 06-04-2017, 03:57 PM   #27
maschelsea
Member
 
Registered: Dec 2016
Distribution: Slackware 64bit 14.2
Posts: 422

Original Poster
Rep: Reputation: Disabled
michael@caitlyn michael $ speaker-test -c 2 -l 1

speaker-test 1.1.1

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
0 - Front Left
1 - Front Right
Time per period = 10.938314


Also, qjackctl did not start. Message window said:
Code:
michael@caitlyn michael $ speaker-test -c 2 -l 1

speaker-test 1.1.1

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 10.938314
And even though the output from speaker test looked good to me, I have no sound. At all. Hopefully it will come back after I reboot the computer, but I'd have to undo some of the stuff you suggested before that would happen. My Pulseaudio applet says "HDMI/Displayport (unplugged), but I have not manually unplugged anything. Thank you for being patient with me.

Last edited by maschelsea; 06-04-2017 at 03:59 PM.
 
Old 06-04-2017, 04:15 PM   #28
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
If you're needing HDMI audio, you probably need to append the speaker-test with that device. Or override it with a .asoundrc.

$ speaker-test -c 2 -l 1 -D hw:0,3

or

$ speaker-test -c 2 -l 1 -D pulse

Although -D pulse would be the assumed default if pulseaudio was running. Perhaps omit -l 1 and run pavucontrol while it runs to configure things. Sometimes you have to disable / re-enable a card for pulseaudio to become sentient again. It's like a loopy X-girlfriend, constantly forgetting that the nature of your relationship has changed.
 
Old 06-04-2017, 04:58 PM   #29
maschelsea
Member
 
Registered: Dec 2016
Distribution: Slackware 64bit 14.2
Posts: 422

Original Poster
Rep: Reputation: Disabled
Code:
michael@caitlyn michael $ speaker-test -c 2 -l 1 -D pulse

speaker-test 1.1.1

Playback device is pulse
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 10.938541
My ~/.asoundrc file says:

Code:
michael@caitlyn michael $ cat .asoundrc
ctl.pulse { type pulse fallback sysdefault }
pcm.pulse { type pulse fallback sysdefault }
ctl.!default { type pulse fallback sysdefault }
pcm.!default { type pulse fallback sysdefault }
And still no sound. Just for kicks and giggles, I tried your other line.
Code:
michael@caitlyn michael $ speaker-test -c 2 -l 1 -D hw:0,3

speaker-test 1.1.1

Playback device is hw:0,3
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Playback open error: -2,No such file or directory
Does this reveal anything helpful?

Last edited by maschelsea; 06-04-2017 at 05:00 PM.
 
Old 06-04-2017, 05:58 PM   #30
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
It reveals that your HDMI audio is NOT hw:0,3. AKA open error..., AKA No such file...

$ egrep -r -i hdmi /proc/asound/*

where ...card0/pcm3p... would be hw:0,3 and other values as applicable.

$ aplay -l

$ aplay -L

Shows up as:

plughw:CARD=Generic,DEV=3
HD-Audio Generic, HDMI 0
Hardware device with all software conversions

on my system which would be -D hw:Generic,3 where Generic is just another names for 0:

card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

So -D hw:0,3 on my system, but -D hw:Generic,3 would work too. But if pulse is in play and working, you can use pavucontrol to mouse click the output you desire. Ignore the jack stuff previously mentioned, on a good day, system defaults should work. YMMV depending on distro. I'm not a fan of ubuntu, but they tend to get pulse right out of the box. So on a bad day you could just cut and paste their configs to almost any distro.
 
  


Reply

Tags
jack, midi, rosegarden


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound in rosegarden/qsynth jpee Linux - General 1 11-11-2015 04:56 PM
Rosegarden help! Can't get sound from keyboard. jimmyjazzstl Linux - Software 0 07-22-2009 06:30 PM
No sound with Rosegarden linmix Linux - Software 27 11-25-2006 10:39 AM
Rosegarden; sound is muted? Nailgun Linux - Software 7 11-05-2006 02:20 PM
no sound for rosegarden drethenerd Linux - Software 9 08-22-2005 12:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration