LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-01-2013, 10:54 AM   #1
Steve W
Member
 
Registered: Mar 2007
Distribution: Ubuntu 12.04, XUbuntu 12.04
Posts: 504

Rep: Reputation: 44
Question about editing grub.cfg


On my laptop with Linux Mint 12 LXDE installed, if I select the default load option in the Grub bootloader, the laptop hangs. However, if I select the "safe mode" second option, it sometimes loads successfully but other times puts up a message: "fixing recursive fault but reboot is needed”, then hangs. However, on doing a power reset, I can (for that one time only) load up normally with the first option.

A Google search for this error brings up a page advising to add to the grub boot line "acpi=off nomodeset xforcevesa".

I presume this means editing /boot/grub/grub.cfg (with "Do not edit this file" in capitals at the top!), but where exactly in the file would I put that new line?
 
Old 02-01-2013, 11:12 AM   #2
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: /LFS/Debian
Posts: 2,482
Blog Entries: 1

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Hi

This is my grub.cfg with nomodeset added
Code:
menuentry "CentOS release 6.3 (Final) (on /dev/sdd1)" --class gnu-linux --class gnu --class os {
	insmod part_msdos
	insmod ext2
	set root='(hd3,msdos1)'
	search --no-floppy --fs-uuid --set=root f6321353-2b1e-4e95-b48b-f5f229825152
	linux /boot/vmlinuz-2.6.32-279.19.1.el6.i686 root=/dev/sdd1 quiet nomodeset
	initrd /boot/initramfs-2.6.32-279.19.1.el6.i686.img
You will have to edit the file with sudo privlages or root
 
Old 02-01-2013, 11:39 AM   #3
Steve W
Member
 
Registered: Mar 2007
Distribution: Ubuntu 12.04, XUbuntu 12.04
Posts: 504

Original Poster
Rep: Reputation: 44
Thanks. At that point in my grub it goes: quiet splash vt.handoff=7

Do I add "nomodeset" onto the end of that, or instead of "splash"?
 
Old 02-01-2013, 11:44 AM   #4
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: /LFS/Debian
Posts: 2,482
Blog Entries: 1

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Hi

No add it after the handoff=7 nomodeset
 
Old 02-01-2013, 12:04 PM   #5
Steve W
Member
 
Registered: Mar 2007
Distribution: Ubuntu 12.04, XUbuntu 12.04
Posts: 504

Original Poster
Rep: Reputation: 44
Thanks, I'll give it a go. If that doesn't work, I'll stick the rest of the "acpi=off nomodeset xforcevesa" in there...
 
Old 02-01-2013, 12:30 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866
As the grub.cfg file warns you already, do not edit it. All changes will be lost the next time the system launches the update-grub command. Instead, add your options (by the way, I would try one at a time, so that you can see which one solves the problem) to the options that exist already for GRUB_CMDLINE_LINUX_DEFAULT in the file /etc/default/grub. After that, launch update-grub to apply your changes to the configuration.
 
Old 02-03-2013, 04:37 PM   #7
Steve W
Member
 
Registered: Mar 2007
Distribution: Ubuntu 12.04, XUbuntu 12.04
Posts: 504

Original Poster
Rep: Reputation: 44
Yes, that did the job. No more hanging on startup. Thank you for your assistance, Spiky and TobiSGD.
 
Old 02-06-2013, 03:07 PM   #8
Steve W
Member
 
Registered: Mar 2007
Distribution: Ubuntu 12.04, XUbuntu 12.04
Posts: 504

Original Poster
Rep: Reputation: 44
Actually, I spoke too soon. Today, it's refusing to go into Mint using the default selection at Grub, it only goes in using Recovery mode. Although it has not, yet, given me the "fixing recursive fault, but needs reboot" message.

I know that solving the overall problem of Mint hanging on boot is technically off-topic for the original request of this thread, but can you think of anything I could do with the Grub boot options that may permanently fix this problem? Or should I start a fresh thread requesting help with this problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Grub.cfg not booting Grub prompt will spiky0011 Linux From Scratch 6 11-02-2012 02:44 PM
Problem editing grub.cfg Vocay2 Linux Mint 4 10-11-2012 06:26 AM
permission for grub.cfg jone kim Linux - General 1 09-15-2010 01:53 PM
[SOLVED] Grub can't find grub.cfg when booting - error: no such device Breagha Linux - Software 8 03-14-2010 12:40 PM
editing GRUB question walid97 Linux - General 2 10-04-2002 01:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration